]> git.pld-linux.org Git - packages/crossppc64-gcc.git/blame - crossppc64-gcc.spec
- outdated
[packages/crossppc64-gcc.git] / crossppc64-gcc.spec
CommitLineData
e7576ad0 1Summary: Cross PPC64 GNU binary utility development utilities - gcc
942816f3
ER
2Summary(es.UTF-8): Utilitarios para desarrollo de binarios de la GNU - PPC64 gcc
3Summary(fr.UTF-8): Utilitaires de développement binaire de GNU - PPC64 gcc
4Summary(pl.UTF-8): Skrośne narzędzia programistyczne GNU dla PPC64 - gcc
5Summary(pt_BR.UTF-8): Utilitários para desenvolvimento de binários da GNU - PPC64 gcc
6Summary(tr.UTF-8): GNU geliştirme araçları - PPC64 gcc
e7576ad0 7Name: crossppc64-gcc
f1845026
PS
8Version: 4.1.1
9%define _snap 20060504r113515
413e076e 10Release: 0.%{_snap}.1
e7576ad0
PS
11Epoch: 1
12License: GPL
13Group: Development/Languages
413e076e 14#Source0: ftp://gcc.gnu.org/pub/gcc/releases/gcc-%{version}/gcc-%{version}.tar.bz2
f1845026
PS
15Source0: gcc-4.1-%{_snap}.tar.bz2
16# Source0-md5: 475abff96a6fb1f80ef69dded2f9ed2d
c90f1261 17Patch0: gcc-pr25672.patch
e7576ad0
PS
18URL: http://gcc.gnu.org/
19BuildRequires: autoconf
20BuildRequires: automake
21BuildRequires: bison
22BuildRequires: crossppc64-binutils
23BuildRequires: fileutils >= 4.0.41
24BuildRequires: flex
25BuildRequires: texinfo >= 4.1
26Requires: crossppc64-binutils
27Requires: gcc-dirs
28ExcludeArch: ppc64
29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31%define target ppc64-pld-linux
32%define arch %{_prefix}/%{target}
33%define gccarch %{_libdir}/gcc/%{target}
34%define gcclib %{gccarch}/%{version}
35
36%define _noautostrip .*/libgc.*\\.a
37
38%description
39This package contains a cross-gcc which allows the creation of
a7753d85 40binaries to be run on PPC64 Linux on other machines.
e7576ad0 41
71b2e7ee
JR
42%description -l de.UTF-8
43Dieses Paket enthält einen Cross-gcc, der es erlaubt, auf einem
44anderem Rechner Code für PPC64 Linux zu generieren.
e7576ad0 45
71b2e7ee
JR
46%description -l pl.UTF-8
47Ten pakiet zawiera skrośny gcc pozwalający na robienie na innych
48maszynach binariów do uruchamiania na Linuksie PPC64.
e7576ad0
PS
49
50%package c++
51Summary: C++ support for crossppc64-gcc
942816f3 52Summary(pl.UTF-8): Obsługa C++ dla crossppc64-gcc
e7576ad0
PS
53Group: Development/Languages
54Requires: %{name} = %{epoch}:%{version}-%{release}
55
56%description c++
57This package adds C++ support to the GNU Compiler Collection for
58PPC64.
59
71b2e7ee
JR
60%description c++ -l pl.UTF-8
61Ten pakiet dodaje obsługę C++ do kompilatora gcc dla PPC64.
e7576ad0
PS
62
63%prep
c90f1261 64#setup -q -n gcc-%{version}
f1845026 65%setup -q -n gcc-4_1-branch
e7576ad0
PS
66%patch0 -p1
67
68%build
e7576ad0
PS
69cp -f /usr/share/automake/config.* .
70rm -rf obj-%{target}
71install -d obj-%{target}
72cd obj-%{target}
73
74CFLAGS="%{rpmcflags}" \
75CXXFLAGS="%{rpmcflags}" \
76TEXCONFIG=false \
77../configure \
78 --prefix=%{_prefix} \
79 --infodir=%{_infodir} \
80 --mandir=%{_mandir} \
81 --bindir=%{_bindir} \
82 --libdir=%{_libdir} \
83 --libexecdir=%{_libdir} \
84 --disable-shared \
85 --disable-threads \
c90f1261 86 --without-headers \
e7576ad0
PS
87 --enable-languages="c,c++" \
88 --enable-c99 \
89 --enable-long-long \
90 --disable-nls \
91 --with-gnu-as \
92 --with-gnu-ld \
93 --with-demangler-in-ld \
94 --with-system-zlib \
95 --enable-multilib \
e7576ad0
PS
96 --without-x \
97 --target=%{target} \
98 --host=%{_target_platform} \
99 --build=%{_target_platform}
100
101%{__make} all-gcc
102
103%install
104rm -rf $RPM_BUILD_ROOT
105
106%{__make} -C obj-%{target} install-gcc \
107 DESTDIR=$RPM_BUILD_ROOT
108
109install obj-%{target}/gcc/specs $RPM_BUILD_ROOT%{gcclib}
110
111# don't want this here
112rm -f $RPM_BUILD_ROOT%{_libdir}/libiberty.a
113
114# include/ contains install-tools/include/* and headers that were fixed up
115# by fixincludes, we don't want former
116gccdir=$RPM_BUILD_ROOT%{gcclib}
117mkdir $gccdir/tmp
118# we have to save these however
119mv -f $gccdir/include/syslimits.h $gccdir/tmp
120rm -rf $gccdir/include
121mv -f $gccdir/tmp $gccdir/include
122cp -f $gccdir/install-tools/include/*.h $gccdir/include
123# but we don't want anything more from install-tools
124rm -rf $gccdir/install-tools
125
126%if 0%{!?debug:1}
17bf5536
PS
127%{target}-strip -g -R.note -R.comment $RPM_BUILD_ROOT%{gcclib}/libgcc.a
128%{target}-strip -g -R.note -R.comment $RPM_BUILD_ROOT%{gcclib}/libgcov.a
e7576ad0
PS
129%endif
130
131%clean
132rm -rf $RPM_BUILD_ROOT
133
134%files
135%defattr(644,root,root,755)
136%attr(755,root,root) %{_bindir}/%{target}-gcc
137%attr(755,root,root) %{_bindir}/%{target}-cpp
138%dir %{gccarch}
139%dir %{gcclib}
140%attr(755,root,root) %{gcclib}/cc1
141%attr(755,root,root) %{gcclib}/collect2
142%dir %{gcclib}/32
143%{gcclib}/32/crt*.o
144%{gcclib}/32/libgcc.a
145%{gcclib}/crt*.o
146%{gcclib}/libgcc.a
147%{gcclib}/specs*
148%dir %{gcclib}/include
149%{gcclib}/include/*.h
150%{_mandir}/man1/%{target}-cpp.1*
151%{_mandir}/man1/%{target}-gcc.1*
152
153%files c++
154%defattr(644,root,root,755)
155%attr(755,root,root) %{_bindir}/%{target}-g++
156%attr(755,root,root) %{gcclib}/cc1plus
157%{_mandir}/man1/%{target}-g++.1*
This page took 0.082614 seconds and 4 git commands to generate.