]> git.pld-linux.org Git - packages/crossppc-gcc.git/commitdiff
- enable .so build/install.
authorPaweł Sikora <pluto@pld-linux.org>
Thu, 6 Mar 2008 14:38:44 +0000 (14:38 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    gcc-enable-java-awt-qt.patch -> 1.8

gcc-enable-java-awt-qt.patch

index e9d3df24a8e851de1b14c9a8626c43579d44c95c..e8afb6d8337bbce4b427623b69cd1d682e28d949 100644 (file)
@@ -1,4 +1,4 @@
---- trunk/libjava/classpath/configure.ac.orig  2006-07-02 15:32:04.000000000 +0200
+--- trunk/libjava/classpath/configure.ac       2006-07-02 15:32:04.000000000 +0200
 +++ trunk/libjava/classpath/configure.ac       2006-07-02 19:18:28.913906000 +0200
 @@ -502,7 +502,8 @@
        AC_CHECK_FILE([$EXTRA_QT_INCLUDE_DIR/QWidget],
        AC_CHECK_PROG(MOC, [moc-qt4], [moc-qt4])
      fi
      if test "x$HAVE_QT4" = "xno"; then
+--- trunk/libjava/classpath/native/jni/qt-peer/Makefile.am     2007-06-03 23:18:43.000000000 +0000
++++ trunk/libjava/classpath/native/jni/qt-peer/Makefile.am     2008-03-04 20:41:55.000000000 +0000
+@@ -64,7 +64,8 @@
+ mkinstalldirs = $(SHELL) $(top_srcdir)/../../mkinstalldirs
+ CONFIG_HEADER = $(top_builddir)/include/config.h
+ CONFIG_CLEAN_FILES =
+-LTLIBRARIES = $(noinst_LTLIBRARIES)
++nativeexeclibLTLIBRARIES_INSTALL = $(INSTALL)
++LTLIBRARIES = $(nativeexeclib_LTLIBRARIES)
+ libqtpeer_la_LIBADD =
+ am_libqtpeer_la_OBJECTS = componentevent.lo keybindings.lo \
+       mainqtthread.lo mainthreadinterface.lo nativewrapper.lo \
+@@ -357,7 +358,7 @@
+ target_vendor = @target_vendor@
+ toolexeclibdir = @toolexeclibdir@
+ vm_classes = @vm_classes@
+-noinst_LTLIBRARIES = libqtpeer.la
++nativeexeclib_LTLIBRARIES = libqtpeer.la
+ AM_LDFLAGS = @CLASSPATH_MODULE@ @QT_LIBS@
+ AM_CPPFLAGS = @CLASSPATH_INCLUDES@
+ AM_CXXFLAGS = @QT_CFLAGS@ \
+@@ -475,7 +476,7 @@
+         rm -f "$${dir}/so_locations"; \
+       done
+ libqtpeer.la: $(libqtpeer_la_OBJECTS) $(libqtpeer_la_DEPENDENCIES) 
+-      $(CXXLINK)  $(libqtpeer_la_LDFLAGS) $(libqtpeer_la_OBJECTS) $(libqtpeer_la_LIBADD) $(LIBS)
++      $(LINK) -rpath $(nativeexeclibdir) $(libqtpeer_la_LDFLAGS) $(libqtpeer_la_OBJECTS) $(libqtpeer_la_LIBADD) $(LIBS)
+ mostlyclean-compile:
+       -rm -f *.$(OBJEXT)
+@@ -686,7 +687,18 @@
+ install-data-am:
+-install-exec-am:
++install-nativeexeclibLTLIBRARIES: $(nativeexeclib_LTLIBRARIES)
++      @$(NORMAL_INSTALL)
++      test -z "$(nativeexeclibdir)" || $(mkdir_p) "$(DESTDIR)$(nativeexeclibdir)"
++      @list='$(nativeexeclib_LTLIBRARIES)'; for p in $$list; do \
++        if test -f $$p; then \
++          f=$(am__strip_dir) \
++          echo " $(LIBTOOL) --mode=install $(nativeexeclibLTLIBRARIES_INSTALL) $(INSTALL_STRIP_FLAG) '$$p' '$(DESTDIR)$(nativeexeclibdir)/$$f'"; \
++          $(LIBTOOL) --mode=install $(nativeexeclibLTLIBRARIES_INSTALL) $(INSTALL_STRIP_FLAG) "$$p" "$(DESTDIR)$(nativeexeclibdir)/$$f"; \
++        else :; fi; \
++      done
++
++install-exec-am: install-nativeexeclibLTLIBRARIES
+ install-info: install-info-am
+@@ -720,6 +732,7 @@
+       distclean-tags distdir dvi dvi-am html html-am info info-am \
+       install install-am install-data install-data-am install-exec \
+       install-exec-am install-info install-info-am install-man \
++      install-nativeexeclibLTLIBRARIES \
+       install-strip installcheck installcheck-am installdirs \
+       maintainer-clean maintainer-clean-generic mostlyclean \
+       mostlyclean-compile mostlyclean-generic mostlyclean-libtool \
This page took 0.072845 seconds and 4 git commands to generate.