]> git.pld-linux.org Git - packages/crossppc-gcc.git/commitdiff
- link gnat tools with shared libgcc. auto/th/gcc-4_1_0-0_20051126r107546_1 auto/th/gcc-4_1_0-0_20051126r107546_2 auto/th/gcc-4_1_0-0_20051130r107724_1
authorPaweł Sikora <pluto@pld-linux.org>
Sat, 26 Nov 2005 23:50:10 +0000 (23:50 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    gcc-ada-link.patch -> 1.7

gcc-ada-link.patch

index 63d4aa5bc1aba241eab3dc7a7e46769a10217f45..658cc1a7142ebd79b5a7936e7c7f276ecb93ec20 100644 (file)
@@ -24,7 +24,7 @@
  shext  =
  hyphen = -
  
-@@ -1367,6 +1367,31 @@
+@@ -1180,6 +1180,31 @@
    LIBRARY_VERSION := $(LIB_VERSION)
  endif
  
@@ -56,7 +56,7 @@
  ifeq ($(strip $(filter-out hppa% linux%,$(arch) $(osys))),)
    LIBGNAT_TARGET_PAIRS = \
    a-intnam.ads<a-intnam-linux.ads \
-@@ -1468,6 +1493,31 @@
+@@ -1287,6 +1312,31 @@
    LIBRARY_VERSION := $(LIB_VERSION)
  endif
  
  ifeq ($(strip $(filter-out powerpc darwin%,$(arch) $(osys))),)
    LIBGNAT_TARGET_PAIRS = \
    a-intnam.ads<a-intnam-darwin.ads \
-@@ -1763,6 +1813,9 @@
- GCC_FOR_TARGET=./xgcc -B./ $(FLAGS_FOR_TARGET)
+@@ -1364,7 +1414,7 @@
+  s-[a-o]*.adb s-[p-z]*.adb s-[a-o]*.ads s-[p-z]*.ads  
  
- gnatlib: ../stamp-gnatlib1 ../stamp-gnatlib2
-+      $(RMDIR) save
-+      $(MKDIR) save
-+      $(MV) *.o save/
-       $(MAKE) -C rts \
-               CC="`echo \"$(GCC_FOR_TARGET)\" \
-               | sed -e 's^./xgcc^../../xgcc^' -e 's^-B./^-B../../^'`" \
-@@ -1779,6 +1832,8 @@
-               srcdir=$(fsrcdir) \
-               -f ../Makefile \
-               $(GNATRTL_OBJS)
-+      $(MV) save/*.o .
-+      $(RMDIR) save
-       $(RM) rts/libgnat$(arext) rts/libgnarl$(arext)
-       $(AR) $(AR_FLAGS) rts/libgnat$(arext) \
-          $(addprefix rts/,$(GNATRTL_NONTASKING_OBJS) $(LIBGNAT_OBJS))
-@@ -1816,7 +1871,8 @@
+ LIBGNAT=../rts/libgnat.a 
+-GCC_LINK="$(CC) -static-libgcc $(ADA_INCLUDES)"
++GCC_LINK="$(CC) $(ADA_INCLUDES)"
+ # when compiling the tools, the runtime has to be first on the path so that
+ # it hides the runtime files lying with the rest of the sources
+@@ -1644,7 +1694,8 @@
                -o libgnarl$(hyphen)$(LIBRARY_VERSION)$(soext) \
                $(GNATRTL_TASKING_OBJS) \
                $(SO_OPTS)libgnarl$(hyphen)$(LIBRARY_VERSION)$(soext) \
        cd rts; $(LN_S) libgnat$(hyphen)$(LIBRARY_VERSION)$(soext) \
                libgnat$(soext)
        cd rts; $(LN_S) libgnarl$(hyphen)$(LIBRARY_VERSION)$(soext) \
-@@ -1863,7 +1919,7 @@
+@@ -1691,7 +1742,7 @@
             THREAD_KIND="$(THREAD_KIND)" \
               gnatlib
        $(RM) rts/libgna*$(soext)
This page took 0.087309 seconds and 4 git commands to generate.