]> git.pld-linux.org Git - packages/crossppc-gcc.git/blobdiff - gcc-nodebug.patch
- drop obsolete files
[packages/crossppc-gcc.git] / gcc-nodebug.patch
index 545d84971f7483be8e46edd4d39120d4e1602ea3..987fe4715b743e1fb05f6ee9270c446fac6af4b5 100644 (file)
@@ -1,20 +1,17 @@
---- gcc-4.1-20050522/gcc/Makefile.in.orig      2005-05-20 21:17:40.000000000 +0000
-+++ gcc-4.1-20050522/gcc/Makefile.in   2005-05-26 10:49:01.000000000 +0000
-@@ -148,10 +148,10 @@
- # TCFLAGS is used for compilations with the GCC just built.
- XCFLAGS =
- TCFLAGS =
--CFLAGS = -g
--STAGE1_CFLAGS = -g @stage1_cflags@
-+CFLAGS =
-+STAGE1_CFLAGS = @stage1_cflags@
- STAGE1_CHECKING = -DENABLE_CHECKING -DENABLE_ASSERT_CHECKING
--BOOT_CFLAGS = -g -O2
-+BOOT_CFLAGS = -O2
+--- a/Makefile.in      2006-07-02 15:31:20.000000000 +0200
++++ b/Makefile.in      2006-07-02 20:55:33.573762250 +0200
+@@ -274,7 +274,7 @@
  
- # Flags to determine code coverage. When coverage is disabled, this will
- # contain the optimization flags, as you normally want code coverage
-@@ -520,7 +520,7 @@
+ # Flags to pass to stage2 and later makes.  They are defined
+ # here so that they can be overridden by Makefile fragments.
+-BOOT_CFLAGS= -g -O2
++BOOT_CFLAGS= -O2
+ BOOT_LDFLAGS=
+ BISON = @BISON@
+--- a/gcc/Makefile.in  2008-02-25 15:53:34.000000000 +0100
++++ b/gcc/Makefile.in  2008-03-03 16:42:29.000000000 +0100
+@@ -560,7 +560,7 @@
  
  # Options to use when compiling libgcc2.a.
  #
 +LIBGCC2_DEBUG_CFLAGS =
  LIBGCC2_CFLAGS = -O2 $(LIBGCC2_INCLUDES) $(GCC_CFLAGS) $(TARGET_LIBGCC2_CFLAGS) \
                 $(LIBGCC2_DEBUG_CFLAGS) $(GTHREAD_FLAGS) \
-                -DIN_LIBGCC2 -D__GCC_FLOAT_NOT_NEEDED @inhibit_libc@
---- gcc-4.0-20040919/gcc/ada/Makefile.in.orig  2004-09-13 12:18:40.000000000 +0200
-+++ gcc-4.0-20040919/gcc/ada/Makefile.in       2004-09-26 11:40:30.070894416 +0200
-@@ -73,7 +73,7 @@
+                -DIN_LIBGCC2 -D__GCC_FLOAT_NOT_NEEDED \
+--- a/gcc/ada/gcc-interface/Makefile.in        2004-09-13 12:18:40.000000000 +0200
++++ b/gcc/ada/gcc-interface/Makefile.in        2004-09-26 11:40:30.070894416 +0200
+@@ -66,7 +66,7 @@
+ # CFLAGS is for the user to override to, e.g., do a bootstrap with -O2.
+ # BOOT_CFLAGS is the value of CFLAGS to pass
  # to the stage2 and stage3 compilations
- # XCFLAGS is used for most compilations but not when using the GCC just built.
- XCFLAGS =
 -CFLAGS = -g
 +CFLAGS =
  BOOT_CFLAGS = -O $(CFLAGS)
- # These exists to be overridden by the x-* and t-* files, respectively.
X_CFLAGS =
-@@ -118,9 +118,9 @@
+ # These exists to be overridden by the t-* files, respectively.
T_CFLAGS =
+@@ -102,9 +102,9 @@
  ADA_CFLAGS =
  ADAFLAGS = -W -Wall -gnatpg -gnata
  SOME_ADAFLAGS =-gnata
 +GNATLIBCFLAGS = -O2
  GNATLIBCFLAGS_FOR_C = $(GNATLIBCFLAGS) $(TARGET_LIBGCC2_CFLAGS) -fexceptions \
        -DIN_RTS
- ALL_ADA_CFLAGS = $(X_ADA_CFLAGS) $(T_ADA_CFLAGS) $(ADA_CFLAGS)
---- gcc/libada/Makefile.in.orig        2005-11-04 13:49:08.000000000 +0000
-+++ gcc/libada/Makefile.in     2005-11-24 23:52:14.739531296 +0000
-@@ -54,7 +54,6 @@
- include $(GCC_DIR)/libada-mk
+ ALL_ADAFLAGS = $(CFLAGS) $(ADA_CFLAGS) $(ADAFLAGS)
+--- a/libada/Makefile.in       2005-11-04 13:49:08.000000000 +0000
++++ b/libada/Makefile.in       2005-11-24 23:52:14.739531296 +0000
+@@ -49,13 +49,13 @@
+ LDFLAGS=
+ # The tedious process of getting CFLAGS right.
+-CFLAGS=-g
++CFLAGS=
+ LOOSE_WARN = -W -Wall -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes
+ GCC_WARN_CFLAGS = $(LOOSE_WARN)
+ WARN_CFLAGS = @warn_cflags@
  
  TARGET_LIBGCC2_CFLAGS=
 -GNATLIBCFLAGS= -g -O2
- # Get target-specific overrides for TARGET_LIBGCC2_CFLAGS
- # and possibly GNATLIBCFLAGS.  Currently this uses files
- # in gcc/config.  The 'subst' call is used to rerelativize them
---- gcc-4.0-20040919/libffi/Makefile.am.orig   2004-08-30 17:42:59.000000000 +0200
-+++ gcc-4.0-20040919/libffi/Makefile.am        2004-09-26 11:44:10.789340112 +0200
-@@ -138,7 +138,7 @@
++GNATLIBCFLAGS= -O2
+ # Get target-specific overrides for TARGET_LIBGCC2_CFLAGS.
+ host_subdir = @host_subdir@
+--- a/libffi/Makefile.in       2004-08-30 17:42:59.000000000 +0200
++++ b/libffi/Makefile.in       2004-09-26 11:44:10.789340112 +0200
+@@ -453,7 +453,7 @@
+       $(am__append_21) $(am__append_22)
  libffi_convenience_la_SOURCES = $(libffi_la_SOURCES)
  nodist_libffi_convenience_la_SOURCES = $(nodist_libffi_la_SOURCES)
 -AM_CFLAGS = -Wall -g -fexceptions
 +AM_CFLAGS = -Wall -fexceptions
- libffi_la_LDFLAGS = -version-info `grep -v '^\#' $(srcdir)/libtool-version`
---- gcc-4.0-20040919/libffi/Makefile.in.orig   2004-09-19 19:47:04.000000000 +0200
-+++ gcc-4.0-20040919/libffi/Makefile.in        2004-09-26 11:44:17.253357432 +0200
-@@ -385,7 +385,7 @@
- nodist_libffi_la_SOURCES = $(am__append_1) $(am__append_2) $(am__append_3) $(am__append_4) $(am__append_5) $(am__append_6) $(am__append_7) $(am__append_8) $(am__append_9) $(am__append_10) $(am__append_11) $(am__append_12) $(am__append_13) $(am__append_14) $(am__append_15) $(am__append_16) $(am__append_17) $(am__append_18)
+ LTLDFLAGS = $(shell $(SHELL) $(top_srcdir)/../libtool-ldflags $(LDFLAGS))
+ libffi_la_LDFLAGS = -version-info `grep -v '^\#' $(srcdir)/libtool-version` $(LTLDFLAGS)
+ AM_CPPFLAGS = -I. -I$(top_srcdir)/include -Iinclude -I$(top_srcdir)/src
+--- a/libffi/Makefile.am       2008-05-09 12:10:53.000000000 +0200
++++ b/libffi/Makefile.am       2008-11-28 02:02:01.690063811 +0100
+@@ -154,7 +154,7 @@
  libffi_convenience_la_SOURCES = $(libffi_la_SOURCES)
  nodist_libffi_convenience_la_SOURCES = $(nodist_libffi_la_SOURCES)
 -AM_CFLAGS = -Wall -g -fexceptions
 +AM_CFLAGS = -Wall -fexceptions
- libffi_la_LDFLAGS = -version-info `grep -v '^\#' $(srcdir)/libtool-version`
- AM_CPPFLAGS = -I. -I$(top_srcdir)/include -Iinclude -I$(top_srcdir)/src
- AM_CCASFLAGS = $(AM_CPPFLAGS)
---- gcc-4.0-20040919/libjava/Makefile.am.orig  2004-09-10 10:22:58.000000000 +0200
-+++ gcc-4.0-20040919/libjava/Makefile.am       2004-09-26 11:46:24.041082768 +0200
+ LTLDFLAGS = $(shell $(SHELL) $(top_srcdir)/../libtool-ldflags $(LDFLAGS))
+--- a/libjava/Makefile.am      2004-09-10 10:22:58.000000000 +0200
++++ b/libjava/Makefile.am      2004-09-26 11:46:24.041082768 +0200
 @@ -179,7 +179,7 @@
  ## Extra CFLAGS used for JNI C sources shared with GNU Classpath.
  PEDANTIC_CFLAGS = -ansi -pedantic -Wall -Wno-long-long
@@ -89,8 +94,8 @@
  JC1FLAGS = @LIBGCJ_JAVAFLAGS@ $(GCJFLAGS)
  
  LIBFFIINCS = @LIBFFIINCS@
---- gcc-4.0-20040919/libjava/Makefile.in.orig  2004-09-19 19:47:04.000000000 +0200
-+++ gcc-4.0-20040919/libjava/Makefile.in       2004-09-26 11:47:02.431246576 +0200
+--- a/libjava/Makefile.in      2004-09-19 19:47:04.000000000 +0200
++++ b/libjava/Makefile.in      2004-09-26 11:47:02.431246576 +0200
 @@ -4167,7 +4167,7 @@
  @USING_GCC_FALSE@AM_CFLAGS = @LIBGCJ_CFLAGS@
  @USING_GCC_TRUE@AM_CFLAGS = @LIBGCJ_CFLAGS@ $(WARNINGS)
This page took 0.0682 seconds and 4 git commands to generate.