]> git.pld-linux.org Git - packages/crossppc-binutils.git/commitdiff
- updated for 2.17.50.0.3 auto/th/binutils-2_17_50_0_3-1 auto/th/crossmipsel-binutils-2_17_50_0_3-1 auto/th/crossmipsel-binutils-2_19_50_0_1-1
authorJakub Bogusz <qboosh@pld-linux.org>
Mon, 17 Jul 2006 09:04:58 +0000 (09:04 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    binutils-gasp.patch -> 1.12
    binutils-mips-relocs.patch -> 1.5
    binutils-pt_pax_flags.patch -> 1.7

binutils-gasp.patch
binutils-mips-relocs.patch
binutils-pt_pax_flags.patch

index 5e2ef091ee36ab04e8fff3f14d7cfead42d6ed22..66e2403b8279bd553b4d12c75af9d8fe47413920 100644 (file)
@@ -1,7 +1,6 @@
-diff -urNbB binutils-2.16.91.0.2.org/gas/Makefile.am binutils-2.16.91.0.2/gas/Makefile.am
---- binutils-2.16.91.0.2.org/gas/Makefile.am   2005-07-20 19:27:27.000000000 +0000
-+++ binutils-2.16.91.0.2/gas/Makefile.am       2005-07-21 18:35:02.000000000 +0000
-@@ -204,7 +204,7 @@
+--- binutils-2.17.50.0.3/gas/Makefile.am.orig  2006-07-15 20:23:50.000000000 +0200
++++ binutils-2.17.50.0.3/gas/Makefile.am       2006-07-17 10:44:29.524440000 +0200
+@@ -192,7 +192,7 @@
        symbols.c \
        write.c
  
@@ -10,7 +9,7 @@ diff -urNbB binutils-2.16.91.0.2.org/gas/Makefile.am binutils-2.16.91.0.2/gas/Ma
  
  HFILES = \
        as.h \
-@@ -466,7 +466,8 @@
+@@ -441,7 +441,8 @@
  
  # Note: GASP is now deprecated and has been removed.  It is still
  # available in the CVS archive or older binutils releases if it is needed.
@@ -20,7 +19,7 @@ diff -urNbB binutils-2.16.91.0.2.org/gas/Makefile.am binutils-2.16.91.0.2/gas/Ma
  noinst_SCRIPTS = $(GDBINIT)
  EXTRA_SCRIPTS = .gdbinit
  
-@@ -530,6 +531,10 @@
+@@ -498,6 +499,10 @@
        as.h asintl.h bignum.h bit_fix.h config.h emul.h expr.h flonum.h \
        frags.h hash.h listing.h obj.h read.h symbols.h tc.h write.h
  
@@ -31,15 +30,15 @@ diff -urNbB binutils-2.16.91.0.2.org/gas/Makefile.am binutils-2.16.91.0.2/gas/Ma
  EXPECT = expect
  RUNTEST = runtest
  RUNTESTFLAGS=
-@@ -2508,6 +2513,8 @@
-   $(INCDIR)/obstack.h subsegs.h struc-symbol.h
- write.o: write.c $(INCDIR)/symcat.h subsegs.h $(INCDIR)/obstack.h \
-   output-file.h dwarf2dbg.h
+@@ -2048,6 +2053,8 @@
+   subsegs.h struc-symbol.h
+ write.o: write.c subsegs.h $(INCDIR)/obstack.h output-file.h \
+   dwarf2dbg.h
 +gasp.o: gasp.c $(INCDIR)/getopt.h $(INCDIR)/safe-ctype.h \
 +  sb.h macro.h $(INCDIR)/xregex.h $(INCDIR)/xregex2.h
- itbl-ops.o: itbl-ops.c itbl-ops.h $(INCDIR)/symcat.h
- e-crisaout.o: $(srcdir)/config/e-crisaout.c $(INCDIR)/symcat.h \
  emul-target.h
+ itbl-ops.o: itbl-ops.c itbl-ops.h
+ e-crisaout.o: $(srcdir)/config/e-crisaout.c emul-target.h
e-criself.o: $(srcdir)/config/e-criself.c emul-target.h
 diff -urNbB binutils-2.16.91.0.2.org/gas/doc/Makefile.am binutils-2.16.91.0.2/gas/doc/Makefile.am
 --- binutils-2.16.91.0.2.org/gas/doc/Makefile.am       2005-07-20 19:27:27.000000000 +0000
 +++ binutils-2.16.91.0.2/gas/doc/Makefile.am   2005-07-21 18:31:04.000000000 +0000
index e7674b0f3fa1d0094e273ef775b38ed96c56681a..b172d29c79a59ac36e346756d4a89682e5e907eb 100644 (file)
@@ -101,18 +101,18 @@ diff -u -r1.2114 ChangeLog
 +      (tc_gen_reloc): Put back pc rel handling.
 +      * config/tc-mips.h: Defines DIFF_EXPR_OK.
 +
---- gas/config/tc-mips.c.orig  2005-12-20 23:43:56.000000000 +0100
-+++ gas/config/tc-mips.c       2005-12-21 22:47:56.000000000 +0100
-@@ -11401,8 +11401,6 @@
+--- gas/config/tc-mips.c.orig  2006-07-15 20:23:51.000000000 +0200
++++ gas/config/tc-mips.c       2006-07-17 10:51:06.164440000 +0200
+@@ -11736,8 +11736,6 @@
  
    buf = (bfd_byte *) (fixP->fx_frag->fr_literal + fixP->fx_where);
  
--  assert (! fixP->fx_pcrel || fixP->fx_r_type == BFD_RELOC_16_PCREL_S2);
+-  assert (!fixP->fx_pcrel || fixP->fx_r_type == BFD_RELOC_16_PCREL_S2);
 -
    /* Don't treat parts of a composite relocation as done.  There are two
       reasons for this:
  
-@@ -13247,8 +13245,6 @@
+@@ -13562,8 +13560,6 @@
  
    if (fixp->fx_pcrel)
      {
@@ -121,7 +121,7 @@ diff -u -r1.2114 ChangeLog
        /* At this point, fx_addnumber is "symbol offset - pcrel address".
         Relocations want only the symbol offset.  */
        reloc->addend = fixp->fx_addnumber + reloc->address;
-@@ -13273,6 +13269,34 @@
+@@ -13588,6 +13584,34 @@
      }
  
    code = fixp->fx_r_type;
index df2c7640744a80e46d5024a89569ba414f6af959..500c5fa4e2c7ea653fba12c7890dfb015b521915 100644 (file)
@@ -11,9 +11,9 @@ diff -uNr binutils-2.15.94.0.2.2.orig/bfd/elf-bfd.h binutils-2.15.94.0.2.2/bfd/e
    /* Symbol version definitions in external objects.  */
    Elf_Internal_Verdef *verdef;
  
---- binutils-2.16.91.0.7/bfd/elf.c.orig        2006-03-18 02:13:54.000000000 +0100
-+++ binutils-2.16.91.0.7/bfd/elf.c     2006-03-21 20:15:01.658432000 +0100
-@@ -1085,6 +1085,7 @@
+--- binutils-2.17.50.0.3/bfd/elf.c.orig        2006-07-15 20:23:49.000000000 +0200
++++ binutils-2.17.50.0.3/bfd/elf.c     2006-07-17 10:47:54.374440000 +0200
+@@ -1101,6 +1101,7 @@
      case PT_GNU_EH_FRAME: pt = "EH_FRAME"; break;
      case PT_GNU_STACK: pt = "STACK"; break;
      case PT_GNU_RELRO: pt = "RELRO"; break;
@@ -21,7 +21,7 @@ diff -uNr binutils-2.15.94.0.2.2.orig/bfd/elf-bfd.h binutils-2.15.94.0.2.2/bfd/e
      default: pt = NULL; break;
      }
    return pt;
-@@ -2606,6 +2607,9 @@
+@@ -2662,6 +2663,9 @@
      case PT_GNU_RELRO:
        return _bfd_elf_make_section_from_phdr (abfd, hdr, index, "relro");
  
@@ -31,28 +31,7 @@ diff -uNr binutils-2.15.94.0.2.2.orig/bfd/elf-bfd.h binutils-2.15.94.0.2.2/bfd/e
      default:
        /* Check for any processor-specific program segment types.  */
        bed = get_elf_backend_data (abfd);
-@@ -3933,6 +3937,20 @@
-       pm = &m->next;
-     }
-+    {
-+      amt = sizeof (struct elf_segment_map);
-+      m = bfd_zalloc (abfd, amt);
-+      if (m == NULL)
-+      goto error_return;
-+      m->next = NULL;
-+      m->p_type = PT_PAX_FLAGS;
-+      m->p_flags = elf_tdata (abfd)->pax_flags;
-+      m->p_flags_valid = 1;
-+
-+      *pm = m;
-+      pm = &m->next;
-+    }
-+
-   free (sections);
-   sections = NULL;
-@@ -4665,6 +4683,11 @@
+@@ -3633,6 +3637,11 @@
        ++segs;
      }
  
@@ -64,7 +43,28 @@ diff -uNr binutils-2.15.94.0.2.2.orig/bfd/elf-bfd.h binutils-2.15.94.0.2.2/bfd/e
    for (s = abfd->sections; s != NULL; s = s->next)
      {
        if ((s->flags & SEC_LOAD) != 0
-@@ -5181,7 +5204,8 @@
+@@ -4116,6 +4125,20 @@
+         pm = &m->next;
+       }
++      {
++        amt = sizeof (struct elf_segment_map);
++        m = bfd_zalloc (abfd, amt);
++        if (m == NULL)
++      goto error_return;
++        m->next = NULL;
++        m->p_type = PT_PAX_FLAGS;
++        m->p_flags = elf_tdata (abfd)->pax_flags;
++        m->p_flags_valid = 1;
++  
++        *pm = m;
++        pm = &m->next;
++      }
++
+       free (sections);
+       elf_tdata (abfd)->segment_map = mfirst;
+     }
+@@ -5228,7 +5251,8 @@
         5. PT_GNU_STACK segments do not include any sections.
         6. PT_TLS segment includes only SHF_TLS sections.
         7. SHF_TLS sections are only in PT_TLS or PT_LOAD segments.
@@ -74,7 +74,7 @@ diff -uNr binutils-2.15.94.0.2.2.orig/bfd/elf-bfd.h binutils-2.15.94.0.2.2/bfd/e
            (with the possible exception of .dynamic).  */
  #define INCLUDE_SECTION_IN_SEGMENT(section, segment, bed)             \
    ((((segment->p_paddr                                                        \
-@@ -5191,6 +5215,7 @@
+@@ -5238,6 +5262,7 @@
      || IS_COREFILE_NOTE (segment, section))                           \
     && section->output_section != NULL                                 \
     && segment->p_type != PT_GNU_STACK                                 \
This page took 0.07109 seconds and 4 git commands to generate.