]> git.pld-linux.org Git - packages/crossppc-binutils.git/blob - crossppc-binutils.spec
- updated gettext BR
[packages/crossppc-binutils.git] / crossppc-binutils.spec
1 #
2
3 Summary:        Cross PPC GNU binary utility development utilities - binutils
4 Summary(es.UTF-8):      Utilitarios para desarrollo de binarios de la GNU - PPC binutils
5 Summary(fr.UTF-8):      Utilitaires de développement binaire de GNU - PPC binutils
6 Summary(pl.UTF-8):      Skrośne narzędzia programistyczne GNU dla PPC - binutils
7 Summary(pt_BR.UTF-8):   Utilitários para desenvolvimento de binários da GNU - PPC binutils
8 Summary(tr.UTF-8):      GNU geliştirme araçları - PPC binutils
9 Name:           crossppc-binutils
10 Version:        2.20.51.0.3
11 Release:        1
12 License:        GPL v3+
13 Group:          Development/Tools
14 Source0:        ftp://ftp.kernel.org/pub/linux/devel/binutils/binutils-%{version}.tar.bz2
15 # Source0-md5:  4d5cdcfa054e697ba92a37f55b125080
16 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/binutils-non-english-man-pages.tar.bz2
17 # Source1-md5:  a717d9707ec77d82acb6ec9078c472d6
18 Patch0:         binutils-gasp.patch
19 Patch1:         binutils-info.patch
20 Patch2:         binutils-libtool-relink.patch
21 Patch3:         binutils-pt_pax_flags.patch
22 Patch5:         binutils-flex.patch
23 Patch6:         binutils-discarded.patch
24 Patch7:         binutils-absolute-gnu_debuglink-path.patch
25 Patch8:         binutils-libtool-m.patch
26 Patch9:         binutils-build-id.patch
27 Patch10:        binutils-tooldir.patch
28 URL:            http://sources.redhat.com/binutils/
29 BuildRequires:  autoconf >= 2.64
30 BuildRequires:  automake >= 1:1.11
31 BuildRequires:  bison
32 BuildRequires:  flex
33 BuildRequires:  gettext-tools
34 BuildRequires:  libstdc++-devel >= 6:4.0-1
35 BuildRequires:  perl-tools-pod
36 %ifarch sparc sparc32
37 BuildRequires:  sparc32
38 %endif
39 BuildRequires:  texinfo >= 4.2
40 Conflicts:      gcc-c++ < 5:3.3
41 ExcludeArch:    ppc
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %define         target          ppc-pld-linux
45 %define         arch            %{_prefix}/%{target}
46
47 %description
48 Binutils is a collection of binary utilities, including:
49 - ar - create, modify and extract from archives,
50 - nm - lists symbols from object files,
51 - objcopy - copy and translate object files,
52 - objdump - display information from object files,
53 - ranlib - generate an index for the contents of an archive,
54 - size - list the section sizes of an object or archive file,
55 - strings - list printable strings from files,
56 - strip - discard symbols,
57 - c++filt - a filter for demangling encoded C++ symbols,
58 - addr2line - convert addresses to file and line,
59 - nlmconv - convert object code into an NLM.
60
61 This package contains the cross version for PPC.
62
63 %description -l pl.UTF-8
64 Pakiet binutils zawiera zestaw narzędzi umożliwiających kompilację
65 programów. Znajdują się tutaj między innymi assembler, konsolidator
66 (linker), a także inne narzędzia do manipulowania binarnymi plikami
67 programów i bibliotek.
68
69 Ten pakiet zawiera wersję skrośną generującą kod dla PPC.
70
71 %prep
72 %setup -q -n binutils-%{version}
73 %patch0 -p1
74 %patch1 -p1
75 %patch2 -p1
76 %{?with_pax:%patch3 -p1}
77 %patch5 -p1
78 %patch6 -p1
79 %patch7 -p1
80 %patch8 -p1
81 %patch9 -p1
82 %patch10 -p1
83
84 # file contains hacks for ac 2.59 only
85 rm config/override.m4
86
87 %build
88 %{__aclocal}
89 %{__autoconf}
90
91 # non-standard regeneration (needed because of gasp patch)
92 # AM_BINUTILS_WARNINGS in bfd/warning.m4, ZW_GNU_GETTEXT_SISTER_DIR in config/gettext-sister.m4
93 for dir in gas bfd; do
94         cd $dir || exit 1
95         %{__aclocal} -I .. -I ../config -I ../bfd
96         %{__automake} Makefile
97         %{__automake} doc/Makefile
98         %{__autoconf}
99         cd ..
100 done
101
102 cp -f /usr/share/automake/config.* .
103
104 CFLAGS="%{rpmcflags}"; export CFLAGS
105 CC="%{__cc}"; export CC
106 %ifarch sparc
107 sparc32 \
108 %endif
109 ./configure %{_target_platform} \
110         --disable-debug \
111         --disable-werror \
112         --enable-build-warnings=,-Wno-missing-prototypes \
113         --disable-shared \
114         --disable-nls \
115         --prefix=%{_prefix} \
116         --libdir=%{_libdir} \
117         --infodir=%{_infodir} \
118         --mandir=%{_mandir} \
119         --with-tooldir=%{arch} \
120         --enable-gold=both \
121         --target=%{target}
122
123 %{__make}
124
125 %install
126 rm -rf $RPM_BUILD_ROOT
127 install -d $RPM_BUILD_ROOT%{_prefix}
128
129 %{__make} install \
130         DESTDIR=$RPM_BUILD_ROOT
131
132 rm $RPM_BUILD_ROOT%{_infodir}/standards.info*
133
134 # remove these man pages unless we cross-build for win*/netware platforms.
135 # however, this should be done in Makefiles.
136 rm $RPM_BUILD_ROOT%{_mandir}/man1/{*dlltool,*nlmconv,*windres}.1
137
138 %clean
139 rm -rf $RPM_BUILD_ROOT
140
141 %files
142 %defattr(644,root,root,755)
143 %doc README
144 %attr(755,root,root) %{_bindir}/%{target}-*
145 %dir %{arch}
146 %dir %{arch}/bin
147 %attr(755,root,root) %{arch}/bin/*
148 %dir %{arch}/lib
149 %{arch}/lib/ldscripts
150 %{_mandir}/man?/%{target}-*
This page took 0.083967 seconds and 3 git commands to generate.