]> git.pld-linux.org Git - packages/crossnacl-newlib.git/commitdiff
up to git 67e3510, nacl-headers-21.0.1180.57 auto/th/crossnacl-newlib-1.20.0-1.git67e3510
authorElan Ruusamäe <glen@delfi.ee>
Wed, 1 Aug 2012 17:13:40 +0000 (20:13 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Wed, 1 Aug 2012 17:13:40 +0000 (20:13 +0300)
sqrt from llvm if enabled, some test syscalls added, pthread.h update
from chrome source

crossnacl-newlib.spec
get-source.sh [changed mode: 0644->0755]
pthread.h

index 425a4ca102d03ae642cdc13652ce6b0c78fe78e2..65c36c3ce30cf97b8b725d1397184fb74a65723b 100644 (file)
@@ -1,14 +1,14 @@
-%define                gitver 096a72b
+%define                gitver 67e3510
 Summary:       C library intended for use on embedded systems
 Name:          crossnacl-newlib
 Version:       1.20.0
-Release:       0.git%{gitver}
+Release:       1.git%{gitver}
 License:       BSD and MIT and LGPL v2+
 Group:         Libraries
 Source0:       nacl-newlib-%{version}-git%{gitver}.tar.bz2
-# Source0-md5: f91294ce67825ccef1f853094abc42ca
-Source1:       nacl-headers-20.0.1132.47.tar.bz2
-# Source1-md5: b0c641bbc1046d066c5d4032e7421fc6
+# Source0-md5: 62471478377d5f99a2ce88213731e500
+Source1:       nacl-headers-21.0.1180.57.tar.bz2
+# Source1-md5: 8e76cde640c1f268e14dbd67568a4bee
 # Taken from chromium-15.0.874.106/native_client/tools/newlib-libc-script
 Source2:       newlib-libc-script
 Source3:       pthread.h
old mode 100644 (file)
new mode 100755 (executable)
index 6e1f170..15f116f
@@ -1,7 +1,6 @@
 #!/bin/sh
 # Make snapshot of nacl-binutils
 # Author: Elan Ruusamäe <glen@pld-linux.org>
-# $Id$
 set -e
 
 # Generated from git
@@ -17,16 +16,18 @@ set -e
 package=nacl-newlib
 repo_url=http://git.chromium.org/native_client/$package.git
 nacl_trunk=http://src.chromium.org/native_client/trunk
+omahaproxy_url=https://omahaproxy.appspot.com
 specfile=crossnacl-newlib.spec
 
 # if you get errors that sha1 hash not found, try increasing depth
 # fatal: Path 'gcc/BASE-VER' does not exist in 'c69a5b7252d2f073d0f526800e4fca3b63cd1fab'
 depth=
 
-chrome_version=20.0.1132.47
-
-chrome_revision=$(curl -s https://omahaproxy.appspot.com/revision?version=$chrome_version)
+chrome_channel=stable
+chrome_version=$(curl -s "$omahaproxy_url/?os=linux&channel=$chrome_channel" | awk -F, 'NR > 1{print $3}')
+chrome_revision=$(curl -s $omahaproxy_url/revision?version=$chrome_version)
 chrome_branch=$(IFS=.; set -- $chrome_version; echo $3)
+
 test -e DEPS.py || svn cat http://src.chromium.org/chrome/branches/$chrome_branch/src/DEPS@$chrome_revision > DEPS.py
 nacl_revision=$(awk -F'"' '/nacl_revision.:/{print $4}' DEPS.py)
 
index be00dfd9c89eb979a884dda3e81f54f73db9d0c4..cf813d765c4f535685d1e671a3acf1952f0da28b 100644 (file)
--- a/pthread.h
+++ b/pthread.h
@@ -1,5 +1,5 @@
 /*
- * Copyright (c) 2011 The Native Client Authors. All rights reserved.
+ * Copyright (c) 2012 The Native Client Authors. All rights reserved.
  * Use of this source code is governed by a BSD-style license that can be
  * found in the LICENSE file.
  */
@@ -36,6 +36,7 @@ extern "C" {
 #endif
 
 struct timespec;
+struct __nc_basic_thread_data;
 
 /** Mutex type attributes */
 enum {
@@ -74,7 +75,7 @@ typedef struct {
   int mutex_type;
 
   /** ID of the thread that owns the mutex */
-  uint32_t owner_thread_id;
+  struct __nc_basic_thread_data *owner_thread_id;
 
   /** Recursion depth counter for recursive mutexes */
   uint32_t recursion_counter;
@@ -123,7 +124,7 @@ typedef struct {
 #define MAX_THREAD_ID (0xfffffffe)
 
 /** Illegal thread ID value. */
-#define NACL_PTHREAD_ILLEGAL_THREAD_ID (0xffffffff)
+#define NACL_PTHREAD_ILLEGAL_THREAD_ID ((pthread_t) 0)
 
 /** Statically initializes a pthread_mutex_t representing a recursive mutex. */
 #define PTHREAD_RECURSIVE_MUTEX_INITIALIZER_NP \
@@ -372,7 +373,7 @@ int pthread_cond_timedwait_rel(pthread_cond_t *cond,
 /** Thread entry function type. */
 typedef void *(*nc_thread_function)(void *p);
 /** Thread identifier type. */
-typedef uint32_t pthread_t;
+typedef struct __nc_basic_thread_data *pthread_t;
 
 /** A structure representing thread attributes. */
 typedef struct {
This page took 0.079798 seconds and 4 git commands to generate.