]> git.pld-linux.org Git - packages/crossnacl-gcc.git/commitdiff
use xz source
authorElan Ruusamäe <glen@delfi.ee>
Thu, 13 Sep 2012 19:17:21 +0000 (22:17 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Thu, 13 Sep 2012 19:17:21 +0000 (22:17 +0300)
crossnacl-gcc.spec
get-source.sh

index 93436dbc996c00b02de072903186a994a0f6950d..56efbcd8412dc5f4f0c390f96f6eccd9ecdb47ce 100644 (file)
@@ -20,6 +20,8 @@ BuildRequires:        gmp-c++-devel
 BuildRequires: gmp-devel
 BuildRequires: mpfr-devel
 BuildRequires: ppl-pwl-devel
+BuildRequires: tar >= 1:1.22
+BuildRequires: xz
 %if %{without bootstrap}
 BuildRequires: crossnacl-newlib
 %endif
index b900b8c7d561e75b5504245913bc36d8fb81a0e3..134cc032ad22913d8bc107cfed4ceebb72e7d11b 100755 (executable)
@@ -60,15 +60,15 @@ version=$(git show $githash:gcc/BASE-VER)
 shorthash=$(git rev-parse --short $githash)
 prefix=$package-$version-git$shorthash
 
-if [ -f $prefix.tar.bz2 ]; then
-       echo "Tarball $prefix.tar.bz2 already exists at $shorthash"
+if [ -f $prefix.tar.xz ]; then
+       echo "Tarball $prefix.tar.xz already exists at $shorthash"
        rm -f NACL_REVISIONS.sh DEPS.py
        exit 0
 fi
 
 git archive $githash --prefix $prefix/ > $prefix.tar
-bzip2 -9 $prefix.tar
+xz -9 $prefix.tar
 
-../dropin $prefix.tar.bz2
+../dropin $prefix.tar.xz
 
 rm -f NACL_REVISIONS.sh DEPS.py
This page took 0.070276 seconds and 4 git commands to generate.