]> git.pld-linux.org Git - packages/crossnacl-gcc.git/commitdiff
- update for omahaproxy changes
authorElan Ruusamäe <glen@delfi.ee>
Fri, 7 Dec 2012 10:19:52 +0000 (12:19 +0200)
committerElan Ruusamäe <glen@delfi.ee>
Fri, 7 Dec 2012 10:19:52 +0000 (12:19 +0200)
get-source.sh

index 500923cb4d82d26756a39e9a2677b3ee1c44da97..ac2584ded2836b518bbe0769b4e4eb7798ab9972 100755 (executable)
@@ -24,13 +24,12 @@ specfile=crossnacl-gcc.spec
 depth=5
 
 chrome_channel=${1:-stable}
-chrome_version=$(curl -s "$omahaproxy_url/?os=linux&channel=$chrome_channel" | awk -F, 'NR > 1{print $3}')
+chrome_version=$(curl -s "$omahaproxy_url/all?os=linux&channel=$chrome_channel" | awk -F, 'NR > 1{print $3}')
 test -n "$chrome_version"
-chrome_revision=$(curl -s $omahaproxy_url/revision?version=$chrome_version)
+chrome_revision=$((echo 'data='; curl -s $omahaproxy_url/revision.json?version=$chrome_version; echo ',print(data.chromium_revision)') | js)
 test -n "$chrome_revision"
 chrome_branch=$(IFS=.; set -- $chrome_version; echo $3)
-
-test -e DEPS.py || svn cat http://src.chromium.org/chrome/branches/$chrome_branch/src/DEPS@$chrome_revision > DEPS.py
+test -s DEPS.py || svn cat http://src.chromium.org/chrome/branches/$chrome_branch/src/DEPS@$chrome_revision > DEPS.py
 nacl_revision=$(awk -F'"' '/nacl_revision.:/{print $4}' DEPS.py)
 test -n "$nacl_revision"
 
@@ -47,7 +46,7 @@ fi
 
 # get src/native_client/tools/REVISIONS directly from svn
 test -n "$nacl_revision"
-test -e NACL_REVISIONS.sh || svn cat $nacl_trunk/src/native_client/tools/REVISIONS@$nacl_revision > NACL_REVISIONS.sh
+test -s NACL_REVISIONS.sh || svn cat $nacl_trunk/src/native_client/tools/REVISIONS@$nacl_revision > NACL_REVISIONS.sh
 
 if grep -Ev '^(#|(LINUX_HEADERS_FOR_NACL|NACL_(BINUTILS|GCC|GDB|GLIBC|NEWLIB))_COMMIT=[0-9a-f]+$|)' NACL_REVISIONS.sh >&2; then
        echo >&2 "I refuse to execute grabbed file for security concerns"
This page took 0.101281 seconds and 4 git commands to generate.