]> git.pld-linux.org Git - packages/crossmipsel-binutils.git/blame_incremental - crossmipsel-binutils.spec
- updated gettext BR
[packages/crossmipsel-binutils.git] / crossmipsel-binutils.spec
... / ...
CommitLineData
1Summary: Cross MIPSel GNU binary utility development utilities - binutils
2Summary(es.UTF-8): Utilitarios para desarrollo de binarios de la GNU - MIPSel binutils
3Summary(fr.UTF-8): Utilitaires de développement binaire de GNU - MIPSel binutils
4Summary(pl.UTF-8): Skrośne narzędzia programistyczne GNU dla AVR MIPSel - binutils
5Summary(pt_BR.UTF-8): Utilitários para desenvolvimento de binários da GNU - MIPSel binutils
6Summary(tr.UTF-8): GNU geliştirme araçları - MIPSel binutils
7Name: crossmipsel-binutils
8Version: 2.20.51.0.5
9Release: 1
10License: GPL
11Group: Development/Tools
12Source0: ftp://ftp.kernel.org/pub/linux/devel/binutils/binutils-%{version}.tar.bz2
13# Source0-md5: 6d2de7cdf7a8389e70b124e3d73b4d37
14URL: http://sources.redhat.com/binutils/
15BuildRequires: automake
16BuildRequires: bash
17BuildRequires: bison
18BuildRequires: flex
19BuildRequires: gettext-tools
20%ifarch sparc sparc32
21BuildRequires: sparc32
22%endif
23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25%define target mipsel-pld-linux
26%define arch %{_prefix}/%{target}
27
28%description
29Binutils is a collection of binary utilities, including:
30- ar - create, modify and extract from archives,
31- nm - lists symbols from object files,
32- objcopy - copy and translate object files,
33- objdump - display information from object files,
34- ranlib - generate an index for the contents of an archive,
35- size - list the section sizes of an object or archive file,
36- strings - list printable strings from files,
37- strip - discard symbols,
38- c++filt - a filter for demangling encoded C++ symbols,
39- addr2line - convert addresses to file and line,
40- nlmconv - convert object code into an NLM.
41
42This package contains the cross version for MIPS Little Endian.
43
44%description -l pl.UTF-8
45Pakiet binutils zawiera zestaw narzędzi umożliwiających kompilację
46programów. Znajdują się tutaj między innymi assembler, konsolidator
47(linker), a także inne narzędzia do manipulowania binarnymi plikami
48programów i bibliotek.
49
50Ten pakiet zawiera wersję skrośną generującą kod dla ostrokońcej (ang.
51Little Endian) architektury MIPS.
52
53%prep
54%setup -q -n binutils-%{version}
55
56%build
57cp -f /usr/share/automake/config.sub .
58
59# ldscripts won't be generated properly if SHELL is not bash...
60CFLAGS="%{rpmcflags}" \
61LDFLAGS="%{rpmldflags}" \
62CONFIG_SHELL="/bin/bash" \
63%ifarch sparc
64sparc32 \
65%endif
66./configure \
67 --disable-shared \
68 --prefix=%{_prefix} \
69 --libdir=%{_libdir} \
70 --mandir=%{_mandir} \
71 --infodir=%{_infodir} \
72 --target=%{target}
73
74%{__make} all \
75 tooldir=%{_prefix} \
76 EXEEXT=""
77
78%install
79rm -rf $RPM_BUILD_ROOT
80install -d $RPM_BUILD_ROOT%{_prefix}
81
82%{__make} install \
83 prefix=$RPM_BUILD_ROOT%{_prefix} \
84 mandir=$RPM_BUILD_ROOT%{_mandir} \
85 infodir=$RPM_BUILD_ROOT%{_infodir} \
86 libdir=$RPM_BUILD_ROOT%{_libdir}
87
88# remove these man pages unless we cross-build for win*/netware platforms.
89# however, this should be done in Makefiles.
90rm -f $RPM_BUILD_ROOT%{_mandir}/man1/{*dlltool,*nlmconv,*windres}.1
91
92%clean
93rm -rf $RPM_BUILD_ROOT
94
95%files
96%defattr(644,root,root,755)
97%doc README
98%attr(755,root,root) %{_bindir}/%{target}-*
99%dir %{arch}
100%dir %{arch}/bin
101%attr(755,root,root) %{arch}/bin/*
102%dir %{arch}/lib
103%{arch}/lib/ldscripts
104%{_mandir}/man?/%{target}-*
This page took 0.051848 seconds and 4 git commands to generate.