]> git.pld-linux.org Git - packages/crossmingw64-headers.git/blob - crossmingw64-headers.spec
- use arch*dir macros
[packages/crossmingw64-headers.git] / crossmingw64-headers.spec
1 Summary:        Cross MinGW-W64 GNU development utilities - headers
2 Summary(pl.UTF-8):      Skrośne narzędzia programistyczne GNU dla MinGW-W64 - pliki nagłówkowe
3 Name:           crossmingw64-headers
4 Version:        2.0
5 Release:        10
6 License:        ZPL v2.1 with parts on Public Domain, BSD and LGPL.
7 Group:          Development/Tools
8 # svn co https://mingw-w64.svn.sourceforge.net/svnroot/mingw-w64/stable/v2.x/mingw-w64-headers mingw64-headers
9 %define         _rev    5515
10 Source0:        mingw64-headers.tar.xz
11 # Source0-md5:  1268ff4bed4aab11c5604281f7741987
12 Patch0:         %{name}-stddef-max_align_t.patch
13 URL:            http://mingw-w64.sourceforge.net/
14 BuildRequires:  automake
15 BuildRequires:  subversion
16 AutoReqProv:    no
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %define         _enable_debug_packages  0
20
21 %define         target          x86_64-w64-mingw32
22 %define         archprefix      %{_prefix}/%{target}
23 %define         archincludedir  %{archprefix}/include
24
25 %description
26 crossmingw64 is a complete cross-compiling development system for
27 building stand-alone Microsoft Windows applications under Linux using
28 the MinGW-W64 build libraries. This includes a binutils, gcc with g++
29 and objc, and libstdc++, all cross targeted to x86_64-pc-mingw32,
30 along with supporting Win64 libraries in PE32+ format from free
31 sources.
32
33 This package contains cross targeted headers for Win64.
34
35 %description -l pl.UTF-8
36 crossmingw64 jest kompletnym systemem do skrośnej kompilacji,
37 pozwalającym budować aplikacje MS Windows pod Linuksem używając
38 bibliotek MinGW-W64. System składa się z binutils, gcc z g++ i objc,
39 libstdc++ - wszystkie generujące kod dla platformy x86_64-pc-mingw32,
40 oraz z bibliotek w formacie PE32+.
41
42 Ten pakiet zawiera pliki nagłówkowe dla Win64.
43
44 %prep
45 %setup -q -n mingw64-headers
46 svn upgrade
47 if [ "`svnversion -n`" != "%{_rev}" ]; then
48         exit 1
49 fi
50 %patch0 -p1
51 cp -p include/ChangeLog ChangeLog.headers
52 cp -p direct-x/ChangeLog ChangeLog.direct-x-headers
53
54 %build
55 %{__aclocal}
56 %{__autoconf}
57 %{__automake}
58 ./configure \
59         --prefix=%{_prefix} \
60         --build=%{_target_platform} \
61         --host=%{target} \
62         --enable-sdk=all
63
64 %{__make}
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68
69 %{__make} install \
70         DESTDIR=$RPM_BUILD_ROOT
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %files
76 %defattr(644,root,root,755)
77 %doc ChangeLog ChangeLog.direct-x-headers ChangeLog.headers
78 %{archincludedir}
This page took 0.05765 seconds and 3 git commands to generate.