]> git.pld-linux.org Git - packages/crossmingw64-gcc.git/commitdiff
- fix svn and texinfo incompatibilities auto/th/crossmingw64-gcc-4.7.2-2
authorJan Rękorajski <baggins@pld-linux.org>
Sat, 12 Mar 2016 22:44:22 +0000 (23:44 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Sat, 12 Mar 2016 22:44:22 +0000 (23:44 +0100)
crossmingw64-gcc.spec
texinfo.patch [new file with mode: 0644]

index b360223645493290e3f6a04b036258f88128b72b..f5f43d73c68c29683497a724f09472b2c9fb58ae 100644 (file)
@@ -24,6 +24,7 @@ Patch0:               gcc-branch.diff
 # Patch0-md5:  2add58e2b9d9874ba62e05ca9b6b513f
 Patch1:                gcc-mingw-dirs.patch
 Patch2:                gnu_inline-mismatch.patch
+Patch3:                texinfo.patch
 URL:           http://mingw-w64.sourceforge.net/
 BuildRequires: autoconf
 BuildRequires: automake
@@ -81,11 +82,13 @@ This package contains cross targeted g++ and libstdc++.
 %patch0 -p0
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 
 # override snapshot version.
 echo %{version} > gcc/BASE-VER
 echo "release" > gcc/DEV-PHASE
 
+svn upgrade mingw64-crt
 if [ "`svnversion -n mingw64-crt`" != "%{_rev}" ]; then
        exit 1
 fi
diff --git a/texinfo.patch b/texinfo.patch
new file mode 100644 (file)
index 0000000..f7054f1
--- /dev/null
@@ -0,0 +1,95 @@
+--- gcc-4.7.2/gcc/doc/cppopts.texi~    2011-12-20 21:44:13.000000000 +0100
++++ gcc-4.7.2/gcc/doc/cppopts.texi     2016-03-12 23:35:55.358231434 +0100
+@@ -803,7 +803,7 @@
+ Enable special code to work around file systems which only permit very
+ short file names, such as MS-DOS@.
+-@itemx --help
++@item --help
+ @itemx --target-help
+ @opindex help
+ @opindex target-help
+--- gcc-4.7.2/gcc/doc/invoke.texi~     2016-03-12 23:30:41.000000000 +0100
++++ gcc-4.7.2/gcc/doc/invoke.texi      2016-03-12 23:38:04.646883359 +0100
+@@ -5179,7 +5179,7 @@
+ e.g. With -fdbg-cnt=dce:10,tail_call:0
+ dbg_cnt(dce) will return true only for first 10 invocations
+-@itemx -fenable-@var{kind}-@var{pass}
++@item -fenable-@var{kind}-@var{pass}
+ @itemx -fdisable-@var{kind}-@var{pass}=@var{range-list}
+ @opindex fdisable-
+ @opindex fenable-
+@@ -5327,11 +5327,11 @@
+ @option{-fdump-rtl-ce3} enable dumping after the three
+ if conversion passes.
+-@itemx -fdump-rtl-cprop_hardreg
++@item -fdump-rtl-cprop_hardreg
+ @opindex fdump-rtl-cprop_hardreg
+ Dump after hard register copy propagation.
+-@itemx -fdump-rtl-csa
++@item -fdump-rtl-csa
+ @opindex fdump-rtl-csa
+ Dump after combining stack adjustments.
+@@ -5342,11 +5342,11 @@
+ @option{-fdump-rtl-cse1} and @option{-fdump-rtl-cse2} enable dumping after
+ the two common sub-expression elimination passes.
+-@itemx -fdump-rtl-dce
++@item -fdump-rtl-dce
+ @opindex fdump-rtl-dce
+ Dump after the standalone dead code elimination passes.
+-@itemx -fdump-rtl-dbr
++@item -fdump-rtl-dbr
+ @opindex fdump-rtl-dbr
+ Dump after delayed branch scheduling.
+@@ -5391,7 +5391,7 @@
+ @opindex fdump-rtl-initvals
+ Dump after the computation of the initial value sets.
+-@itemx -fdump-rtl-into_cfglayout
++@item -fdump-rtl-into_cfglayout
+ @opindex fdump-rtl-into_cfglayout
+ Dump after converting to cfglayout mode.
+@@ -5421,7 +5421,7 @@
+ @opindex fdump-rtl-rnreg
+ Dump after register renumbering.
+-@itemx -fdump-rtl-outof_cfglayout
++@item -fdump-rtl-outof_cfglayout
+ @opindex fdump-rtl-outof_cfglayout
+ Dump after converting from cfglayout mode.
+@@ -5433,7 +5433,7 @@
+ @opindex fdump-rtl-postreload
+ Dump after post-reload optimizations.
+-@itemx -fdump-rtl-pro_and_epilogue
++@item -fdump-rtl-pro_and_epilogue
+ @opindex fdump-rtl-pro_and_epilogue
+ Dump after generating the function prologues and epilogues.
+--- gcc-4.7.2/gcc/doc/generic.texi~    2011-12-23 23:07:16.000000000 +0100
++++ gcc-4.7.2/gcc/doc/generic.texi     2016-03-12 23:39:00.557744439 +0100
+@@ -1415,13 +1415,13 @@
+ not matter.  The type of the operands and that of the result are
+ always of @code{BOOLEAN_TYPE} or @code{INTEGER_TYPE}.
+-@itemx POINTER_PLUS_EXPR
++@item POINTER_PLUS_EXPR
+ This node represents pointer arithmetic.  The first operand is always
+ a pointer/reference type.  The second operand is always an unsigned
+ integer type compatible with sizetype.  This is the only binary
+ arithmetic operand that can operate on pointer types.
+-@itemx PLUS_EXPR
++@item PLUS_EXPR
+ @itemx MINUS_EXPR
+ @itemx MULT_EXPR
+ These nodes represent various binary arithmetic operations.
This page took 0.152007 seconds and 4 git commands to generate.