]> git.pld-linux.org Git - packages/crossmingw64-binutils.git/blob - crossmingw64-binutils.spec
f027ce7a53323952c8ab516e54192dcd0c9063da
[packages/crossmingw64-binutils.git] / crossmingw64-binutils.spec
1 Summary:        Cross MinGW64 GNU binary utility development utilities - binutils
2 Summary(es.UTF-8):      Utilitarios para desarrollo de binarios de la GNU - MinGW64 binutils
3 Summary(fr.UTF-8):      Utilitaires de développement binaire de GNU - MinGW64 binutils
4 Summary(pl.UTF-8):      Skrośne narzędzia programistyczne GNU dla MinGW64 - binutils
5 Summary(pt_BR.UTF-8):   Utilitários para desenvolvimento de binários da GNU - MinGW64 binutils
6 Summary(tr.UTF-8):      GNU geliştirme araçları - Mingw64 binutils
7 Name:           crossmingw64-binutils
8 Version:        2.26
9 Release:        1
10 License:        GPL v3+
11 Group:          Development/Tools
12 Source0:        http://ftp.gnu.org/gnu/binutils/binutils-%{version}.tar.bz2
13 # Source0-md5:  64146a0faa3b411ba774f47d41de239f
14 Patch0:         binutils-libdir.patch
15 Patch1:         binutils-am.patch
16 URL:            http://sources.redhat.com/binutils/
17 BuildRequires:  autoconf >= 2.64
18 BuildRequires:  automake >= 1:1.11
19 BuildRequires:  bash
20 BuildRequires:  bison
21 BuildRequires:  flex
22 BuildRequires:  gettext-tools
23 BuildRequires:  perl-tools-pod
24 # not necessary unless we patch .texi docs; but they are not packaged here anyway
25 #BuildRequires: texinfo >= 4.2
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         target          x86_64-w64-mingw64
29 %define         arch            %{_prefix}/%{target}
30
31 %description
32 crossmingw64 is a complete cross-compiling development system for
33 building stand-alone Microsoft Windows applications under Linux using
34 the MinGW64 build libraries. This includes a binutils, gcc with g++
35 and objc, and libstdc++, all cross targeted to x86_64-w64-mingw32,
36 along with supporting Win64 libraries in 'coff' format from free
37 sources.
38
39 This package contains cross targeted binutils.
40
41 %description -l pl.UTF-8
42 crossmingw64 jest kompletnym systemem do kroskompilacji, pozwalającym
43 budować aplikacje MS Windows pod Linuksem używając bibliotek mingw64.
44 System składa się z binutils, gcc z g++ i objc, libstdc++ - wszystkie
45 generujące kod dla platformy x86_64-w64-mingw32, oraz z bibliotek w
46 formacie COFF.
47
48 Ten pakiet zawiera binutils generujące skrośnie binaria dla Win64.
49
50 %prep
51 %setup -q -n binutils-%{version}
52 %patch0 -p1
53 %patch1 -p1
54
55 # file contains hacks for ac 2.64 only
56 %{__rm} config/override.m4
57 %{__sed} -i '/^m4_include(config\/override\.m4/d' configure.ac
58
59 %build
60 cp -f /usr/share/automake/config.* .
61 %{__aclocal}
62 %{__autoconf}
63
64 # non-standard regeneration (needed because of libdir patch)
65 # AM_BINUTILS_WARNINGS in bfd/warning.m4, ZW_GNU_GETTEXT_SISTER_DIR in config/gettext-sister.m4
66 for dir in gas bfd; do
67         cd $dir || exit 1
68         %{__aclocal} -I .. -I ../config -I ../bfd
69         %{__automake} Makefile
70         %{__automake} doc/Makefile
71         %{__autoconf}
72         cd ..
73 done
74
75 # We don't install libbfd (nor use shared binutils libraries) to avoid
76 # conflict with native binutils.
77
78 # ldscripts won't be generated properly if SHELL is not bash...
79 CFLAGS="%{rpmcflags}" \
80 LDFLAGS="%{rpmldflags}" \
81 CONFIG_SHELL="/bin/bash" \
82 ./configure \
83         --disable-nls \
84         --disable-shared \
85         --prefix=%{_prefix} \
86         --libdir=%{_libdir} \
87         --mandir=%{_mandir} \
88         --infodir=%{_infodir} \
89         --host=%{_target_platform} \
90         --build=%{_target_platform} \
91         --target=%{target}
92
93 %{__make} all \
94         tooldir=%{_prefix}
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98
99 %{__make} install \
100         INSTALL='$$s/install-sh -c' \
101         prefix=$RPM_BUILD_ROOT%{_prefix} \
102         mandir=$RPM_BUILD_ROOT%{_mandir} \
103         infodir=$RPM_BUILD_ROOT%{_infodir} \
104         libdir=$RPM_BUILD_ROOT%{_libdir}
105
106 # remove this man page unless we cross-build for netware platform.
107 # however, this should be done in Makefiles.
108 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/*nlmconv.1
109
110 # not prefixed, keep infos only from native packages
111 %{__rm} -r $RPM_BUILD_ROOT%{_infodir}
112
113 # "filesystem" for crossmingw32-* packages (move to crossmingw32-dirs?)
114 install -d $RPM_BUILD_ROOT%{arch}/lib/pkgconfig
115
116 %clean
117 rm -rf $RPM_BUILD_ROOT
118
119 %files
120 %defattr(644,root,root,755)
121 %doc README
122 # mingw64 directory tree
123 %dir %{arch}
124 %dir %{arch}/lib
125 %dir %{arch}/lib/pkgconfig
126 %dir %{arch}/bin
127 # binutils files
128 %attr(755,root,root) %{arch}/bin/ar
129 %attr(755,root,root) %{arch}/bin/as
130 %attr(755,root,root) %{arch}/bin/dlltool
131 %attr(755,root,root) %{arch}/bin/ld
132 %attr(755,root,root) %{arch}/bin/ld.bfd
133 %attr(755,root,root) %{arch}/bin/nm
134 %attr(755,root,root) %{arch}/bin/objcopy
135 %attr(755,root,root) %{arch}/bin/objdump
136 %attr(755,root,root) %{arch}/bin/ranlib
137 %attr(755,root,root) %{arch}/bin/readelf
138 %attr(755,root,root) %{arch}/bin/strip
139 %{arch}/lib/ldscripts
140 %attr(755,root,root) %{_bindir}/%{target}-addr2line
141 %attr(755,root,root) %{_bindir}/%{target}-ar
142 %attr(755,root,root) %{_bindir}/%{target}-as
143 %attr(755,root,root) %{_bindir}/%{target}-c++filt
144 %attr(755,root,root) %{_bindir}/%{target}-dlltool
145 %attr(755,root,root) %{_bindir}/%{target}-dllwrap
146 %attr(755,root,root) %{_bindir}/%{target}-elfedit
147 %attr(755,root,root) %{_bindir}/%{target}-gprof
148 %attr(755,root,root) %{_bindir}/%{target}-ld
149 %attr(755,root,root) %{_bindir}/%{target}-ld.bfd
150 %attr(755,root,root) %{_bindir}/%{target}-nm
151 %attr(755,root,root) %{_bindir}/%{target}-objcopy
152 %attr(755,root,root) %{_bindir}/%{target}-objdump
153 %attr(755,root,root) %{_bindir}/%{target}-ranlib
154 %attr(755,root,root) %{_bindir}/%{target}-readelf
155 %attr(755,root,root) %{_bindir}/%{target}-size
156 %attr(755,root,root) %{_bindir}/%{target}-strings
157 %attr(755,root,root) %{_bindir}/%{target}-strip
158 %attr(755,root,root) %{_bindir}/%{target}-windmc
159 %attr(755,root,root) %{_bindir}/%{target}-windres
160 %{_mandir}/man1/%{target}-addr2line.1*
161 %{_mandir}/man1/%{target}-ar.1*
162 %{_mandir}/man1/%{target}-as.1*
163 %{_mandir}/man1/%{target}-c++filt.1*
164 %{_mandir}/man1/%{target}-dlltool.1*
165 %{_mandir}/man1/%{target}-elfedit.1*
166 %{_mandir}/man1/%{target}-gprof.1*
167 %{_mandir}/man1/%{target}-ld.1*
168 %{_mandir}/man1/%{target}-nm.1*
169 %{_mandir}/man1/%{target}-objcopy.1*
170 %{_mandir}/man1/%{target}-objdump.1*
171 %{_mandir}/man1/%{target}-ranlib.1*
172 %{_mandir}/man1/%{target}-readelf.1*
173 %{_mandir}/man1/%{target}-size.1*
174 %{_mandir}/man1/%{target}-strings.1*
175 %{_mandir}/man1/%{target}-strip.1*
176 %{_mandir}/man1/%{target}-windmc.1*
177 %{_mandir}/man1/%{target}-windres.1*
This page took 0.06052 seconds and 2 git commands to generate.