]> git.pld-linux.org Git - packages/crossmingw64-binutils.git/blob - crossmingw64-binutils.spec
e3e9b04e462cebe47a53e7955a2099387de804da
[packages/crossmingw64-binutils.git] / crossmingw64-binutils.spec
1 Summary:        Cross MinGW-W64 GNU binary utility development utilities - binutils
2 Summary(es.UTF-8):      Utilitarios para desarrollo de binarios de la GNU - MinGW-W64 binutils
3 Summary(fr.UTF-8):      Utilitaires de développement binaire de GNU - MinGW-W64 binutils
4 Summary(pl.UTF-8):      Skrośne narzędzia programistyczne GNU dla MinGW-W64 - binutils
5 Summary(pt_BR.UTF-8):   Utilitários para desenvolvimento de binários da GNU - MinGW-W64 binutils
6 Summary(tr.UTF-8):      GNU geliştirme araçları - MinGW-W64 binutils
7 Name:           crossmingw64-binutils
8 Version:        2.33.1
9 Release:        1
10 License:        GPL v3+
11 Group:          Development/Tools
12 Source0:        https://ftp.gnu.org/gnu/binutils/binutils-%{version}.tar.lz
13 # Source0-md5:  f4e7e023664f087b3017fc42955ebb46
14 URL:            http://sources.redhat.com/binutils/
15 BuildRequires:  autoconf >= 2.64
16 BuildRequires:  automake >= 1:1.11
17 BuildRequires:  bash
18 BuildRequires:  bison
19 BuildRequires:  flex
20 BuildRequires:  gettext-tools
21 BuildRequires:  lzip
22 BuildRequires:  perl-tools-pod
23 BuildRequires:  tar >= 1:1.22
24 # not necessary unless we patch .texi docs; but they are not packaged here anyway
25 #BuildRequires: texinfo >= 4.2
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 # mingw-w64 project uses x86_64-w64-mingw32 triplet for 64-bit Windows
29 # and (i?86-w64-mingw32 for 32-bit Windows)
30 %define         target          x86_64-w64-mingw32
31 %define         arch            %{_prefix}/%{target}
32
33 %description
34 crossmingw64 is a complete cross-compiling development system for
35 building stand-alone Microsoft Windows applications under Linux using
36 the MinGW64 build libraries. This includes a binutils, gcc with g++
37 and objc, and libstdc++, all cross targeted to x86_64-w64-mingw32,
38 along with supporting Win64 libraries in 'coff' format from free
39 sources.
40
41 This package contains cross targeted binutils.
42
43 %description -l pl.UTF-8
44 crossmingw64 jest kompletnym systemem do kroskompilacji, pozwalającym
45 budować aplikacje MS Windows pod Linuksem używając bibliotek mingw64.
46 System składa się z binutils, gcc z g++ i objc, libstdc++ - wszystkie
47 generujące kod dla platformy x86_64-w64-mingw32, oraz z bibliotek
48 Win64 w formacie COFF.
49
50 Ten pakiet zawiera binutils generujące skrośnie binaria dla
51 64-bitowych Windows.
52
53 %prep
54 %setup -q -n binutils-%{version}
55
56 # file contains hacks for ac 2.64 only
57 %{__rm} config/override.m4
58 %{__sed} -i '/^m4_include(config\/override\.m4/d' configure.ac
59
60 %build
61 cp -f /usr/share/automake/config.* .
62 %{__aclocal}
63 %{__autoconf}
64
65 # non-standard regeneration (needed because of libdir patch)
66 # AM_BINUTILS_WARNINGS in bfd/warning.m4, ZW_GNU_GETTEXT_SISTER_DIR in config/gettext-sister.m4
67 for dir in gas bfd; do
68         cd $dir || exit 1
69         %{__aclocal} -I .. -I ../config -I ../bfd
70         %{__automake} Makefile
71         %{__automake} doc/Makefile
72         %{__autoconf}
73         cd ..
74 done
75
76 # We don't install libbfd (nor use shared binutils libraries) to avoid
77 # conflict with native binutils.
78
79 # ldscripts won't be generated properly if SHELL is not bash...
80 CFLAGS="%{rpmcflags}" \
81 LDFLAGS="%{rpmldflags}" \
82 CONFIG_SHELL="/bin/bash" \
83 ./configure \
84         --disable-nls \
85         --disable-shared \
86         --prefix=%{_prefix} \
87         --libdir=%{_libdir} \
88         --mandir=%{_mandir} \
89         --infodir=%{_infodir} \
90         --host=%{_target_platform} \
91         --build=%{_target_platform} \
92         --target=%{target}
93
94 %{__make} all \
95         tooldir=%{_prefix}
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99
100 %{__make} install \
101         INSTALL='$$s/install-sh -c' \
102         prefix=$RPM_BUILD_ROOT%{_prefix} \
103         mandir=$RPM_BUILD_ROOT%{_mandir} \
104         infodir=$RPM_BUILD_ROOT%{_infodir} \
105         libdir=$RPM_BUILD_ROOT%{_libdir}
106
107 # not prefixed, keep infos only from native packages
108 %{__rm} -r $RPM_BUILD_ROOT%{_infodir}
109
110 # "filesystem" for crossmingw32-* packages (move to crossmingw32-dirs?)
111 install -d $RPM_BUILD_ROOT%{arch}/lib/pkgconfig
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %files
117 %defattr(644,root,root,755)
118 %doc README
119 # mingw64 directory tree
120 %dir %{arch}
121 %dir %{arch}/lib
122 %dir %{arch}/lib/pkgconfig
123 %dir %{arch}/bin
124 # binutils files
125 %attr(755,root,root) %{arch}/bin/ar
126 %attr(755,root,root) %{arch}/bin/as
127 %attr(755,root,root) %{arch}/bin/dlltool
128 %attr(755,root,root) %{arch}/bin/ld
129 %attr(755,root,root) %{arch}/bin/ld.bfd
130 %attr(755,root,root) %{arch}/bin/nm
131 %attr(755,root,root) %{arch}/bin/objcopy
132 %attr(755,root,root) %{arch}/bin/objdump
133 %attr(755,root,root) %{arch}/bin/ranlib
134 %attr(755,root,root) %{arch}/bin/readelf
135 %attr(755,root,root) %{arch}/bin/strip
136 %{arch}/lib/ldscripts
137 %attr(755,root,root) %{_bindir}/%{target}-addr2line
138 %attr(755,root,root) %{_bindir}/%{target}-ar
139 %attr(755,root,root) %{_bindir}/%{target}-as
140 %attr(755,root,root) %{_bindir}/%{target}-c++filt
141 %attr(755,root,root) %{_bindir}/%{target}-dlltool
142 %attr(755,root,root) %{_bindir}/%{target}-dllwrap
143 %attr(755,root,root) %{_bindir}/%{target}-elfedit
144 %attr(755,root,root) %{_bindir}/%{target}-gprof
145 %attr(755,root,root) %{_bindir}/%{target}-ld
146 %attr(755,root,root) %{_bindir}/%{target}-ld.bfd
147 %attr(755,root,root) %{_bindir}/%{target}-nm
148 %attr(755,root,root) %{_bindir}/%{target}-objcopy
149 %attr(755,root,root) %{_bindir}/%{target}-objdump
150 %attr(755,root,root) %{_bindir}/%{target}-ranlib
151 %attr(755,root,root) %{_bindir}/%{target}-readelf
152 %attr(755,root,root) %{_bindir}/%{target}-size
153 %attr(755,root,root) %{_bindir}/%{target}-strings
154 %attr(755,root,root) %{_bindir}/%{target}-strip
155 %attr(755,root,root) %{_bindir}/%{target}-windmc
156 %attr(755,root,root) %{_bindir}/%{target}-windres
157 %{_mandir}/man1/%{target}-addr2line.1*
158 %{_mandir}/man1/%{target}-ar.1*
159 %{_mandir}/man1/%{target}-as.1*
160 %{_mandir}/man1/%{target}-c++filt.1*
161 %{_mandir}/man1/%{target}-dlltool.1*
162 %{_mandir}/man1/%{target}-elfedit.1*
163 %{_mandir}/man1/%{target}-gprof.1*
164 %{_mandir}/man1/%{target}-ld.1*
165 %{_mandir}/man1/%{target}-nm.1*
166 %{_mandir}/man1/%{target}-objcopy.1*
167 %{_mandir}/man1/%{target}-objdump.1*
168 %{_mandir}/man1/%{target}-ranlib.1*
169 %{_mandir}/man1/%{target}-readelf.1*
170 %{_mandir}/man1/%{target}-size.1*
171 %{_mandir}/man1/%{target}-strings.1*
172 %{_mandir}/man1/%{target}-strip.1*
173 %{_mandir}/man1/%{target}-windmc.1*
174 %{_mandir}/man1/%{target}-windres.1*
This page took 0.064738 seconds and 2 git commands to generate.