]> git.pld-linux.org Git - packages/crossmingw64-binutils.git/blob - crossmingw64-binutils.spec
ccbb737d99d9c4a9941c5c7e9dfeeb3752a27c69
[packages/crossmingw64-binutils.git] / crossmingw64-binutils.spec
1 Summary:        Cross MinGW-W64 GNU binary utility development utilities - binutils
2 Summary(es.UTF-8):      Utilitarios para desarrollo de binarios de la GNU - MinGW-W64 binutils
3 Summary(fr.UTF-8):      Utilitaires de développement binaire de GNU - MinGW-W64 binutils
4 Summary(pl.UTF-8):      Skrośne narzędzia programistyczne GNU dla MinGW-W64 - binutils
5 Summary(pt_BR.UTF-8):   Utilitários para desenvolvimento de binários da GNU - MinGW-W64 binutils
6 Summary(tr.UTF-8):      GNU geliştirme araçları - MinGW-W64 binutils
7 Name:           crossmingw64-binutils
8 Version:        2.28
9 Release:        1
10 License:        GPL v3+
11 Group:          Development/Tools
12 Source0:        http://ftp.gnu.org/gnu/binutils/binutils-%{version}.tar.bz2
13 # Source0-md5:  9e8340c96626b469a603c15c9d843727
14 Patch0:         binutils-libdir.patch
15 Patch1:         binutils-am.patch
16 URL:            http://sources.redhat.com/binutils/
17 BuildRequires:  autoconf >= 2.64
18 BuildRequires:  automake >= 1:1.11
19 BuildRequires:  bash
20 BuildRequires:  bison
21 BuildRequires:  flex
22 BuildRequires:  gettext-tools
23 BuildRequires:  perl-tools-pod
24 # not necessary unless we patch .texi docs; but they are not packaged here anyway
25 #BuildRequires: texinfo >= 4.2
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 # mingw-w64 project uses x86_64-w64-mingw32 triplet for 64-bit Windows
29 # and (i?86-w64-mingw32 for 32-bit Windows)
30 %define         target          x86_64-w64-mingw32
31 %define         arch            %{_prefix}/%{target}
32
33 %description
34 crossmingw64 is a complete cross-compiling development system for
35 building stand-alone Microsoft Windows applications under Linux using
36 the MinGW64 build libraries. This includes a binutils, gcc with g++
37 and objc, and libstdc++, all cross targeted to x86_64-w64-mingw32,
38 along with supporting Win64 libraries in 'coff' format from free
39 sources.
40
41 This package contains cross targeted binutils.
42
43 %description -l pl.UTF-8
44 crossmingw64 jest kompletnym systemem do kroskompilacji, pozwalającym
45 budować aplikacje MS Windows pod Linuksem używając bibliotek mingw64.
46 System składa się z binutils, gcc z g++ i objc, libstdc++ - wszystkie
47 generujące kod dla platformy x86_64-w64-mingw32, oraz z bibliotek
48 Win64 w formacie COFF.
49
50 Ten pakiet zawiera binutils generujące skrośnie binaria dla
51 64-bitowych Windows.
52
53 %prep
54 %setup -q -n binutils-%{version}
55 %patch0 -p1
56 %patch1 -p1
57
58 # file contains hacks for ac 2.64 only
59 %{__rm} config/override.m4
60 %{__sed} -i '/^m4_include(config\/override\.m4/d' configure.ac
61
62 %build
63 cp -f /usr/share/automake/config.* .
64 %{__aclocal}
65 %{__autoconf}
66
67 # non-standard regeneration (needed because of libdir patch)
68 # AM_BINUTILS_WARNINGS in bfd/warning.m4, ZW_GNU_GETTEXT_SISTER_DIR in config/gettext-sister.m4
69 for dir in gas bfd; do
70         cd $dir || exit 1
71         %{__aclocal} -I .. -I ../config -I ../bfd
72         %{__automake} Makefile
73         %{__automake} doc/Makefile
74         %{__autoconf}
75         cd ..
76 done
77
78 # We don't install libbfd (nor use shared binutils libraries) to avoid
79 # conflict with native binutils.
80
81 # ldscripts won't be generated properly if SHELL is not bash...
82 CFLAGS="%{rpmcflags}" \
83 LDFLAGS="%{rpmldflags}" \
84 CONFIG_SHELL="/bin/bash" \
85 ./configure \
86         --disable-nls \
87         --disable-shared \
88         --prefix=%{_prefix} \
89         --libdir=%{_libdir} \
90         --mandir=%{_mandir} \
91         --infodir=%{_infodir} \
92         --host=%{_target_platform} \
93         --build=%{_target_platform} \
94         --target=%{target}
95
96 %{__make} all \
97         tooldir=%{_prefix}
98
99 %install
100 rm -rf $RPM_BUILD_ROOT
101
102 %{__make} install \
103         INSTALL='$$s/install-sh -c' \
104         prefix=$RPM_BUILD_ROOT%{_prefix} \
105         mandir=$RPM_BUILD_ROOT%{_mandir} \
106         infodir=$RPM_BUILD_ROOT%{_infodir} \
107         libdir=$RPM_BUILD_ROOT%{_libdir}
108
109 # remove this man page unless we cross-build for netware platform.
110 # however, this should be done in Makefiles.
111 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/*nlmconv.1
112
113 # not prefixed, keep infos only from native packages
114 %{__rm} -r $RPM_BUILD_ROOT%{_infodir}
115
116 # "filesystem" for crossmingw32-* packages (move to crossmingw32-dirs?)
117 install -d $RPM_BUILD_ROOT%{arch}/lib/pkgconfig
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %files
123 %defattr(644,root,root,755)
124 %doc README
125 # mingw64 directory tree
126 %dir %{arch}
127 %dir %{arch}/lib
128 %dir %{arch}/lib/pkgconfig
129 %dir %{arch}/bin
130 # binutils files
131 %attr(755,root,root) %{arch}/bin/ar
132 %attr(755,root,root) %{arch}/bin/as
133 %attr(755,root,root) %{arch}/bin/dlltool
134 %attr(755,root,root) %{arch}/bin/ld
135 %attr(755,root,root) %{arch}/bin/ld.bfd
136 %attr(755,root,root) %{arch}/bin/nm
137 %attr(755,root,root) %{arch}/bin/objcopy
138 %attr(755,root,root) %{arch}/bin/objdump
139 %attr(755,root,root) %{arch}/bin/ranlib
140 %attr(755,root,root) %{arch}/bin/readelf
141 %attr(755,root,root) %{arch}/bin/strip
142 %{arch}/lib/ldscripts
143 %attr(755,root,root) %{_bindir}/%{target}-addr2line
144 %attr(755,root,root) %{_bindir}/%{target}-ar
145 %attr(755,root,root) %{_bindir}/%{target}-as
146 %attr(755,root,root) %{_bindir}/%{target}-c++filt
147 %attr(755,root,root) %{_bindir}/%{target}-dlltool
148 %attr(755,root,root) %{_bindir}/%{target}-dllwrap
149 %attr(755,root,root) %{_bindir}/%{target}-elfedit
150 %attr(755,root,root) %{_bindir}/%{target}-gprof
151 %attr(755,root,root) %{_bindir}/%{target}-ld
152 %attr(755,root,root) %{_bindir}/%{target}-ld.bfd
153 %attr(755,root,root) %{_bindir}/%{target}-nm
154 %attr(755,root,root) %{_bindir}/%{target}-objcopy
155 %attr(755,root,root) %{_bindir}/%{target}-objdump
156 %attr(755,root,root) %{_bindir}/%{target}-ranlib
157 %attr(755,root,root) %{_bindir}/%{target}-readelf
158 %attr(755,root,root) %{_bindir}/%{target}-size
159 %attr(755,root,root) %{_bindir}/%{target}-strings
160 %attr(755,root,root) %{_bindir}/%{target}-strip
161 %attr(755,root,root) %{_bindir}/%{target}-windmc
162 %attr(755,root,root) %{_bindir}/%{target}-windres
163 %{_mandir}/man1/%{target}-addr2line.1*
164 %{_mandir}/man1/%{target}-ar.1*
165 %{_mandir}/man1/%{target}-as.1*
166 %{_mandir}/man1/%{target}-c++filt.1*
167 %{_mandir}/man1/%{target}-dlltool.1*
168 %{_mandir}/man1/%{target}-elfedit.1*
169 %{_mandir}/man1/%{target}-gprof.1*
170 %{_mandir}/man1/%{target}-ld.1*
171 %{_mandir}/man1/%{target}-nm.1*
172 %{_mandir}/man1/%{target}-objcopy.1*
173 %{_mandir}/man1/%{target}-objdump.1*
174 %{_mandir}/man1/%{target}-ranlib.1*
175 %{_mandir}/man1/%{target}-readelf.1*
176 %{_mandir}/man1/%{target}-size.1*
177 %{_mandir}/man1/%{target}-strings.1*
178 %{_mandir}/man1/%{target}-strip.1*
179 %{_mandir}/man1/%{target}-windmc.1*
180 %{_mandir}/man1/%{target}-windres.1*
This page took 0.076939 seconds and 2 git commands to generate.