]> git.pld-linux.org Git - packages/crossmingw64-binutils.git/blob - crossmingw64-binutils.spec
- updated to 2.38
[packages/crossmingw64-binutils.git] / crossmingw64-binutils.spec
1 Summary:        Cross MinGW-W64 GNU binary utility development utilities - binutils
2 Summary(es.UTF-8):      Utilitarios para desarrollo de binarios de la GNU - MinGW-W64 binutils
3 Summary(fr.UTF-8):      Utilitaires de développement binaire de GNU - MinGW-W64 binutils
4 Summary(pl.UTF-8):      Skrośne narzędzia programistyczne GNU dla MinGW-W64 - binutils
5 Summary(pt_BR.UTF-8):   Utilitários para desenvolvimento de binários da GNU - MinGW-W64 binutils
6 Summary(tr.UTF-8):      GNU geliştirme araçları - MinGW-W64 binutils
7 Name:           crossmingw64-binutils
8 Version:        2.38
9 Release:        1
10 License:        GPL v3+
11 Group:          Development/Tools
12 Source0:        https://ftp.gnu.org/gnu/binutils/binutils-%{version}.tar.lz
13 # Source0-md5:  a54dd3cba0f276a52063b7de151e6334
14 URL:            http://www.sourceware.org/binutils/
15 BuildRequires:  autoconf >= 2.69
16 BuildRequires:  automake >= 1:1.11
17 BuildRequires:  bash
18 BuildRequires:  bison
19 BuildRequires:  flex
20 BuildRequires:  gettext-tools
21 BuildRequires:  lzip
22 BuildRequires:  perl-tools-pod
23 BuildRequires:  tar >= 1:1.22
24 # not necessary unless we patch .texi docs; but they are not packaged here anyway
25 #BuildRequires: texinfo >= 4.2
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 # mingw-w64 project uses x86_64-w64-mingw32 triplet for 64-bit Windows
29 # and (i?86-w64-mingw32 for 32-bit Windows)
30 %define         target          x86_64-w64-mingw32
31 %define         arch            %{_prefix}/%{target}
32
33 %description
34 crossmingw64 is a complete cross-compiling development system for
35 building stand-alone Microsoft Windows applications under Linux using
36 the MinGW64 build libraries. This includes a binutils, gcc with g++
37 and objc, and libstdc++, all cross targeted to x86_64-w64-mingw32,
38 along with supporting Win64 libraries in 'coff' format from free
39 sources.
40
41 This package contains cross targeted binutils.
42
43 %description -l pl.UTF-8
44 crossmingw64 jest kompletnym systemem do kroskompilacji, pozwalającym
45 budować aplikacje MS Windows pod Linuksem używając bibliotek mingw64.
46 System składa się z binutils, gcc z g++ i objc, libstdc++ - wszystkie
47 generujące kod dla platformy x86_64-w64-mingw32, oraz z bibliotek
48 Win64 w formacie COFF.
49
50 Ten pakiet zawiera binutils generujące skrośnie binaria dla
51 64-bitowych Windows.
52
53 %prep
54 %setup -q -n binutils-%{version}
55
56 # file contains hacks for ac 2.69 only
57 %{__rm} config/override.m4
58 %{__sed} -i '/^m4_include(config\/override\.m4/d' configure.ac
59
60 %build
61 cp -f /usr/share/automake/config.* .
62 %{__aclocal}
63 %{__autoconf}
64
65 # non-standard regeneration (needed because of libdir patch)
66 # AM_BINUTILS_WARNINGS in bfd/warning.m4, ZW_GNU_GETTEXT_SISTER_DIR in config/gettext-sister.m4
67 for dir in gas bfd; do
68         cd $dir || exit 1
69         %{__aclocal} -I .. -I ../config -I ../bfd
70         %{__automake} Makefile
71         test -f doc/Makefile.am && %{__automake} doc/Makefile
72         %{__autoconf}
73         cd ..
74 done
75
76 # We don't install libbfd (nor use shared binutils libraries) to avoid
77 # conflict with native binutils.
78
79 # ldscripts won't be generated properly if SHELL is not bash...
80 CFLAGS="%{rpmcflags}" \
81 LDFLAGS="%{rpmldflags}" \
82 CONFIG_SHELL="/bin/bash" \
83 ./configure \
84         --disable-nls \
85         --disable-shared \
86         --disable-silent-rules \
87         --prefix=%{_prefix} \
88         --libdir=%{_libdir} \
89         --mandir=%{_mandir} \
90         --infodir=%{_infodir} \
91         --host=%{_target_platform} \
92         --build=%{_target_platform} \
93         --target=%{target}
94
95 %{__make} all \
96         tooldir=%{_prefix}
97
98 %install
99 rm -rf $RPM_BUILD_ROOT
100
101 %{__make} install \
102         INSTALL='$$s/install-sh -c' \
103         prefix=$RPM_BUILD_ROOT%{_prefix} \
104         mandir=$RPM_BUILD_ROOT%{_mandir} \
105         infodir=$RPM_BUILD_ROOT%{_infodir} \
106         libdir=$RPM_BUILD_ROOT%{_libdir}
107
108 %{__rm} $RPM_BUILD_ROOT%{_libdir}/bfd-plugins/*.a
109
110 # not prefixed, keep infos only from native packages
111 %{__rm} -r $RPM_BUILD_ROOT%{_infodir}
112
113 # "filesystem" for crossmingw32-* packages (move to crossmingw32-dirs?)
114 install -d $RPM_BUILD_ROOT%{arch}/lib/pkgconfig
115
116 %clean
117 rm -rf $RPM_BUILD_ROOT
118
119 %files
120 %defattr(644,root,root,755)
121 %doc README
122 # mingw64 directory tree
123 %dir %{arch}
124 %dir %{arch}/lib
125 %dir %{arch}/lib/pkgconfig
126 %dir %{arch}/bin
127 # binutils files
128 %attr(755,root,root) %{arch}/bin/ar
129 %attr(755,root,root) %{arch}/bin/as
130 %attr(755,root,root) %{arch}/bin/dlltool
131 %attr(755,root,root) %{arch}/bin/ld
132 %attr(755,root,root) %{arch}/bin/ld.bfd
133 %attr(755,root,root) %{arch}/bin/nm
134 %attr(755,root,root) %{arch}/bin/objcopy
135 %attr(755,root,root) %{arch}/bin/objdump
136 %attr(755,root,root) %{arch}/bin/ranlib
137 %attr(755,root,root) %{arch}/bin/readelf
138 %attr(755,root,root) %{arch}/bin/strip
139 %{arch}/lib/ldscripts
140 %attr(755,root,root) %{_bindir}/%{target}-addr2line
141 %attr(755,root,root) %{_bindir}/%{target}-ar
142 %attr(755,root,root) %{_bindir}/%{target}-as
143 %attr(755,root,root) %{_bindir}/%{target}-c++filt
144 %attr(755,root,root) %{_bindir}/%{target}-dlltool
145 %attr(755,root,root) %{_bindir}/%{target}-dllwrap
146 %attr(755,root,root) %{_bindir}/%{target}-elfedit
147 %attr(755,root,root) %{_bindir}/%{target}-gprof
148 %attr(755,root,root) %{_bindir}/%{target}-ld
149 %attr(755,root,root) %{_bindir}/%{target}-ld.bfd
150 %attr(755,root,root) %{_bindir}/%{target}-nm
151 %attr(755,root,root) %{_bindir}/%{target}-objcopy
152 %attr(755,root,root) %{_bindir}/%{target}-objdump
153 %attr(755,root,root) %{_bindir}/%{target}-ranlib
154 %attr(755,root,root) %{_bindir}/%{target}-readelf
155 %attr(755,root,root) %{_bindir}/%{target}-size
156 %attr(755,root,root) %{_bindir}/%{target}-strings
157 %attr(755,root,root) %{_bindir}/%{target}-strip
158 %attr(755,root,root) %{_bindir}/%{target}-windmc
159 %attr(755,root,root) %{_bindir}/%{target}-windres
160 %{_mandir}/man1/%{target}-addr2line.1*
161 %{_mandir}/man1/%{target}-ar.1*
162 %{_mandir}/man1/%{target}-as.1*
163 %{_mandir}/man1/%{target}-c++filt.1*
164 %{_mandir}/man1/%{target}-dlltool.1*
165 %{_mandir}/man1/%{target}-elfedit.1*
166 %{_mandir}/man1/%{target}-gprof.1*
167 %{_mandir}/man1/%{target}-ld.1*
168 %{_mandir}/man1/%{target}-nm.1*
169 %{_mandir}/man1/%{target}-objcopy.1*
170 %{_mandir}/man1/%{target}-objdump.1*
171 %{_mandir}/man1/%{target}-ranlib.1*
172 %{_mandir}/man1/%{target}-readelf.1*
173 %{_mandir}/man1/%{target}-size.1*
174 %{_mandir}/man1/%{target}-strings.1*
175 %{_mandir}/man1/%{target}-strip.1*
176 %{_mandir}/man1/%{target}-windmc.1*
177 %{_mandir}/man1/%{target}-windres.1*
This page took 0.07568 seconds and 3 git commands to generate.