]> git.pld-linux.org Git - packages/crossmingw64-binutils.git/blob - crossmingw64-binutils.spec
- updated to 2.30
[packages/crossmingw64-binutils.git] / crossmingw64-binutils.spec
1 Summary:        Cross MinGW-W64 GNU binary utility development utilities - binutils
2 Summary(es.UTF-8):      Utilitarios para desarrollo de binarios de la GNU - MinGW-W64 binutils
3 Summary(fr.UTF-8):      Utilitaires de développement binaire de GNU - MinGW-W64 binutils
4 Summary(pl.UTF-8):      Skrośne narzędzia programistyczne GNU dla MinGW-W64 - binutils
5 Summary(pt_BR.UTF-8):   Utilitários para desenvolvimento de binários da GNU - MinGW-W64 binutils
6 Summary(tr.UTF-8):      GNU geliştirme araçları - MinGW-W64 binutils
7 Name:           crossmingw64-binutils
8 Version:        2.30
9 Release:        1
10 License:        GPL v3+
11 Group:          Development/Tools
12 Source0:        http://ftp.gnu.org/gnu/binutils/binutils-%{version}.tar.lz
13 # Source0-md5:  e64eb5655c6c2caa78677e19c84ba5b5
14 Patch0:         binutils-libdir.patch
15 Patch1:         binutils-am.patch
16 URL:            http://sources.redhat.com/binutils/
17 BuildRequires:  autoconf >= 2.64
18 BuildRequires:  automake >= 1:1.11
19 BuildRequires:  bash
20 BuildRequires:  bison
21 BuildRequires:  flex
22 BuildRequires:  gettext-tools
23 BuildRequires:  lzip
24 BuildRequires:  perl-tools-pod
25 BuildRequires:  tar >= 1:1.22
26 # not necessary unless we patch .texi docs; but they are not packaged here anyway
27 #BuildRequires: texinfo >= 4.2
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 # mingw-w64 project uses x86_64-w64-mingw32 triplet for 64-bit Windows
31 # and (i?86-w64-mingw32 for 32-bit Windows)
32 %define         target          x86_64-w64-mingw32
33 %define         arch            %{_prefix}/%{target}
34
35 %description
36 crossmingw64 is a complete cross-compiling development system for
37 building stand-alone Microsoft Windows applications under Linux using
38 the MinGW64 build libraries. This includes a binutils, gcc with g++
39 and objc, and libstdc++, all cross targeted to x86_64-w64-mingw32,
40 along with supporting Win64 libraries in 'coff' format from free
41 sources.
42
43 This package contains cross targeted binutils.
44
45 %description -l pl.UTF-8
46 crossmingw64 jest kompletnym systemem do kroskompilacji, pozwalającym
47 budować aplikacje MS Windows pod Linuksem używając bibliotek mingw64.
48 System składa się z binutils, gcc z g++ i objc, libstdc++ - wszystkie
49 generujące kod dla platformy x86_64-w64-mingw32, oraz z bibliotek
50 Win64 w formacie COFF.
51
52 Ten pakiet zawiera binutils generujące skrośnie binaria dla
53 64-bitowych Windows.
54
55 %prep
56 %setup -q -n binutils-%{version}
57 %patch0 -p1
58 %patch1 -p1
59
60 # file contains hacks for ac 2.64 only
61 %{__rm} config/override.m4
62 %{__sed} -i '/^m4_include(config\/override\.m4/d' configure.ac
63
64 %build
65 cp -f /usr/share/automake/config.* .
66 %{__aclocal}
67 %{__autoconf}
68
69 # non-standard regeneration (needed because of libdir patch)
70 # AM_BINUTILS_WARNINGS in bfd/warning.m4, ZW_GNU_GETTEXT_SISTER_DIR in config/gettext-sister.m4
71 for dir in gas bfd; do
72         cd $dir || exit 1
73         %{__aclocal} -I .. -I ../config -I ../bfd
74         %{__automake} Makefile
75         %{__automake} doc/Makefile
76         %{__autoconf}
77         cd ..
78 done
79
80 # We don't install libbfd (nor use shared binutils libraries) to avoid
81 # conflict with native binutils.
82
83 # ldscripts won't be generated properly if SHELL is not bash...
84 CFLAGS="%{rpmcflags}" \
85 LDFLAGS="%{rpmldflags}" \
86 CONFIG_SHELL="/bin/bash" \
87 ./configure \
88         --disable-nls \
89         --disable-shared \
90         --prefix=%{_prefix} \
91         --libdir=%{_libdir} \
92         --mandir=%{_mandir} \
93         --infodir=%{_infodir} \
94         --host=%{_target_platform} \
95         --build=%{_target_platform} \
96         --target=%{target}
97
98 %{__make} all \
99         tooldir=%{_prefix}
100
101 %install
102 rm -rf $RPM_BUILD_ROOT
103
104 %{__make} install \
105         INSTALL='$$s/install-sh -c' \
106         prefix=$RPM_BUILD_ROOT%{_prefix} \
107         mandir=$RPM_BUILD_ROOT%{_mandir} \
108         infodir=$RPM_BUILD_ROOT%{_infodir} \
109         libdir=$RPM_BUILD_ROOT%{_libdir}
110
111 # remove this man page unless we cross-build for netware platform.
112 # however, this should be done in Makefiles.
113 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/*nlmconv.1
114
115 # not prefixed, keep infos only from native packages
116 %{__rm} -r $RPM_BUILD_ROOT%{_infodir}
117
118 # "filesystem" for crossmingw32-* packages (move to crossmingw32-dirs?)
119 install -d $RPM_BUILD_ROOT%{arch}/lib/pkgconfig
120
121 %clean
122 rm -rf $RPM_BUILD_ROOT
123
124 %files
125 %defattr(644,root,root,755)
126 %doc README
127 # mingw64 directory tree
128 %dir %{arch}
129 %dir %{arch}/lib
130 %dir %{arch}/lib/pkgconfig
131 %dir %{arch}/bin
132 # binutils files
133 %attr(755,root,root) %{arch}/bin/ar
134 %attr(755,root,root) %{arch}/bin/as
135 %attr(755,root,root) %{arch}/bin/dlltool
136 %attr(755,root,root) %{arch}/bin/ld
137 %attr(755,root,root) %{arch}/bin/ld.bfd
138 %attr(755,root,root) %{arch}/bin/nm
139 %attr(755,root,root) %{arch}/bin/objcopy
140 %attr(755,root,root) %{arch}/bin/objdump
141 %attr(755,root,root) %{arch}/bin/ranlib
142 %attr(755,root,root) %{arch}/bin/readelf
143 %attr(755,root,root) %{arch}/bin/strip
144 %{arch}/lib/ldscripts
145 %attr(755,root,root) %{_bindir}/%{target}-addr2line
146 %attr(755,root,root) %{_bindir}/%{target}-ar
147 %attr(755,root,root) %{_bindir}/%{target}-as
148 %attr(755,root,root) %{_bindir}/%{target}-c++filt
149 %attr(755,root,root) %{_bindir}/%{target}-dlltool
150 %attr(755,root,root) %{_bindir}/%{target}-dllwrap
151 %attr(755,root,root) %{_bindir}/%{target}-elfedit
152 %attr(755,root,root) %{_bindir}/%{target}-gprof
153 %attr(755,root,root) %{_bindir}/%{target}-ld
154 %attr(755,root,root) %{_bindir}/%{target}-ld.bfd
155 %attr(755,root,root) %{_bindir}/%{target}-nm
156 %attr(755,root,root) %{_bindir}/%{target}-objcopy
157 %attr(755,root,root) %{_bindir}/%{target}-objdump
158 %attr(755,root,root) %{_bindir}/%{target}-ranlib
159 %attr(755,root,root) %{_bindir}/%{target}-readelf
160 %attr(755,root,root) %{_bindir}/%{target}-size
161 %attr(755,root,root) %{_bindir}/%{target}-strings
162 %attr(755,root,root) %{_bindir}/%{target}-strip
163 %attr(755,root,root) %{_bindir}/%{target}-windmc
164 %attr(755,root,root) %{_bindir}/%{target}-windres
165 %{_mandir}/man1/%{target}-addr2line.1*
166 %{_mandir}/man1/%{target}-ar.1*
167 %{_mandir}/man1/%{target}-as.1*
168 %{_mandir}/man1/%{target}-c++filt.1*
169 %{_mandir}/man1/%{target}-dlltool.1*
170 %{_mandir}/man1/%{target}-elfedit.1*
171 %{_mandir}/man1/%{target}-gprof.1*
172 %{_mandir}/man1/%{target}-ld.1*
173 %{_mandir}/man1/%{target}-nm.1*
174 %{_mandir}/man1/%{target}-objcopy.1*
175 %{_mandir}/man1/%{target}-objdump.1*
176 %{_mandir}/man1/%{target}-ranlib.1*
177 %{_mandir}/man1/%{target}-readelf.1*
178 %{_mandir}/man1/%{target}-size.1*
179 %{_mandir}/man1/%{target}-strings.1*
180 %{_mandir}/man1/%{target}-strip.1*
181 %{_mandir}/man1/%{target}-windmc.1*
182 %{_mandir}/man1/%{target}-windres.1*
This page took 0.105927 seconds and 3 git commands to generate.