]> git.pld-linux.org Git - packages/crossmingw32ce-binutils.git/blob - crossmingw32ce-binutils.spec
- based on crossmingw32-binutils.spec, compiles but right now probably just creates...
[packages/crossmingw32ce-binutils.git] / crossmingw32ce-binutils.spec
1 # TODO
2 # - copy (get inspired) descriptions from http://cegcc.sourceforge.net/
3 Summary:        Cross Mingw32 GNU binary utility development utilities - binutils
4 Summary(es):    Utilitarios para desarrollo de binarios de la GNU - Mingw32 binutils
5 Summary(fr):    Utilitaires de développement binaire de GNU - Mingw32 binutils
6 Summary(pl):    Skro¶ne narzêdzia programistyczne GNU dla Mingw32 - binutils
7 Summary(pt_BR): Utilitários para desenvolvimento de binários da GNU - Mingw32 binutils
8 Summary(tr):    GNU geliþtirme araçlarý - Mingw32 binutils
9 Name:           crossmingw32ce-binutils
10 Version:        2.17.50.0.8
11 Release:        1
12 License:        GPL
13 Group:          Development/Tools
14 Source0:        ftp://ftp.kernel.org/pub/linux/devel/binutils/binutils-%{version}.tar.bz2
15 # Source0-md5:  1441fe6fa44b344d0575cb66d3f89252
16 URL:            http://sources.redhat.com/binutils/
17 BuildRequires:  automake
18 BuildRequires:  bash
19 BuildRequires:  bison
20 BuildRequires:  flex
21 BuildRequires:  gettext-devel
22 # not necessary unless we patch .texi docs; but they are not packaged here anyway
23 #BuildRequires: texinfo >= 4.2
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define         target          i386-mingw32ce
27 %define         arch            %{_prefix}/%{target}
28
29 %description
30 crossmingw32ce is a complete cross-compiling development system for
31 building stand-alone Microsoft Windows applications under Linux using
32 the Mingw32 build libraries. This includes a binutils, gcc with g++
33 and objc, and libstdc++, all cross targeted to i386-mingw32, along
34 with supporting Win32 libraries in 'coff' format from free sources.
35
36
37 This package contains cross targeted binutils.
38
39 %description -l pl
40 crossmingw32ce jest kompletnym systemem do kroskompilacji, pozwalaj±cym
41 budowaæ aplikacje MS Windows pod Linuksem u¿ywaj±c bibliotek mingw32.
42 System sk³ada siê z binutils, gcc z g++ i objc, libstdc++ - wszystkie
43 generuj±ce kod dla platformy i386-mingw32, oraz z bibliotek w formacie
44 COFF.
45
46 Ten pakiet zawiera binutils generuj±ce skro¶nie binaria dla Win32.
47
48 %prep
49 %setup -q -n binutils-%{version}
50
51 %build
52 cp /usr/share/automake/config.sub .
53
54 # Because of a bug in binutils-2.9.1, a cross libbfd.so* is not named
55 # lib<target>bfd.so*. To prevent confusion with native binutils, we
56 # forget about shared libraries right now, and do not install libbfd.a
57 # [the same applies to binutils 2.10.1.0.4]
58
59 # ldscripts won't be generated properly if SHELL is not bash...
60 CFLAGS="%{rpmcflags}" \
61 LDFLAGS="%{rpmldflags}" \
62 CONFIG_SHELL="/bin/bash" \
63 ./configure \
64         --disable-shared \
65         --disable-nls \
66         --prefix=%{_prefix} \
67         --libdir=%{_libdir} \
68         --mandir=%{_mandir} \
69         --infodir=%{_infodir} \
70         --host=%{_target_platform} \
71         --build=%{_target_platform} \
72         --target=%{target}
73
74 %{__make} all \
75         tooldir=%{_prefix}
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79
80 %{__make} install \
81         INSTALL='$$s/install-sh -c' \
82         prefix=$RPM_BUILD_ROOT%{_prefix} \
83         mandir=$RPM_BUILD_ROOT%{_mandir} \
84         infodir=$RPM_BUILD_ROOT%{_infodir} \
85         libdir=$RPM_BUILD_ROOT%{_libdir}
86
87 # remove this man page unless we cross-build for netware platform.
88 # however, this should be done in Makefiles.
89 rm -f $RPM_BUILD_ROOT%{_mandir}/man1/*nlmconv.1
90
91 # libiberty.a is ELF not PE
92 rm -f $RPM_BUILD_ROOT%{arch}/lib/libiberty.a
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %files
98 %defattr(644,root,root,755)
99 %doc README
100 %dir %{arch}
101 %dir %{arch}/lib
102 %dir %{arch}/bin
103 %attr(755,root,root) %{arch}/bin/*
104 %{arch}/lib/ldscripts
105 %attr(755,root,root) %{_bindir}/%{target}-*
106 %{_mandir}/man1/%{target}-*
This page took 0.089051 seconds and 3 git commands to generate.