]> git.pld-linux.org Git - packages/crossmingw32-zlib.git/commitdiff
- updated to 1.2.4 (adds LFS)
authorJakub Bogusz <qboosh@pld-linux.org>
Mon, 15 Mar 2010 07:59:01 +0000 (07:59 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- updated shared patch, removed obsolete asmopt patch

Changed files:
    crossmingw32-zlib-shared.patch -> 1.2
    crossmingw32-zlib.spec -> 1.22
    zlib-asmopt.patch -> 1.3

crossmingw32-zlib-shared.patch
crossmingw32-zlib.spec
zlib-asmopt.patch [deleted file]

index 7190cf5d93d7c532686a7e6bd9b9f0c805d4e8e3..e588c50c8905b6d8add482150143aa7ef6d788c5 100644 (file)
@@ -1,12 +1,11 @@
-diff -ruN zlib-1.2.1./Makefile.in zlib-1.2.1/Makefile.in
---- zlib-1.2.1./Makefile.in    2003-12-25 03:08:31.000000000 +0100
-+++ zlib-1.2.1/Makefile.in     2003-12-25 03:10:13.070092968 +0100
-@@ -71,6 +71,9 @@
-       $(AR) $@ $(OBJS) $(OBJA)
+--- zlib-1.2.4./Makefile.in    2003-12-25 03:08:31.000000000 +0100
++++ zlib-1.2.4/Makefile.in     2003-12-25 03:10:13.070092968 +0100
+@@ -108,6 +108,9 @@
+       $(AR) $@ $(OBJS)
        -@ ($(RANLIB) $@ || true) >/dev/null 2>&1
  
-+z.dll: $(OBJS) $(OBJA)
-+      $(CC) -shared $(OBJS) $(OBJA) -Wl,--enable-auto-image-base -o z.dll -Wl,--out-implib,libz.dll.a
++z.dll: $(OBJS)
++      $(CC) -shared $(OBJS) -Wl,--enable-auto-image-base -o z.dll -Wl,--out-implib,libz.dll.a
 +
  match.o: match.S
        $(CPP) match.S > _match.s
index 114359fec89ede1b69626eb1d71cfd0e1bcc9e54..bdde6f0b8b2108e4d5032c342505d5f613162a68 100644 (file)
 Summary:       Library for compression and decompression - Ming32 cross version
 Summary(pl.UTF-8):     Biblioteka z podprogramami do kompresji i dekompresji - wersja skrośna dla Ming32
 Name:          crossmingw32-%{realname}
-Version:       1.2.3
-Release:       4
+Version:       1.2.4
+Release:       1
 License:       BSD
 Group:         Development/Libraries
-Source0:       http://www.zlib.net/%{realname}-%{version}.tar.gz
-# Source0-md5: debc62758716a169df9f62e6ab2bc634
-Patch0:                %{realname}-asmopt.patch
-Patch1:                %{name}-shared.patch
+Source0:       http://www.zlib.net/current/%{realname}-%{version}.tar.gz
+# Source0-md5: 47f6ed51b3c83a8534f9228531effa18
+#Patch0:               %{realname}-asmopt.patch
+Patch0:                %{name}-shared.patch
 URL:           http://www.zlib.org/
 BuildRequires: crossmingw32-gcc
 BuildRequires: sed >= 4.0
@@ -35,6 +35,7 @@ BuildRoot:    %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                _sysprefix              /usr
 %define                _prefix                 %{_sysprefix}/%{target}
 %define                _libdir                 %{_prefix}/lib
+%define                _pkgconfigdir           %{_prefix}/lib/pkgconfig
 %define                _dlldir                 /usr/share/wine/windows/system
 %define                __cc                    %{target}-gcc
 %define                __cxx                   %{target}-g++
@@ -88,10 +89,9 @@ zlib - biblioteka DLL dla Windows.
 
 %prep
 %setup -q -n %{realname}-%{version}
-%patch1 -p1
+%patch0 -p1
 
 %if %{with asmopt}
-%patch0 -p1
 %ifarch i686 athlon
 cp contrib/asm686/match.S .
 %endif
@@ -110,14 +110,15 @@ sed -i -e 's/.*grep _hello.*/if false; then/' configure
 %build
 CC="%{__cc}" \
 CXX="%{__cxx}" \
-AR="%{target}-ar rc" \
+AR="%{target}-ar" \
 RANLIB="%{target}-ranlib" \
 CFLAGS="-D_REENTRANT %{rpmcflags}%{?with_asmopt: -DASMV}" \
 ./configure \
+       --static \
        --prefix=%{_prefix}
 
-%{__make}
-%{__make} z.dll
+%{__make} static z.dll \
+       %{?with_asmopt:OBJA=match.o}
 
 # used by libtool to detect dependencies
 cat << "EOF" >> libz.la
@@ -183,7 +184,10 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %{_libdir}/libz.dll.a
 %{_libdir}/libz.la
-%{_includedir}/*.h
+%{_includedir}/zconf.h
+%{_includedir}/zlib.h
+%{_includedir}/zutil.h
+%{_pkgconfigdir}/zlib.pc
 
 %files static
 %defattr(644,root,root,755)
diff --git a/zlib-asmopt.patch b/zlib-asmopt.patch
deleted file mode 100644 (file)
index 81eba56..0000000
+++ /dev/null
@@ -1,22 +0,0 @@
---- zlib-1.2.1/Makefile.in.orig        2003-11-09 03:29:23.000000000 +0100
-+++ zlib-1.2.1/Makefile.in     2003-11-25 23:58:48.202584104 +0100
-@@ -49,7 +49,7 @@
- OBJS = adler32.o compress.o crc32.o gzio.o uncompr.o deflate.o trees.o \
-        zutil.o inflate.o infback.o inftrees.o inffast.o
--OBJA =
-+OBJA = match.o
- # to use the asm code: make OBJA=match.o
- TEST_OBJS = example.o minigzip.o
-@@ -77,8 +77,8 @@
-       mv _match.o match.o
-       rm -f _match.s
--$(SHAREDLIBV): $(OBJS)
--      $(LDSHARED) -o $@ $(OBJS)
-+$(SHAREDLIBV): $(OBJS) $(OBJA)
-+      $(LDSHARED) -o $@ $(OBJS) $(OBJA)
-       rm -f $(SHAREDLIB) $(SHAREDLIBM)
-       ln -s $@ $(SHAREDLIB)
-       ln -s $@ $(SHAREDLIBM)
This page took 0.14627 seconds and 4 git commands to generate.