]> git.pld-linux.org Git - packages/crossmingw32-zlib.git/blobdiff - crossmingw32-zlib.spec
- updated to 1.2.11
[packages/crossmingw32-zlib.git] / crossmingw32-zlib.spec
index 33669b52677dd1f6ca603d0ad8272288cfc80910..73c8a17f700ae1cc4f37bdeca1d0d2972e90825a 100644 (file)
@@ -1,25 +1,26 @@
 #
 # Conditional build:
-%bcond_without asmopt  # without assmbler optimization for i586+
+%bcond_with    asmopt  # without assembler optimization for i686+
+                       # (asm is unsupported by upstream and unmaintained)
 #
 # disable asmopt where not applicable
-%ifarch i386 i486
+%ifarch i386 i486 i586
 %undefine      with_asmopt
 %endif
 %ifnarch %{ix86}
 %undefine      with_asmopt
 %endif
 %define                realname                zlib
-Summary:       Library for compression and decompression - Ming32 cross version
-Summary(pl.UTF-8):     Biblioteka z podprogramami do kompresji i dekompresji - wersja skrośna dla Ming32
+Summary:       Library for compression and decompression - MinGW32 cross version
+Summary(pl.UTF-8):     Biblioteka z podprogramami do kompresji i dekompresji - wersja skrośna dla MinGW32
 Name:          crossmingw32-%{realname}
-Version:       1.2.4
-Release:       2
+Version:       1.2.11
+Release:       1
 License:       BSD
 Group:         Development/Libraries
 Source0:       http://www.zlib.net/current/%{realname}-%{version}.tar.gz
-# Source0-md5: 47f6ed51b3c83a8534f9228531effa18
-URL:           http://www.zlib.org/
+# Source0-md5: 1c9f62f0778697a09d36121ead88e08e
+URL:           http://www.zlib.net/
 BuildRequires: crossmingw32-gcc
 BuildRequires: sed >= 4.0
 Requires:      crossmingw32-runtime
@@ -37,11 +38,17 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                _dlldir                 /usr/share/wine/windows/system
 %define                __cc                    %{target}-gcc
 %define                __cxx                   %{target}-g++
+%define                __pkgconfig_provides    %{nil}
+%define                __pkgconfig_requires    %{nil}
 
 %ifarch alpha sparc sparc64 sparcv9
 %define                optflags        -O2
 %endif
 
+# -z options are invalid for mingw linker, most of -f options are Linux-specific
+%define                filterout_ld    -Wl,-z,.*
+%define                filterout_c             -f[-a-z0-9=]*
+
 %description
 The 'zlib' compression library provides in-memory compression and
 decompression functions, including integrity checks of the
@@ -62,16 +69,16 @@ strumieniu danych.
 Ten pakiet zawiera wersję skrośną dla Win32.
 
 %package static
-Summary:       Static zlib library (cross mingw32 version)
-Summary(pl.UTF-8):     Statyczna biblioteka zlib (wersja skrośna mingw32)
+Summary:       Static zlib library (cross MinGW32 version)
+Summary(pl.UTF-8):     Statyczna biblioteka zlib (wersja skrośna MinGW32)
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
 
 %description static
-Static zlib library (cross mingw32 version).
+Static zlib library (cross MinGW32 version).
 
 %description static -l pl.UTF-8
-Statyczna biblioteka zlib (wersja skrośna mingw32).
+Statyczna biblioteka zlib (wersja skrośna MinGW32).
 
 %package dll
 Summary:       zlib - DLL library for Windows
@@ -92,9 +99,6 @@ zlib - biblioteka DLL dla Windows.
 %ifarch i686 athlon
 cp contrib/asm686/match.S .
 %endif
-%ifarch i586
-cp contrib/asm586/match.S .
-%endif
 %endif
 
 %build
@@ -103,11 +107,12 @@ cp contrib/asm586/match.S .
        CXX="%{__cxx}" \
        AR="%{target}-ar" \
        RANLIB="%{target}-ranlib" \
-       CFLAGS="-D_REENTRANT %{rpmcflags}%{?with_asmopt: -DASMV}" \
+       CFLAGS="-D_REENTRANT -D_LARGEFILE64_SOURCE=1 %{rpmcflags}%{?with_asmopt: -DASMV}" \
        DLLWRAP="%{target}-dllwrap" \
        RC="%{target}-windres" \
-       prefix="%{_prefix}" \
        CP="install" \
+       IMPLIB="libz.dll.a" \
+       prefix="%{_prefix}" \
        %{?with_asmopt:OBJA=match.o}
 
 # used by libtool to detect dependencies
@@ -118,10 +123,10 @@ cat << "EOF" >> libz.la
 # Made by czarny czarny at pld-linux.org
 
 # The name that we can dlopen(3).
-dlname='../bin/zlib1.dll'
+dlname='%{_dlldir}/zlib1.dll'
 
 # Names of this library.
-library_names='libzdll.a'
+library_names='libz.dll.a'
 
 # The name of the static archive.
 old_library='libz.a'
@@ -148,7 +153,7 @@ dlpreopen=''
 libdir='%{_libdir}'
 EOF
 
-sed -e 's=@prefix@=%{_prefix}=;s=@exec_prefix@=%{_prefix}=;s=@libdir@=%{_libdir}=;s=@includedir@=%{_includedir}=;s=@VERSION@=%{version}=' \
+sed -e 's=@prefix@=%{_prefix}=;s=@exec_prefix@=%{_prefix}=;s=@\(shared\)\?libdir@=%{_libdir}=;s=@includedir@=%{_includedir}=;s=@VERSION@=%{version}=' \
        < zlib.pc.in > zlib.pc
 
 %if 0%{!?debug:1}
@@ -162,20 +167,18 @@ install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir},%{_dlldir},%{_pkgconfigdir}
 
 install zlib.h $RPM_BUILD_ROOT%{_includedir}
 install zconf.h $RPM_BUILD_ROOT%{_includedir}
-install libzdll.a $RPM_BUILD_ROOT%{_libdir}
+install libz.dll.a $RPM_BUILD_ROOT%{_libdir}
 install libz.a $RPM_BUILD_ROOT%{_libdir}
 install libz.la $RPM_BUILD_ROOT%{_libdir}
 install zlib1.dll $RPM_BUILD_ROOT%{_dlldir}
 install zlib.pc $RPM_BUILD_ROOT%{_pkgconfigdir}
 
-rm -rf $RPM_BUILD_ROOT%{_datadir}/man
-
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%{_libdir}/libzdll.a
+%{_libdir}/libz.dll.a
 %{_libdir}/libz.la
 %{_includedir}/zconf.h
 %{_includedir}/zlib.h
This page took 0.377781 seconds and 4 git commands to generate.