]> git.pld-linux.org Git - packages/crossmingw32-zlib.git/blobdiff - crossmingw32-zlib.spec
- build using configure
[packages/crossmingw32-zlib.git] / crossmingw32-zlib.spec
index 528a417433ef0ff78c030cd4b259f84ef4637399..08d692cfad40752be15e6c7997f116e4b1d7f86f 100644 (file)
@@ -36,8 +36,15 @@ BuildRoot:   %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                no_install_post_strip   1
 
 %define                target                  i386-mingw32
+%define                target_platform         i386-pc-mingw32
 %define                arch                    %{_prefix}/%{target}
+%define                gccarch                 %{_prefix}/lib/gcc-lib/%{target}
+%define                gcclib                  %{_prefix}/lib/gcc-lib/%{target}/%{version}
 
+%define                _sysprefix              /usr
+%define                _prefix                 %{_sysprefix}/%{target}
+%define                _aclocaldir             %{_datadir}/aclocal
+%define                _pkgconfigdir           %{_libdir}/pkgconfig
 %define                __cc                    %{target}-gcc
 %define                __cxx                   %{target}-g++
 
@@ -153,11 +160,48 @@ AR="%{target}-ar rc" \
 RANLIB="%{target}-ranlib" \
 CFLAGS="-D_REENTRANT %{rpmcflags}%{?with_asmopt: -DASMV}" \
 ./configure \
-       --prefix=%{arch}
+       --prefix=%{_prefix}
 
 %{__make}
 %{__make} z.dll
 
+cat << "EOF" >> libz.la
+# libz.la - a libtool library file
+# Generated by ltmain.sh - GNU libtool 1.5.22 (1.1220.2.365 2005/12/18 22:14:06)
+# ^^^^ This line needs to stay
+# Made by czarny czarny at pld-linux.org
+
+# The name that we can dlopen(3).
+dlname='../bin/libz.dll'
+
+# Names of this library.
+library_names='libz.dll.a'
+
+# The name of the static archive.
+old_library='libz.a'
+
+# Libraries that this one depends upon.
+dependency_libs=''
+
+# Version information for libz.
+current=0
+age=0
+revision=0
+
+# Is this an already installed library?
+installed=yes
+
+# Should we warn about portability when linking against -modules?
+shouldnotlink=no
+
+# Files to dlopen/dlpreopen
+dlopen=''
+dlpreopen=''
+
+# Directory that this library needs to be installed in:
+libdir='%{_libdir}'
+EOF
+
 %if 0%{!?debug:1}
 %{target}-strip -R.comment -R.note z.dll
 %{target}-strip -g -R.comment -R.note *.a
@@ -165,24 +209,26 @@ CFLAGS="-D_REENTRANT %{rpmcflags}%{?with_asmopt: -DASMV}" \
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{arch}{/lib,/include}
-install -d $RPM_BUILD_ROOT%{_datadir}/wine/windows/system
+install -d $RPM_BUILD_ROOT%{_prefix}/{/lib,/include,/bin}
 
 %{__make} install \
-       prefix=$RPM_BUILD_ROOT%{arch}
+       prefix=$RPM_BUILD_ROOT%{_prefix}
+    
 
-install zutil.h $RPM_BUILD_ROOT%{arch}/include
-install libz.dll.a $RPM_BUILD_ROOT%{arch}/lib
-install z.dll $RPM_BUILD_ROOT%{_datadir}/wine/windows/system
+install zutil.h $RPM_BUILD_ROOT%{_includedir}
+install libz.dll.a $RPM_BUILD_ROOT%{_libdir}
+install z.dll $RPM_BUILD_ROOT%{_bindir}/libz.dll
+install libz.la $RPM_BUILD_ROOT%{_libdir}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%{arch}/include/*.h
-%{arch}/lib/*
+#%{arch}/include/*.h
+%{_includedir}/*.h
+%{_libdir}/*
 
 %files dll
 %defattr(644,root,root,755)
-%{_datadir}/wine/windows/system/*
+%{_bindir}/*.dll
This page took 0.110124 seconds and 4 git commands to generate.