]> git.pld-linux.org Git - packages/crossmingw32-zlib.git/blob - crossmingw32-zlib.spec
- updated to 1.2.4 (adds LFS)
[packages/crossmingw32-zlib.git] / crossmingw32-zlib.spec
1 #
2 # Conditional build:
3 %bcond_without  asmopt  # without assmbler optimization for i586+
4 #
5 # disable asmopt where not applicable
6 %ifarch i386 i486
7 %undefine       with_asmopt
8 %endif
9 %ifnarch %{ix86}
10 %undefine       with_asmopt
11 %endif
12 %define         realname                zlib
13 Summary:        Library for compression and decompression - Ming32 cross version
14 Summary(pl.UTF-8):      Biblioteka z podprogramami do kompresji i dekompresji - wersja skrośna dla Ming32
15 Name:           crossmingw32-%{realname}
16 Version:        1.2.4
17 Release:        1
18 License:        BSD
19 Group:          Development/Libraries
20 Source0:        http://www.zlib.net/current/%{realname}-%{version}.tar.gz
21 # Source0-md5:  47f6ed51b3c83a8534f9228531effa18
22 #Patch0:                %{realname}-asmopt.patch
23 Patch0:         %{name}-shared.patch
24 URL:            http://www.zlib.org/
25 BuildRequires:  crossmingw32-gcc
26 BuildRequires:  sed >= 4.0
27 Requires:       crossmingw32-runtime
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %define         no_install_post_strip   1
31
32 %define         target                  i386-mingw32
33 %define         target_platform         i386-pc-mingw32
34
35 %define         _sysprefix              /usr
36 %define         _prefix                 %{_sysprefix}/%{target}
37 %define         _libdir                 %{_prefix}/lib
38 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
39 %define         _dlldir                 /usr/share/wine/windows/system
40 %define         __cc                    %{target}-gcc
41 %define         __cxx                   %{target}-g++
42
43 %ifarch alpha sparc sparc64 sparcv9
44 %define         optflags        -O2
45 %endif
46
47 %description
48 The 'zlib' compression library provides in-memory compression and
49 decompression functions, including integrity checks of the
50 uncompressed data. This version of the library supports only one
51 compression method (deflation) but other algorithms may be added later
52 and will have the same stream interface.
53
54 This package contains the cross version for Win32.
55
56 %description -l pl.UTF-8
57 Biblioteka zlib udostępnia podprogramy do kompresji i dekompresji w
58 pamięci operacyjnej włącznie ze sprawdzaniem integralności w trakcie
59 dekompresji. Ta wersja biblioteki udostępnia tylko jedną metodę
60 kompresji o nazwie deflation niemniej inne algorytmy mogą być
61 dodawane udostępniając taki sam interfejs funkcji operujących na
62 strumieniu danych.
63
64 Ten pakiet zawiera wersję skrośną dla Win32.
65
66 %package static
67 Summary:        Static zlib library (cross mingw32 version)
68 Summary(pl.UTF-8):      Statyczna biblioteka zlib (wersja skrośna mingw32)
69 Group:          Development/Libraries
70 Requires:       %{name} = %{version}-%{release}
71
72 %description static
73 Static zlib library (cross mingw32 version).
74
75 %description static -l pl.UTF-8
76 Statyczna biblioteka zlib (wersja skrośna mingw32).
77
78 %package dll
79 Summary:        zlib - DLL library for Windows
80 Summary(pl.UTF-8):      zlib - biblioteka DLL dla Windows
81 Group:          Applications/Emulators
82 Requires:       wine
83
84 %description dll
85 zlib - DLL library for Windows.
86
87 %description dll -l pl.UTF-8
88 zlib - biblioteka DLL dla Windows.
89
90 %prep
91 %setup -q -n %{realname}-%{version}
92 %patch0 -p1
93
94 %if %{with asmopt}
95 %ifarch i686 athlon
96 cp contrib/asm686/match.S .
97 %endif
98 %ifarch i586
99 cp contrib/asm586/match.S .
100 %endif
101 %endif
102
103 # fix for underline test
104 #sed -i -e 's/nm/%{target}-nm/' configure
105 # but it's broken anyway (tries to use mmap test remains, but there is no mmap
106 # in mingw32) - so hardcode that underline is needed
107 sed -i -e 's/.*grep _hello.*/if false; then/' configure
108 # vim '
109
110 %build
111 CC="%{__cc}" \
112 CXX="%{__cxx}" \
113 AR="%{target}-ar" \
114 RANLIB="%{target}-ranlib" \
115 CFLAGS="-D_REENTRANT %{rpmcflags}%{?with_asmopt: -DASMV}" \
116 ./configure \
117         --static \
118         --prefix=%{_prefix}
119
120 %{__make} static z.dll \
121         %{?with_asmopt:OBJA=match.o}
122
123 # used by libtool to detect dependencies
124 cat << "EOF" >> libz.la
125 # libz.la - a libtool library file
126 # Generated by ltmain.sh - GNU libtool 1.5.22 (1.1220.2.365 2005/12/18 22:14:06)
127 # ^^^^ This line needs to stay
128 # Made by czarny czarny at pld-linux.org
129
130 # The name that we can dlopen(3).
131 dlname='../bin/libz.dll'
132
133 # Names of this library.
134 library_names='libz.dll.a'
135
136 # The name of the static archive.
137 old_library='libz.a'
138
139 # Libraries that this one depends upon.
140 dependency_libs=''
141
142 # Version information for libz.
143 current=0
144 age=0
145 revision=0
146
147 # Is this an already installed library?
148 installed=yes
149
150 # Should we warn about portability when linking against -modules?
151 shouldnotlink=no
152
153 # Files to dlopen/dlpreopen
154 dlopen=''
155 dlpreopen=''
156
157 # Directory that this library needs to be installed in:
158 libdir='%{_libdir}'
159 EOF
160
161 %if 0%{!?debug:1}
162 %{target}-strip -R.comment -R.note z.dll
163 %{target}-strip -g -R.comment -R.note *.a
164 %endif
165
166 %install
167 rm -rf $RPM_BUILD_ROOT
168 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir},%{_dlldir}}
169
170 %{__make} install \
171         prefix=$RPM_BUILD_ROOT%{_prefix}
172
173 install zutil.h $RPM_BUILD_ROOT%{_includedir}
174 install libz.dll.a $RPM_BUILD_ROOT%{_libdir}
175 install libz.la $RPM_BUILD_ROOT%{_libdir}
176 install z.dll $RPM_BUILD_ROOT%{_dlldir}/libz.dll
177
178 rm -rf $RPM_BUILD_ROOT%{_datadir}/man
179
180 %clean
181 rm -rf $RPM_BUILD_ROOT
182
183 %files
184 %defattr(644,root,root,755)
185 %{_libdir}/libz.dll.a
186 %{_libdir}/libz.la
187 %{_includedir}/zconf.h
188 %{_includedir}/zlib.h
189 %{_includedir}/zutil.h
190 %{_pkgconfigdir}/zlib.pc
191
192 %files static
193 %defattr(644,root,root,755)
194 %{_libdir}/libz.a
195
196 %files dll
197 %defattr(644,root,root,755)
198 %{_dlldir}/libz.dll
This page took 0.082706 seconds and 4 git commands to generate.