]> git.pld-linux.org Git - packages/crossmingw32-zlib.git/blob - crossmingw32-zlib.spec
43636196112575d41ed33aef89260f7668ca31f4
[packages/crossmingw32-zlib.git] / crossmingw32-zlib.spec
1 #
2 # Conditional build:
3 %bcond_without  asmopt  # without assembler optimization for i686+
4 #
5 # disable asmopt where not applicable
6 %ifarch i386 i486 i586
7 %undefine       with_asmopt
8 %endif
9 %ifnarch %{ix86}
10 %undefine       with_asmopt
11 %endif
12 %define         realname                zlib
13 Summary:        Library for compression and decompression - MinGW32 cross version
14 Summary(pl.UTF-8):      Biblioteka z podprogramami do kompresji i dekompresji - wersja skrośna dla MinGW32
15 Name:           crossmingw32-%{realname}
16 Version:        1.2.6
17 Release:        1
18 License:        BSD
19 Group:          Development/Libraries
20 Source0:        http://www.zlib.net/current/%{realname}-%{version}.tar.gz
21 # Source0-md5:  618e944d7c7cd6521551e30b32322f4a
22 URL:            http://www.zlib.net/
23 BuildRequires:  crossmingw32-gcc
24 BuildRequires:  sed >= 4.0
25 Requires:       crossmingw32-runtime
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         no_install_post_strip   1
29
30 %define         target                  i386-mingw32
31 %define         target_platform         i386-pc-mingw32
32
33 %define         _sysprefix              /usr
34 %define         _prefix                 %{_sysprefix}/%{target}
35 %define         _libdir                 %{_prefix}/lib
36 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
37 %define         _dlldir                 /usr/share/wine/windows/system
38 %define         __cc                    %{target}-gcc
39 %define         __cxx                   %{target}-g++
40
41 %ifarch alpha sparc sparc64 sparcv9
42 %define         optflags        -O2
43 %endif
44
45 %description
46 The 'zlib' compression library provides in-memory compression and
47 decompression functions, including integrity checks of the
48 uncompressed data. This version of the library supports only one
49 compression method (deflation) but other algorithms may be added later
50 and will have the same stream interface.
51
52 This package contains the cross version for Win32.
53
54 %description -l pl.UTF-8
55 Biblioteka zlib udostępnia podprogramy do kompresji i dekompresji w
56 pamięci operacyjnej włącznie ze sprawdzaniem integralności w trakcie
57 dekompresji. Ta wersja biblioteki udostępnia tylko jedną metodę
58 kompresji o nazwie deflation niemniej inne algorytmy mogą być
59 dodawane udostępniając taki sam interfejs funkcji operujących na
60 strumieniu danych.
61
62 Ten pakiet zawiera wersję skrośną dla Win32.
63
64 %package static
65 Summary:        Static zlib library (cross MinGW32 version)
66 Summary(pl.UTF-8):      Statyczna biblioteka zlib (wersja skrośna MinGW32)
67 Group:          Development/Libraries
68 Requires:       %{name} = %{version}-%{release}
69
70 %description static
71 Static zlib library (cross MinGW32 version).
72
73 %description static -l pl.UTF-8
74 Statyczna biblioteka zlib (wersja skrośna MinGW32).
75
76 %package dll
77 Summary:        zlib - DLL library for Windows
78 Summary(pl.UTF-8):      zlib - biblioteka DLL dla Windows
79 Group:          Applications/Emulators
80 Requires:       wine
81
82 %description dll
83 zlib - DLL library for Windows.
84
85 %description dll -l pl.UTF-8
86 zlib - biblioteka DLL dla Windows.
87
88 %prep
89 %setup -q -n %{realname}-%{version}
90
91 %if %{with asmopt}
92 %ifarch i686 athlon
93 cp contrib/asm686/match.S .
94 %endif
95 %endif
96
97 %build
98 %{__make} -fwin32/Makefile.gcc all \
99         CC="%{__cc}" \
100         CXX="%{__cxx}" \
101         AR="%{target}-ar" \
102         RANLIB="%{target}-ranlib" \
103         CFLAGS="-D_REENTRANT -D_LARGEFILE64_SOURCE=1 %{rpmcflags}%{?with_asmopt: -DASMV}" \
104         DLLWRAP="%{target}-dllwrap" \
105         RC="%{target}-windres" \
106         CP="install" \
107         IMPLIB="libz.dll.a" \
108         prefix="%{_prefix}" \
109         %{?with_asmopt:OBJA=match.o}
110
111 # used by libtool to detect dependencies
112 cat << "EOF" >> libz.la
113 # libz.la - a libtool library file
114 # Generated by ltmain.sh - GNU libtool 1.5.22 (1.1220.2.365 2005/12/18 22:14:06)
115 # ^^^^ This line needs to stay
116 # Made by czarny czarny at pld-linux.org
117
118 # The name that we can dlopen(3).
119 dlname='%{_dlldir}/zlib1.dll'
120
121 # Names of this library.
122 library_names='libz.dll.a'
123
124 # The name of the static archive.
125 old_library='libz.a'
126
127 # Libraries that this one depends upon.
128 dependency_libs=''
129
130 # Version information for libz.
131 current=0
132 age=0
133 revision=0
134
135 # Is this an already installed library?
136 installed=yes
137
138 # Should we warn about portability when linking against -modules?
139 shouldnotlink=no
140
141 # Files to dlopen/dlpreopen
142 dlopen=''
143 dlpreopen=''
144
145 # Directory that this library needs to be installed in:
146 libdir='%{_libdir}'
147 EOF
148
149 sed -e 's=@prefix@=%{_prefix}=;s=@exec_prefix@=%{_prefix}=;s=@\(shared\)\?libdir@=%{_libdir}=;s=@includedir@=%{_includedir}=;s=@VERSION@=%{version}=' \
150         < zlib.pc.in > zlib.pc
151
152 %if 0%{!?debug:1}
153 %{target}-strip -R.comment -R.note zlib1.dll
154 %{target}-strip -g -R.comment -R.note *.a
155 %endif
156
157 %install
158 rm -rf $RPM_BUILD_ROOT
159 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir},%{_dlldir},%{_pkgconfigdir}}
160
161 install zlib.h $RPM_BUILD_ROOT%{_includedir}
162 install zconf.h $RPM_BUILD_ROOT%{_includedir}
163 install libz.dll.a $RPM_BUILD_ROOT%{_libdir}
164 install libz.a $RPM_BUILD_ROOT%{_libdir}
165 install libz.la $RPM_BUILD_ROOT%{_libdir}
166 install zlib1.dll $RPM_BUILD_ROOT%{_dlldir}
167 install zlib.pc $RPM_BUILD_ROOT%{_pkgconfigdir}
168
169 %clean
170 rm -rf $RPM_BUILD_ROOT
171
172 %files
173 %defattr(644,root,root,755)
174 %{_libdir}/libz.dll.a
175 %{_libdir}/libz.la
176 %{_includedir}/zconf.h
177 %{_includedir}/zlib.h
178 %{_pkgconfigdir}/zlib.pc
179
180 %files static
181 %defattr(644,root,root,755)
182 %{_libdir}/libz.a
183
184 %files dll
185 %defattr(644,root,root,755)
186 %{_dlldir}/zlib1.dll
This page took 0.078067 seconds and 2 git commands to generate.