]> git.pld-linux.org Git - packages/crossmingw32-zlib.git/blob - crossmingw32-zlib.spec
33669b52677dd1f6ca603d0ad8272288cfc80910
[packages/crossmingw32-zlib.git] / crossmingw32-zlib.spec
1 #
2 # Conditional build:
3 %bcond_without  asmopt  # without assmbler optimization for i586+
4 #
5 # disable asmopt where not applicable
6 %ifarch i386 i486
7 %undefine       with_asmopt
8 %endif
9 %ifnarch %{ix86}
10 %undefine       with_asmopt
11 %endif
12 %define         realname                zlib
13 Summary:        Library for compression and decompression - Ming32 cross version
14 Summary(pl.UTF-8):      Biblioteka z podprogramami do kompresji i dekompresji - wersja skrośna dla Ming32
15 Name:           crossmingw32-%{realname}
16 Version:        1.2.4
17 Release:        2
18 License:        BSD
19 Group:          Development/Libraries
20 Source0:        http://www.zlib.net/current/%{realname}-%{version}.tar.gz
21 # Source0-md5:  47f6ed51b3c83a8534f9228531effa18
22 URL:            http://www.zlib.org/
23 BuildRequires:  crossmingw32-gcc
24 BuildRequires:  sed >= 4.0
25 Requires:       crossmingw32-runtime
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         no_install_post_strip   1
29
30 %define         target                  i386-mingw32
31 %define         target_platform         i386-pc-mingw32
32
33 %define         _sysprefix              /usr
34 %define         _prefix                 %{_sysprefix}/%{target}
35 %define         _libdir                 %{_prefix}/lib
36 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
37 %define         _dlldir                 /usr/share/wine/windows/system
38 %define         __cc                    %{target}-gcc
39 %define         __cxx                   %{target}-g++
40
41 %ifarch alpha sparc sparc64 sparcv9
42 %define         optflags        -O2
43 %endif
44
45 %description
46 The 'zlib' compression library provides in-memory compression and
47 decompression functions, including integrity checks of the
48 uncompressed data. This version of the library supports only one
49 compression method (deflation) but other algorithms may be added later
50 and will have the same stream interface.
51
52 This package contains the cross version for Win32.
53
54 %description -l pl.UTF-8
55 Biblioteka zlib udostępnia podprogramy do kompresji i dekompresji w
56 pamięci operacyjnej włącznie ze sprawdzaniem integralności w trakcie
57 dekompresji. Ta wersja biblioteki udostępnia tylko jedną metodę
58 kompresji o nazwie deflation niemniej inne algorytmy mogą być
59 dodawane udostępniając taki sam interfejs funkcji operujących na
60 strumieniu danych.
61
62 Ten pakiet zawiera wersję skrośną dla Win32.
63
64 %package static
65 Summary:        Static zlib library (cross mingw32 version)
66 Summary(pl.UTF-8):      Statyczna biblioteka zlib (wersja skrośna mingw32)
67 Group:          Development/Libraries
68 Requires:       %{name} = %{version}-%{release}
69
70 %description static
71 Static zlib library (cross mingw32 version).
72
73 %description static -l pl.UTF-8
74 Statyczna biblioteka zlib (wersja skrośna mingw32).
75
76 %package dll
77 Summary:        zlib - DLL library for Windows
78 Summary(pl.UTF-8):      zlib - biblioteka DLL dla Windows
79 Group:          Applications/Emulators
80 Requires:       wine
81
82 %description dll
83 zlib - DLL library for Windows.
84
85 %description dll -l pl.UTF-8
86 zlib - biblioteka DLL dla Windows.
87
88 %prep
89 %setup -q -n %{realname}-%{version}
90
91 %if %{with asmopt}
92 %ifarch i686 athlon
93 cp contrib/asm686/match.S .
94 %endif
95 %ifarch i586
96 cp contrib/asm586/match.S .
97 %endif
98 %endif
99
100 %build
101 %{__make} -fwin32/Makefile.gcc all \
102         CC="%{__cc}" \
103         CXX="%{__cxx}" \
104         AR="%{target}-ar" \
105         RANLIB="%{target}-ranlib" \
106         CFLAGS="-D_REENTRANT %{rpmcflags}%{?with_asmopt: -DASMV}" \
107         DLLWRAP="%{target}-dllwrap" \
108         RC="%{target}-windres" \
109         prefix="%{_prefix}" \
110         CP="install" \
111         %{?with_asmopt:OBJA=match.o}
112
113 # used by libtool to detect dependencies
114 cat << "EOF" >> libz.la
115 # libz.la - a libtool library file
116 # Generated by ltmain.sh - GNU libtool 1.5.22 (1.1220.2.365 2005/12/18 22:14:06)
117 # ^^^^ This line needs to stay
118 # Made by czarny czarny at pld-linux.org
119
120 # The name that we can dlopen(3).
121 dlname='../bin/zlib1.dll'
122
123 # Names of this library.
124 library_names='libzdll.a'
125
126 # The name of the static archive.
127 old_library='libz.a'
128
129 # Libraries that this one depends upon.
130 dependency_libs=''
131
132 # Version information for libz.
133 current=0
134 age=0
135 revision=0
136
137 # Is this an already installed library?
138 installed=yes
139
140 # Should we warn about portability when linking against -modules?
141 shouldnotlink=no
142
143 # Files to dlopen/dlpreopen
144 dlopen=''
145 dlpreopen=''
146
147 # Directory that this library needs to be installed in:
148 libdir='%{_libdir}'
149 EOF
150
151 sed -e 's=@prefix@=%{_prefix}=;s=@exec_prefix@=%{_prefix}=;s=@libdir@=%{_libdir}=;s=@includedir@=%{_includedir}=;s=@VERSION@=%{version}=' \
152         < zlib.pc.in > zlib.pc
153
154 %if 0%{!?debug:1}
155 %{target}-strip -R.comment -R.note zlib1.dll
156 %{target}-strip -g -R.comment -R.note *.a
157 %endif
158
159 %install
160 rm -rf $RPM_BUILD_ROOT
161 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir},%{_dlldir},%{_pkgconfigdir}}
162
163 install zlib.h $RPM_BUILD_ROOT%{_includedir}
164 install zconf.h $RPM_BUILD_ROOT%{_includedir}
165 install libzdll.a $RPM_BUILD_ROOT%{_libdir}
166 install libz.a $RPM_BUILD_ROOT%{_libdir}
167 install libz.la $RPM_BUILD_ROOT%{_libdir}
168 install zlib1.dll $RPM_BUILD_ROOT%{_dlldir}
169 install zlib.pc $RPM_BUILD_ROOT%{_pkgconfigdir}
170
171 rm -rf $RPM_BUILD_ROOT%{_datadir}/man
172
173 %clean
174 rm -rf $RPM_BUILD_ROOT
175
176 %files
177 %defattr(644,root,root,755)
178 %{_libdir}/libzdll.a
179 %{_libdir}/libz.la
180 %{_includedir}/zconf.h
181 %{_includedir}/zlib.h
182 %{_pkgconfigdir}/zlib.pc
183
184 %files static
185 %defattr(644,root,root,755)
186 %{_libdir}/libz.a
187
188 %files dll
189 %defattr(644,root,root,755)
190 %{_dlldir}/zlib1.dll
This page took 0.033102 seconds and 2 git commands to generate.