]> git.pld-linux.org Git - packages/crossmingw32-zlib.git/blame_incremental - crossmingw32-zlib.spec
- updated to 1.2.11
[packages/crossmingw32-zlib.git] / crossmingw32-zlib.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_with asmopt # without assembler optimization for i686+
4 # (asm is unsupported by upstream and unmaintained)
5#
6# disable asmopt where not applicable
7%ifarch i386 i486 i586
8%undefine with_asmopt
9%endif
10%ifnarch %{ix86}
11%undefine with_asmopt
12%endif
13%define realname zlib
14Summary: Library for compression and decompression - MinGW32 cross version
15Summary(pl.UTF-8): Biblioteka z podprogramami do kompresji i dekompresji - wersja skrośna dla MinGW32
16Name: crossmingw32-%{realname}
17Version: 1.2.11
18Release: 1
19License: BSD
20Group: Development/Libraries
21Source0: http://www.zlib.net/current/%{realname}-%{version}.tar.gz
22# Source0-md5: 1c9f62f0778697a09d36121ead88e08e
23URL: http://www.zlib.net/
24BuildRequires: crossmingw32-gcc
25BuildRequires: sed >= 4.0
26Requires: crossmingw32-runtime
27BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29%define no_install_post_strip 1
30
31%define target i386-mingw32
32%define target_platform i386-pc-mingw32
33
34%define _sysprefix /usr
35%define _prefix %{_sysprefix}/%{target}
36%define _libdir %{_prefix}/lib
37%define _pkgconfigdir %{_prefix}/lib/pkgconfig
38%define _dlldir /usr/share/wine/windows/system
39%define __cc %{target}-gcc
40%define __cxx %{target}-g++
41%define __pkgconfig_provides %{nil}
42%define __pkgconfig_requires %{nil}
43
44%ifarch alpha sparc sparc64 sparcv9
45%define optflags -O2
46%endif
47
48# -z options are invalid for mingw linker, most of -f options are Linux-specific
49%define filterout_ld -Wl,-z,.*
50%define filterout_c -f[-a-z0-9=]*
51
52%description
53The 'zlib' compression library provides in-memory compression and
54decompression functions, including integrity checks of the
55uncompressed data. This version of the library supports only one
56compression method (deflation) but other algorithms may be added later
57and will have the same stream interface.
58
59This package contains the cross version for Win32.
60
61%description -l pl.UTF-8
62Biblioteka zlib udostępnia podprogramy do kompresji i dekompresji w
63pamięci operacyjnej włącznie ze sprawdzaniem integralności w trakcie
64dekompresji. Ta wersja biblioteki udostępnia tylko jedną metodę
65kompresji o nazwie deflation niemniej inne algorytmy mogą być
66dodawane udostępniając taki sam interfejs funkcji operujących na
67strumieniu danych.
68
69Ten pakiet zawiera wersję skrośną dla Win32.
70
71%package static
72Summary: Static zlib library (cross MinGW32 version)
73Summary(pl.UTF-8): Statyczna biblioteka zlib (wersja skrośna MinGW32)
74Group: Development/Libraries
75Requires: %{name} = %{version}-%{release}
76
77%description static
78Static zlib library (cross MinGW32 version).
79
80%description static -l pl.UTF-8
81Statyczna biblioteka zlib (wersja skrośna MinGW32).
82
83%package dll
84Summary: zlib - DLL library for Windows
85Summary(pl.UTF-8): zlib - biblioteka DLL dla Windows
86Group: Applications/Emulators
87Requires: wine
88
89%description dll
90zlib - DLL library for Windows.
91
92%description dll -l pl.UTF-8
93zlib - biblioteka DLL dla Windows.
94
95%prep
96%setup -q -n %{realname}-%{version}
97
98%if %{with asmopt}
99%ifarch i686 athlon
100cp contrib/asm686/match.S .
101%endif
102%endif
103
104%build
105%{__make} -fwin32/Makefile.gcc all \
106 CC="%{__cc}" \
107 CXX="%{__cxx}" \
108 AR="%{target}-ar" \
109 RANLIB="%{target}-ranlib" \
110 CFLAGS="-D_REENTRANT -D_LARGEFILE64_SOURCE=1 %{rpmcflags}%{?with_asmopt: -DASMV}" \
111 DLLWRAP="%{target}-dllwrap" \
112 RC="%{target}-windres" \
113 CP="install" \
114 IMPLIB="libz.dll.a" \
115 prefix="%{_prefix}" \
116 %{?with_asmopt:OBJA=match.o}
117
118# used by libtool to detect dependencies
119cat << "EOF" >> libz.la
120# libz.la - a libtool library file
121# Generated by ltmain.sh - GNU libtool 1.5.22 (1.1220.2.365 2005/12/18 22:14:06)
122# ^^^^ This line needs to stay
123# Made by czarny czarny at pld-linux.org
124
125# The name that we can dlopen(3).
126dlname='%{_dlldir}/zlib1.dll'
127
128# Names of this library.
129library_names='libz.dll.a'
130
131# The name of the static archive.
132old_library='libz.a'
133
134# Libraries that this one depends upon.
135dependency_libs=''
136
137# Version information for libz.
138current=0
139age=0
140revision=0
141
142# Is this an already installed library?
143installed=yes
144
145# Should we warn about portability when linking against -modules?
146shouldnotlink=no
147
148# Files to dlopen/dlpreopen
149dlopen=''
150dlpreopen=''
151
152# Directory that this library needs to be installed in:
153libdir='%{_libdir}'
154EOF
155
156sed -e 's=@prefix@=%{_prefix}=;s=@exec_prefix@=%{_prefix}=;s=@\(shared\)\?libdir@=%{_libdir}=;s=@includedir@=%{_includedir}=;s=@VERSION@=%{version}=' \
157 < zlib.pc.in > zlib.pc
158
159%if 0%{!?debug:1}
160%{target}-strip -R.comment -R.note zlib1.dll
161%{target}-strip -g -R.comment -R.note *.a
162%endif
163
164%install
165rm -rf $RPM_BUILD_ROOT
166install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir},%{_dlldir},%{_pkgconfigdir}}
167
168install zlib.h $RPM_BUILD_ROOT%{_includedir}
169install zconf.h $RPM_BUILD_ROOT%{_includedir}
170install libz.dll.a $RPM_BUILD_ROOT%{_libdir}
171install libz.a $RPM_BUILD_ROOT%{_libdir}
172install libz.la $RPM_BUILD_ROOT%{_libdir}
173install zlib1.dll $RPM_BUILD_ROOT%{_dlldir}
174install zlib.pc $RPM_BUILD_ROOT%{_pkgconfigdir}
175
176%clean
177rm -rf $RPM_BUILD_ROOT
178
179%files
180%defattr(644,root,root,755)
181%{_libdir}/libz.dll.a
182%{_libdir}/libz.la
183%{_includedir}/zconf.h
184%{_includedir}/zlib.h
185%{_pkgconfigdir}/zlib.pc
186
187%files static
188%defattr(644,root,root,755)
189%{_libdir}/libz.a
190
191%files dll
192%defattr(644,root,root,755)
193%{_dlldir}/zlib1.dll
This page took 0.064903 seconds and 4 git commands to generate.