]> git.pld-linux.org Git - packages/crossmingw32-runtime.git/blame - crossmingw32-runtime.spec
- added ptw32 patch (drop ptw32-errno hack which appeared to be withdrawn idea);...
[packages/crossmingw32-runtime.git] / crossmingw32-runtime.spec
CommitLineData
7cfc6460
JB
1Summary: MinGW32 Binary Utility Development Utilities - runtime libraries
2Summary(pl.UTF-8): Zestaw narzędzi MinGW32 - biblioteki uruchomieniowe
3dbe179e 3Name: crossmingw32-runtime
75a9cc84 4Version: 5.4.2
cfc40c06 5Release: 2
3dbe179e 6Epoch: 1
47d4578c 7License: BSD-like
3dbe179e 8Group: Development/Libraries
75a9cc84
JB
9#Source0Download: https://osdn.net/projects/mingw/releases/
10Source0: https://osdn.net/projects/mingw/downloads/74925/mingwrt-%{version}-mingw32-src.tar.xz
11# Source0-md5: 09f7ed7f4b134448ec4f9112f8a241f5
310c8b34
JB
12Patch0: %{name}-gawk.patch
13Patch1: %{name}-stdinc.patch
75a9cc84 14Patch2: %{name}-oldlib.patch
58a8f9ea 15Patch3: %{name}-memalign-includes.patch
cfc40c06 16Patch4: %{name}-ptw32.patch
75a9cc84 17URL: https://osdn.net/projects/mingw/
47d4578c 18BuildRequires: autoconf >= 2.68
22e52151 19BuildRequires: automake
30cdd931
AF
20BuildRequires: crossmingw32-binutils
21BuildRequires: crossmingw32-gcc
310c8b34 22BuildRequires: crossmingw32-w32api >= 1:%{version}
1213f0a0 23BuildRequires: dos2unix
75a9cc84
JB
24BuildRequires: tar >= 1:1.22
25BuildRequires: xz
cbf4bf21 26Requires: crossmingw32-binutils >= 2.15.91.0.2-2
310c8b34 27Requires: crossmingw32-w32api >= 1:%{version}
cfc40c06 28Obsoletes: crossmingw32-platform < 2.4
3dbe179e
JB
29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
509ceed2 31%define target i386-mingw32
32%define target_platform i386-pc-mingw32
33%define _prefix /usr/%{target}
34%define _libdir %{_prefix}/lib
4876bd58 35%define _dlldir /usr/share/wine/windows/system
3dbe179e
JB
36
37# strip fails on static COFF files
75a9cc84
JB
38%define no_install_post_strip 1
39%define _enable_debug_packages 0
3dbe179e 40
47d4578c
JB
41# -z options are invalid for mingw linker, most of -f options are Linux-specific
42%define filterout_ld -Wl,-z,.*
43%define filterout_c -f[-a-z0-9=]* -gdwarf-3
44
45%ifnarch %{ix86}
46# arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
47%define optflags -O2
48%endif
49
3dbe179e
JB
50%description
51crossmingw32 is a complete cross-compiling development system for
52building stand-alone Microsoft Windows applications under Linux using
7cfc6460 53the MinGW32 build libraries. This includes a binutils, gcc with g++
3dbe179e
JB
54and objc, and libstdc++, all cross targeted to i386-mingw32, along
55with supporting Win32 libraries in 'coff' format from free sources.
56
57This package contains MinGW32 runtime includes and libraries.
58
93ef0e0c
JR
59%description -l pl.UTF-8
60crossmingw32 jest kompletnym systemem do kompilacji skrośnej,
61pozwalającym budować aplikacje MS Windows pod Linuksem używając
7cfc6460 62bibliotek MinGW32. System składa się z binutils, gcc z g++ i objc,
93ef0e0c 63libstdc++ - wszystkie generujące kod dla platformy i386-mingw32, oraz
0708bafe 64z bibliotek w formacie COFF.
3dbe179e 65
93ef0e0c 66Ten pakiet zawiera pliki nagłówkowe i biblioteki uruchomieniowe
3dbe179e
JB
67MinGW32.
68
4876bd58
JB
69%package dll
70Summary: MinGW32 runtime DLL library for Windows
71Summary(pl.UTF-8): Biblioteka uruchomieniowa MingW32 DLL dla Windows
72Group: Applications/Emulators
73
74%description dll
75MinGW32 runtime DLL library for Windows.
76
77%description dll -l pl.UTF-8
78Biblioteka uruchomieniowa MingW32 DLL dla Windows.
79
3dbe179e 80%prep
310c8b34 81%setup -q -n mingwrt-%{version}
47d4578c
JB
82dos2unix Makefile.in configure.ac */Makefile.in
83%patch0 -p1
84%patch1 -p1
75a9cc84 85%patch2 -p1
58a8f9ea 86%patch3 -p1
cfc40c06 87%patch4 -p1
30cdd931
AF
88
89%build
75a9cc84 90cp -p %{_includedir}/w32api.h w32api.h.in
22e52151 91cp /usr/share/automake/config.sub .
30cdd931 92%{__autoconf}
30cdd931
AF
93./configure \
94 --prefix=%{_prefix} \
47d4578c 95 --libdir=%{_libdir} \
30cdd931
AF
96 --host=%{target} \
97 --build=%{_target_platform}
75a9cc84
JB
98
99%{__make} -j1 all all-optional-dlls \
100 w32api_srcdir=%{_prefix}
3dbe179e
JB
101
102%install
103rm -rf $RPM_BUILD_ROOT
47d4578c 104
75a9cc84 105%{__make} -j1 install install-optional-dlls \
47d4578c 106 DESTDIR=$RPM_BUILD_ROOT
30cdd931 107
47d4578c 108install -d $RPM_BUILD_ROOT%{_dlldir}
310c8b34 109%{__mv} $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
47d4578c 110
58a8f9ea
JB
111# required by <_mingw.h>, missing from install
112cp -p features.h $RPM_BUILD_ROOT%{_includedir}
113
30cdd931 114%if %{!?debug:1}0
4876bd58 115%{target}-strip $RPM_BUILD_ROOT%{_dlldir}/*.dll
30cdd931
AF
116%{target}-strip -g $RPM_BUILD_ROOT%{_libdir}/*.a
117%endif
3dbe179e
JB
118
119%clean
120rm -rf $RPM_BUILD_ROOT
121
122%files
123%defattr(644,root,root,755)
310c8b34 124%doc CONTRIBUTORS ChangeLog DISCLAIMER README TODO readme.txt
4876bd58 125%{_includedir}/_mingw.h
75a9cc84 126%{_includedir}/alloca.h
4876bd58
JB
127%{_includedir}/assert.h
128%{_includedir}/complex.h
129%{_includedir}/conio.h
130%{_includedir}/ctype.h
131%{_includedir}/dir.h
132%{_includedir}/direct.h
133%{_includedir}/dirent.h
310c8b34 134%{_includedir}/dlfcn.h
4876bd58
JB
135%{_includedir}/dos.h
136%{_includedir}/errno.h
310c8b34 137%{_includedir}/excpt.h
4876bd58 138%{_includedir}/fcntl.h
58a8f9ea 139%{_includedir}/features.h
4876bd58
JB
140%{_includedir}/fenv.h
141%{_includedir}/float.h
142%{_includedir}/getopt.h
47d4578c 143%{_includedir}/glob.h
310c8b34 144%{_includedir}/gmon.h
4876bd58
JB
145%{_includedir}/inttypes.h
146%{_includedir}/io.h
147%{_includedir}/libgen.h
148%{_includedir}/limits.h
149%{_includedir}/locale.h
150%{_includedir}/malloc.h
151%{_includedir}/math.h
152%{_includedir}/mbctype.h
153%{_includedir}/mbstring.h
154%{_includedir}/mem.h
155%{_includedir}/memory.h
310c8b34 156%{_includedir}/msvcrtver.h
4876bd58
JB
157%{_includedir}/process.h
158%{_includedir}/profil.h
159%{_includedir}/profile.h
160%{_includedir}/search.h
161%{_includedir}/setjmp.h
162%{_includedir}/share.h
163%{_includedir}/signal.h
164%{_includedir}/stdint.h
165%{_includedir}/stdio.h
166%{_includedir}/stdlib.h
167%{_includedir}/string.h
168%{_includedir}/strings.h
169%{_includedir}/tchar.h
170%{_includedir}/time.h
171%{_includedir}/unistd.h
172%{_includedir}/utime.h
173%{_includedir}/values.h
4876bd58
JB
174%{_includedir}/wchar.h
175%{_includedir}/wctype.h
c0dc01ed
JB
176%{_includedir}/sys
177%{_libdir}/CRT_*.o
178%{_libdir}/binmode.o
179%{_libdir}/crt*.o
180%{_libdir}/dllcrt*.o
181%{_libdir}/gcrt*.o
182%{_libdir}/txtmode.o
310c8b34
JB
183%{_libdir}/libcoldname.a
184%{_libdir}/libcrtdll.a
c0dc01ed
JB
185%{_libdir}/libgmon.a
186%{_libdir}/libm.a
75a9cc84
JB
187%{_libdir}/libmemalign.a
188%{_libdir}/libmingw32.a
189%{_libdir}/libmingwex.a
190%{_libdir}/libmingwex.dll.a
191%{_libdir}/libmingwthrd.a
192%{_libdir}/libmingwthrd_old.a
c0dc01ed
JB
193%{_libdir}/libmoldname*.a
194%{_libdir}/libmsvcr*.a
4876bd58
JB
195
196%files dll
197%defattr(644,root,root,755)
198%{_dlldir}/mingwm10.dll
75a9cc84 199%{_dlldir}/libmingwex-4.dll
This page took 0.156311 seconds and 4 git commands to generate.