]> git.pld-linux.org Git - packages/crossmingw32-libxml2.git/blob - crossmingw32-libxml2.spec
do not provide pkgconfig deps in system namespace
[packages/crossmingw32-libxml2.git] / crossmingw32-libxml2.spec
1 %define         realname   libxml2
2 Summary:        libXML library - cross MinGW32 version
3 Summary(pl.UTF-8):      Biblioteka libXML wersja 2 - wersja skrośna dla MinGW32
4 Name:           crossmingw32-%{realname}
5 Version:        2.9.0
6 Release:        2
7 License:        MIT
8 Group:          Development/Libraries
9 #Source0:       http://ftp.gnome.org/pub/GNOME/sources/libxml2/2.6/%{name}-%{version}.tar.bz2
10 Source0:        ftp://xmlsoft.org/libxml2/%{realname}-%{version}.tar.gz
11 # Source0-md5:  5b9bebf4f5d2200ae2c4efe8fa6103f7
12 Patch0:         %{realname}-man_fixes.patch
13 Patch1:         %{realname}-open.gz.patch
14 Patch2:         %{realname}-largefile.patch
15 URL:            http://xmlsoft.org/
16 BuildRequires:  autoconf >= 2.68
17 BuildRequires:  automake >= 1.4
18 BuildRequires:  crossmingw32-gcc
19 BuildRequires:  crossmingw32-zlib >= 1.2.4-3
20 BuildRequires:  libtool >= 2:2.0
21 BuildRequires:  sed >= 4.0
22 Requires:       crossmingw32-zlib >= 1.2.4-3
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         no_install_post_strip   1
26
27 %define         target                  i386-mingw32
28 %define         target_platform         i386-pc-mingw32
29
30 %define         _sysprefix              /usr
31 %define         _prefix                 %{_sysprefix}/%{target}
32 %define         _libdir                 %{_prefix}/lib
33 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
34 %define         _dlldir                 /usr/share/wine/windows/system
35 %define         __cc                    %{target}-gcc
36 %define         __cxx                   %{target}-g++
37 %define         __pkgconfig_provides    %{nil}
38
39 %ifnarch %{ix86}
40 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
41 %define         optflags        -O2
42 %endif
43 # -z options are invalid for mingw linker, most of -f options are Linux-specific
44 %define         filterout_ld    -Wl,--as-needed -Wl,-z,relro -Wl,-z,combreloc
45 %define         filterout_c     -f[-a-z0-9=]*
46
47 %description
48 This library allows you to manipulate XML files.
49
50 This package contains the cross version for Win32.
51
52 %description -l pl.UTF-8
53 Biblioteka libxml2 umożliwia manipulowanie zawartością plików XML.
54
55 Ten pakiet zawiera wersję skrośną dla Win32.
56
57 %package static
58 Summary:        Static libxml2 library (cross MinGW32 version)
59 Summary(pl.UTF-8):      Statyczna biblioteka libxml2 (wersja skrośna MinGW32)
60 Group:          Development/Libraries
61 Requires:       %{name} = %{version}-%{release}
62
63 %description static
64 Static libxml2 library (cross MinGW32 version).
65
66 %description static -l pl.UTF-8
67 Statyczna biblioteka libxml2 (wersja skrośna MinGW32).
68
69 %package dll
70 Summary:        DLL libxml2 library for Windows
71 Summary(pl.UTF-8):      Biblioteka DLL libxml2 dla Windows
72 Group:          Applications/Emulators
73 Requires:       crossmingw32-zlib-dll >= 1.2.4-3
74 Requires:       wine
75
76 %description dll
77 DLL libxml2 library for Windows.
78
79 %description dll -l pl.UTF-8
80 Biblioteka DLL libxml2 dla Windows.
81
82 %prep
83 %setup -q -n %{realname}-%{version}
84 %patch0 -p1
85 %patch1 -p1
86 %patch2 -p1
87
88 %build
89 %{__libtoolize}
90 %{__aclocal}
91 %{__autoconf}
92 %{__autoheader}
93 %{__automake}
94 %configure \
95         --target=%{target} \
96         --host=%{target} \
97         --disable-silent-rules \
98         --without-python
99
100 %{__make}
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104
105 %{__make} install \
106         DESTDIR=$RPM_BUILD_ROOT
107
108 install -d $RPM_BUILD_ROOT%{_dlldir}
109 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
110
111 %if 0%{!?debug:1}
112 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
113 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
114 %endif
115
116 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/{aclocal,doc,gtk-doc,man}
117
118 %clean
119 rm -rf $RPM_BUILD_ROOT
120
121 %files
122 %defattr(644,root,root,755)
123 %doc AUTHORS ChangeLog Copyright NEWS README TODO
124 %{_libdir}/libxml2.dll.a
125 %{_libdir}/libxml2.la
126 %{_includedir}/libxml2
127 %{_pkgconfigdir}/libxml-2.0.pc
128
129 %files static
130 %defattr(644,root,root,755)
131 %{_libdir}/libxml2.a
132
133 %files dll
134 %defattr(644,root,root,755)
135 %{_dlldir}/libxml2-*.dll
This page took 0.036619 seconds and 3 git commands to generate.