]> git.pld-linux.org Git - packages/crossmingw32-libvorbis.git/blob - crossmingw32-libvorbis.spec
- updated to 1.3.7 (fixes CVE-2017-14160 CVE-2018-10393)
[packages/crossmingw32-libvorbis.git] / crossmingw32-libvorbis.spec
1 %define         realname        libvorbis
2 Summary:        The Vorbis General Audio Compression Codec - MinGW32 cross version
3 Summary(pl.UTF-8):      Kodek kompresji audio - Vorbis - wersja skrośna dla MinGW32
4 Name:           crossmingw32-%{realname}
5 Version:        1.3.6
6 Release:        1
7 License:        BSD
8 Group:          Development/Libraries
9 Source0:        https://downloads.xiph.org/releases/vorbis/%{realname}-%{version}.tar.xz
10 # Source0-md5:  b7d1692f275c73e7833ed1cc2697cd65
11 Patch0:         %{realname}-make.patch
12 URL:            https://xiph.org/vorbis/
13 BuildRequires:  autoconf >= 2.50
14 BuildRequires:  automake >= 1:1.6
15 BuildRequires:  crossmingw32-gcc >= 3.0
16 BuildRequires:  crossmingw32-libogg >= 1.0
17 BuildRequires:  crossmingw32-w32api
18 BuildRequires:  libtool
19 BuildRequires:  pkgconfig >= 1:0.15
20 BuildRequires:  sed >= 4.0
21 BuildRequires:  tar >= 1:1.22
22 BuildRequires:  xz
23 Requires:       crossmingw32-libogg >= 1.0
24 Requires:       crossmingw32-runtime
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         no_install_post_strip   1
28
29 %define         target                  i386-mingw32
30 %define         target_platform         %{target}
31
32 %define         _sysprefix              /usr
33 %define         _prefix                 %{_sysprefix}/%{target}
34 %define         _libdir                 %{_prefix}/lib
35 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
36 %define         _dlldir                 /usr/share/wine/windows/system
37 %define         __cc                    %{target}-gcc
38 %define         __cxx                   %{target}-g++
39
40 %ifnarch %{ix86}
41 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
42 %define         optflags        -O2
43 %endif
44 # -z options are invalid for mingw linker, most of -f options are Linux-specific
45 %define         filterout_ld    -Wl,-z,.*
46 %define         filterout_c     -f[-a-z0-9=]*
47
48 %description
49 Ogg Vorbis is a fully open, non-proprietary, patent-and-royalty-free,
50 general-purpose compressed audio format for audio and music at fixed
51 and variable bitrates from 16 to 128 kbps/channel.
52
53 This package contains the cross version for Win32.
54
55 %description -l pl.UTF-8
56 Ogg Vorbis jest całkowicie otwartym, nie będącym niczyją własnością,
57 wolnym od patentów, ogólnego przeznaczenia kodekiem audio i muzyki o
58 stałej i zmiennej bitrate od 16 do 128 kbps/kanał.
59
60 Ten pakiet zawiera wersję skrośną dla Win32.
61
62 %package static
63 Summary:        Static libvorbis library (cross MinGW32 version)
64 Summary(pl.UTF-8):      Statyczna biblioteka libvorbis (wersja skrośna MinGW32)
65 Group:          Development/Libraries
66 Requires:       %{name} = %{version}-%{release}
67
68 %description static
69 Static libvorbis library (cross MinGW32 version).
70
71 %description static -l pl.UTF-8
72 Statyczna biblioteka libvorbis (wersja skrośna MinGW32).
73
74 %package dll
75 Summary:        DLL libvorbis library for Windows
76 Summary(pl.UTF-8):      Biblioteka DLL libvorbis dla Windows
77 Group:          Applications/Emulators
78 Requires:       crossmingw32-libogg-dll >= 1.0
79 Requires:       wine
80
81 %description dll
82 DLL libvorbis library for Windows.
83
84 %description dll -l pl.UTF-8
85 Biblioteka DLL libvorbis dla Windows.
86
87 %prep
88 %setup -q -n %{realname}-%{version}
89 %patch0 -p1
90
91 %build
92 export PKG_CONFIG_LIBDIR=%{_prefix}/lib/pkgconfig
93 %{__libtoolize}
94 %{__aclocal} -I m4
95 %{__autoconf}
96 %{__autoheader}
97 %{__automake}
98 %configure \
99         OBJDUMP=%{target}-objdump \
100         --host=%{target} \
101         --target=%{target} \
102         --disable-silent-rules
103
104 %{__make}
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108
109 %{__make} install \
110         DESTDIR=$RPM_BUILD_ROOT
111
112 install -d $RPM_BUILD_ROOT%{_dlldir}
113 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
114
115 %if 0%{!?debug:1}
116 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
117 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
118 %endif
119
120 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/{aclocal,doc}
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %files
126 %defattr(644,root,root,755)
127 %doc AUTHORS CHANGES COPYING
128 %{_libdir}/libvorbis.dll.a
129 %{_libdir}/libvorbisenc.dll.a
130 %{_libdir}/libvorbisfile.dll.a
131 %{_libdir}/libvorbis.la
132 %{_libdir}/libvorbisenc.la
133 %{_libdir}/libvorbisfile.la
134 %{_includedir}/vorbis
135 %{_pkgconfigdir}/vorbis.pc
136 %{_pkgconfigdir}/vorbisenc.pc
137 %{_pkgconfigdir}/vorbisfile.pc
138
139 %files static
140 %defattr(644,root,root,755)
141 %{_libdir}/libvorbis.a
142 %{_libdir}/libvorbisenc.a
143 %{_libdir}/libvorbisfile.a
144
145 %files dll
146 %defattr(644,root,root,755)
147 %{_dlldir}/libvorbis-*.dll
148 %{_dlldir}/libvorbisenc-*.dll
149 %{_dlldir}/libvorbisfile-*.dll
This page took 0.067954 seconds and 3 git commands to generate.