]> git.pld-linux.org Git - packages/crossmingw32-libtiff.git/blob - crossmingw32-libtiff.spec
- cleanup, separated -static,-dll
[packages/crossmingw32-libtiff.git] / crossmingw32-libtiff.spec
1 Summary:        Library for handling TIFF files - cross Mingw32 version
2 Summary(pl.UTF-8):      Biblioteka do manipulacji plikami w formacie TIFF - wersja skrośna Mingw32
3 %define         _realname   libtiff
4 Name:           crossmingw32-%{_realname}
5 Version:        3.8.2
6 Release:        1
7 License:        BSD-like
8 Group:          Development/Libraries
9 Source0:        ftp://ftp.remotesensing.org/pub/libtiff/tiff-%{version}.tar.gz
10 # Source0-md5:  fbb6f446ea4ed18955e2714934e5b698
11 Patch0:         %{_realname}-sec.patch
12 URL:            http://www.remotesensing.org/libtiff/
13 BuildRequires:  autoconf >= 2.59
14 BuildRequires:  automake
15 BuildRequires:  crossmingw32-gcc
16 BuildRequires:  crossmingw32-libjpeg
17 BuildRequires:  crossmingw32-zlib
18 BuildRequires:  libtool
19 Requires:       crossmingw32-libjpeg
20 Requires:       crossmingw32-zlib
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         no_install_post_strip   1
24
25 %define         target                  i386-mingw32
26 %define         target_platform         i386-pc-mingw32
27 %define         arch                    %{_prefix}/%{target}
28
29 %define         _sysprefix              /usr
30 %define         _prefix                 %{_sysprefix}/%{target}
31 %define         _dlldir                 /usr/share/windows/wine/system
32 %define         __cc                    %{target}-gcc
33 %define         __cxx                   %{target}-g++
34
35 %description
36 This package is a library of functions that manipulate TIFF images
37 (cross mingw32 version).
38
39 %description -l pl.UTF-8
40 Ten pakiet zawiera bibliotekę pozwalającą manipulować plikami w
41 formacie TIFF (w wersji skrośnej mingw32).
42
43 %package static
44 Summary:        Static libtiff library (cross mingw32 version)
45 Summary(pl.UTF-8):      Statyczna biblioteka libtiff (wersja skrośna mingw32)
46 Group:          Development/Libraries
47 Requires:       %{name} = %{version}-%{release}
48
49 %description static
50 Static libtiff library (cross mingw32 version).
51
52 %description static -l pl.UTF-8
53 Statyczna biblioteka libtiff (wersja skrośna mingw32).
54
55 %package dll
56 Summary:        DLL libtiff library for Windows
57 Summary(pl.UTF-8):      Biblioteka DLL libtiff dla Windows
58 Group:          Applications/Emulators
59 Requires:       wine
60 Requires:       crossmingw32-libjpeg-dll
61 Requires:       crossmingw32-zlib-dll
62
63 %description dll
64 DLL libtiff library for Windows.
65
66 %description dll -l pl.UTF-8
67 Biblioteka DLL libtiff dla Windows.
68
69 %package cxx
70 Summary:        libtiff C++ streams library (cross mingw32 version)
71 Summary(pl.UTF-8):      Biblioteka strumieni C++ dla libtiff (wersja skrośna mingw32)
72 Group:          Development/Libraries
73 Requires:       %{name} = %{version}-%{release}
74
75 %description cxx
76 libtiff C++ streams library (cross mingw32 version).
77
78 %description cxx -l pl.UTF-8
79 Biblioteka strumieni C++ dla libtiff (wersja skrośna mingw32).
80
81 %package cxx-static
82 Summary:        Static libtiff C++ streams library (cross mingw32 version)
83 Summary(pl.UTF-8):      Statyczna biblioteka strumieni C++ dla libtiff (wersja skrośna mingw32)
84 Group:          Development/Libraries
85 Requires:       %{name}-cxx = %{version}-%{release}
86
87 %description cxx-static
88 Static libtiff C++ streams library (cross mingw32 version).
89
90 %description cxx-static -l pl.UTF-8
91 Statyczna biblioteka strumieni C++ dla libtiff (wersja skrośna
92 mingw32).
93
94 %package cxx-dll
95 Summary:        DLL libtiff C++ streams library for Windows
96 Summary(pl.UTF-8):      Biblioteka DLL strumieni C++ libtiff dla Windows
97 Group:          Applications/Emulators
98 Requires:       %{name}-dll = %{version}-%{release}
99
100 %description cxx-dll
101 DLL libtiff C++ streams library for Windows.
102
103 %description cxx-dll -l pl.UTF-8
104 Biblioteka DLL strumieni C++ libtiff dla Windows.
105
106 %prep
107 %setup -q -n tiff-%{version}
108 %patch0 -p1
109
110 rm -f m4/{libtool,lt*}.m4
111
112 %build
113 %{__libtoolize}
114 %{__aclocal} -I m4
115 %{__autoconf}
116 %{__autoheader}
117 %{__automake}
118 %configure \
119         lt_cv_deplibs_check_method=pass_all \
120         --target=%{target} \
121         --host=%{target} \
122         --enable-static
123 %{__make}
124
125 %install
126 rm -rf $RPM_BUILD_ROOT
127
128 %{__make} install \
129         DESTDIR=$RPM_BUILD_ROOT
130
131 install -d $RPM_BUILD_ROOT%{_dlldir}
132 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
133
134 %if 0%{!?debug:1}
135 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
136 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
137 %endif
138
139 rm -rf $RPM_BUILD_ROOT%{_datadir}/{doc,man}
140
141 %clean
142 rm -rf $RPM_BUILD_ROOT
143
144 %files
145 %defattr(644,root,root,755)
146 %doc COPYRIGHT ChangeLog README TODO
147 %{_libdir}/libtiff.dll.a
148 %{_libdir}/libtiff.la
149 %{_includedir}/tiff*.h
150
151 %files static
152 %defattr(644,root,root,755)
153 %{_libdir}/libtiff.a
154
155 %files dll
156 %defattr(644,root,root,755)
157 %{_dlldir}/libtiff-*.dll
158
159 %files cxx
160 %defattr(644,root,root,755)
161 %{_libdir}/libtiffxx.dll.a
162 %{_libdir}/libtiffxx.la
163 %{_includedir}/tiffio.hxx
164
165 %files cxx-static
166 %defattr(644,root,root,755)
167 %{_libdir}/libtiffxx.a
168
169 %files cxx-dll
170 %defattr(644,root,root,755)
171 %{_dlldir}/libtiffxx-*.dll
This page took 0.091405 seconds and 4 git commands to generate.