]> git.pld-linux.org Git - packages/crossmingw32-libtiff.git/blob - crossmingw32-libtiff.spec
do not provide pkgconfig deps in system namespace
[packages/crossmingw32-libtiff.git] / crossmingw32-libtiff.spec
1 # TODO: jbigkit support
2 Summary:        Library for handling TIFF files - cross MinGW32 version
3 Summary(pl.UTF-8):      Biblioteka do manipulacji plikami w formacie TIFF - wersja skrośna MinGW32
4 %define         realname   libtiff
5 Name:           crossmingw32-%{realname}
6 Version:        4.0.3
7 Release:        2
8 License:        BSD-like
9 Group:          Development/Libraries
10 Source0:        http://download.osgeo.org/libtiff/tiff-%{version}.tar.gz
11 # Source0-md5:  051c1068e6a0627f461948c365290410
12 Patch0:         %{realname}-glut.patch
13 URL:            http://www.remotesensing.org/libtiff/
14 BuildRequires:  autoconf >= 2.64
15 BuildRequires:  automake >= 1:1.11
16 BuildRequires:  crossmingw32-gcc-c++
17 BuildRequires:  crossmingw32-libjpeg
18 BuildRequires:  crossmingw32-zlib
19 BuildRequires:  libtool >= 2:2.2
20 Requires:       crossmingw32-libjpeg
21 Requires:       crossmingw32-xz
22 Requires:       crossmingw32-zlib
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         no_install_post_strip   1
26
27 %define         target                  i386-mingw32
28 %define         target_platform         i386-pc-mingw32
29
30 %define         _sysprefix              /usr
31 %define         _prefix                 %{_sysprefix}/%{target}
32 %define         _libdir                 %{_prefix}/lib
33 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
34 %define         _dlldir                 /usr/share/wine/windows/system
35 %define         __cc                    %{target}-gcc
36 %define         __cxx                   %{target}-g++
37 %define         __pkgconfig_provides    %{nil}
38
39 %ifnarch %{ix86}
40 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
41 %define         optflags        -O2
42 %endif
43 # -z options are invalid for mingw linker, most of -f options are Linux-specific
44 %define         filterout_ld    -Wl,-z,.*
45 %define         filterout_c     -f[-a-z0-9=]*
46 %define         filterout_cxx   -f[-a-z0-9=]*
47
48 %description
49 This package is a library of functions that manipulate TIFF images
50 (cross MinGW32 version).
51
52 %description -l pl.UTF-8
53 Ten pakiet zawiera bibliotekę pozwalającą manipulować plikami w
54 formacie TIFF (w wersji skrośnej MinGW32).
55
56 %package static
57 Summary:        Static libtiff library (cross MinGW32 version)
58 Summary(pl.UTF-8):      Statyczna biblioteka libtiff (wersja skrośna MinGW32)
59 Group:          Development/Libraries
60 Requires:       %{name} = %{version}-%{release}
61
62 %description static
63 Static libtiff library (cross MinGW32 version).
64
65 %description static -l pl.UTF-8
66 Statyczna biblioteka libtiff (wersja skrośna MinGW32).
67
68 %package dll
69 Summary:        DLL libtiff library for Windows
70 Summary(pl.UTF-8):      Biblioteka DLL libtiff dla Windows
71 Group:          Applications/Emulators
72 Requires:       wine
73 Requires:       crossmingw32-libjpeg-dll
74 Requires:       crossmingw32-xz-dll
75 Requires:       crossmingw32-zlib-dll
76
77 %description dll
78 DLL libtiff library for Windows.
79
80 %description dll -l pl.UTF-8
81 Biblioteka DLL libtiff dla Windows.
82
83 %package cxx
84 Summary:        libtiff C++ streams library (cross MinGW32 version)
85 Summary(pl.UTF-8):      Biblioteka strumieni C++ dla libtiff (wersja skrośna MinGW32)
86 Group:          Development/Libraries
87 Requires:       %{name} = %{version}-%{release}
88
89 %description cxx
90 libtiff C++ streams library (cross MinGW32 version).
91
92 %description cxx -l pl.UTF-8
93 Biblioteka strumieni C++ dla libtiff (wersja skrośna MinGW32).
94
95 %package cxx-static
96 Summary:        Static libtiff C++ streams library (cross MinGW32 version)
97 Summary(pl.UTF-8):      Statyczna biblioteka strumieni C++ dla libtiff (wersja skrośna MinGW32)
98 Group:          Development/Libraries
99 Requires:       %{name}-cxx = %{version}-%{release}
100
101 %description cxx-static
102 Static libtiff C++ streams library (cross MinGW32 version).
103
104 %description cxx-static -l pl.UTF-8
105 Statyczna biblioteka strumieni C++ dla libtiff (wersja skrośna
106 MinGW32).
107
108 %package cxx-dll
109 Summary:        DLL libtiff C++ streams library for Windows
110 Summary(pl.UTF-8):      Biblioteka DLL strumieni C++ libtiff dla Windows
111 Group:          Applications/Emulators
112 Requires:       %{name}-dll = %{version}-%{release}
113
114 %description cxx-dll
115 DLL libtiff C++ streams library for Windows.
116
117 %description cxx-dll -l pl.UTF-8
118 Biblioteka DLL strumieni C++ libtiff dla Windows.
119
120 %prep
121 %setup -q -n tiff-%{version}
122 %patch0 -p1
123
124 %build
125 %{__libtoolize}
126 %{__aclocal} -I m4
127 %{__autoconf}
128 %{__autoheader}
129 %{__automake}
130 %configure \
131         lt_cv_deplibs_check_method=pass_all \
132         --target=%{target} \
133         --host=%{target} \
134         --enable-static
135 %{__make}
136
137 %install
138 rm -rf $RPM_BUILD_ROOT
139
140 %{__make} install \
141         DESTDIR=$RPM_BUILD_ROOT
142
143 install -d $RPM_BUILD_ROOT%{_dlldir}
144 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
145
146 %if 0%{!?debug:1}
147 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
148 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
149 %endif
150
151 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/{doc,man}
152 %{__rm} $RPM_BUILD_ROOT%{_bindir}/*.exe
153
154 %clean
155 rm -rf $RPM_BUILD_ROOT
156
157 %files
158 %defattr(644,root,root,755)
159 %doc COPYRIGHT ChangeLog README TODO
160 %{_libdir}/libtiff.dll.a
161 %{_libdir}/libtiff.la
162 %{_includedir}/tiff*.h
163 %{_pkgconfigdir}/libtiff-4.pc
164
165 %files static
166 %defattr(644,root,root,755)
167 %{_libdir}/libtiff.a
168
169 %files dll
170 %defattr(644,root,root,755)
171 %{_dlldir}/libtiff-*.dll
172
173 %files cxx
174 %defattr(644,root,root,755)
175 %{_libdir}/libtiffxx.dll.a
176 %{_libdir}/libtiffxx.la
177 %{_includedir}/tiffio.hxx
178
179 %files cxx-static
180 %defattr(644,root,root,755)
181 %{_libdir}/libtiffxx.a
182
183 %files cxx-dll
184 %defattr(644,root,root,755)
185 %{_dlldir}/libtiffxx-*.dll
This page took 0.038863 seconds and 4 git commands to generate.