]> git.pld-linux.org Git - packages/crossmingw32-libtiff.git/blob - crossmingw32-libtiff.spec
- added filterout_c and filterout_cxx
[packages/crossmingw32-libtiff.git] / crossmingw32-libtiff.spec
1 # TODO: jbigkit support
2 Summary:        Library for handling TIFF files - cross MinGW32 version
3 Summary(pl.UTF-8):      Biblioteka do manipulacji plikami w formacie TIFF - wersja skrośna MinGW32
4 %define         realname   libtiff
5 Name:           crossmingw32-%{realname}
6 Version:        4.0.3
7 Release:        1
8 License:        BSD-like
9 Group:          Development/Libraries
10 Source0:        http://download.osgeo.org/libtiff/tiff-%{version}.tar.gz
11 # Source0-md5:  051c1068e6a0627f461948c365290410
12 Patch0:         %{realname}-glut.patch
13 URL:            http://www.remotesensing.org/libtiff/
14 BuildRequires:  autoconf >= 2.64
15 BuildRequires:  automake >= 1:1.11
16 BuildRequires:  crossmingw32-gcc-c++
17 BuildRequires:  crossmingw32-libjpeg
18 BuildRequires:  crossmingw32-zlib
19 BuildRequires:  libtool >= 2:2.2
20 Requires:       crossmingw32-libjpeg
21 Requires:       crossmingw32-xz
22 Requires:       crossmingw32-zlib
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         no_install_post_strip   1
26
27 %define         target                  i386-mingw32
28 %define         target_platform         i386-pc-mingw32
29
30 %define         _sysprefix              /usr
31 %define         _prefix                 %{_sysprefix}/%{target}
32 %define         _libdir                 %{_prefix}/lib
33 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
34 %define         _dlldir                 /usr/share/wine/windows/system
35 %define         __cc                    %{target}-gcc
36 %define         __cxx                   %{target}-g++
37
38 %ifnarch %{ix86}
39 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
40 %define         optflags        -O2
41 %endif
42 # -z options are invalid for mingw linker, most of -f options are Linux-specific
43 %define         filterout_ld    -Wl,-z,.*
44 %define         filterout_c     -f[-a-z0-9=]*
45 %define         filterout_cxx   -f[-a-z0-9=]*
46
47 %description
48 This package is a library of functions that manipulate TIFF images
49 (cross MinGW32 version).
50
51 %description -l pl.UTF-8
52 Ten pakiet zawiera bibliotekę pozwalającą manipulować plikami w
53 formacie TIFF (w wersji skrośnej MinGW32).
54
55 %package static
56 Summary:        Static libtiff library (cross MinGW32 version)
57 Summary(pl.UTF-8):      Statyczna biblioteka libtiff (wersja skrośna MinGW32)
58 Group:          Development/Libraries
59 Requires:       %{name} = %{version}-%{release}
60
61 %description static
62 Static libtiff library (cross MinGW32 version).
63
64 %description static -l pl.UTF-8
65 Statyczna biblioteka libtiff (wersja skrośna MinGW32).
66
67 %package dll
68 Summary:        DLL libtiff library for Windows
69 Summary(pl.UTF-8):      Biblioteka DLL libtiff dla Windows
70 Group:          Applications/Emulators
71 Requires:       wine
72 Requires:       crossmingw32-libjpeg-dll
73 Requires:       crossmingw32-xz-dll
74 Requires:       crossmingw32-zlib-dll
75
76 %description dll
77 DLL libtiff library for Windows.
78
79 %description dll -l pl.UTF-8
80 Biblioteka DLL libtiff dla Windows.
81
82 %package cxx
83 Summary:        libtiff C++ streams library (cross MinGW32 version)
84 Summary(pl.UTF-8):      Biblioteka strumieni C++ dla libtiff (wersja skrośna MinGW32)
85 Group:          Development/Libraries
86 Requires:       %{name} = %{version}-%{release}
87
88 %description cxx
89 libtiff C++ streams library (cross MinGW32 version).
90
91 %description cxx -l pl.UTF-8
92 Biblioteka strumieni C++ dla libtiff (wersja skrośna MinGW32).
93
94 %package cxx-static
95 Summary:        Static libtiff C++ streams library (cross MinGW32 version)
96 Summary(pl.UTF-8):      Statyczna biblioteka strumieni C++ dla libtiff (wersja skrośna MinGW32)
97 Group:          Development/Libraries
98 Requires:       %{name}-cxx = %{version}-%{release}
99
100 %description cxx-static
101 Static libtiff C++ streams library (cross MinGW32 version).
102
103 %description cxx-static -l pl.UTF-8
104 Statyczna biblioteka strumieni C++ dla libtiff (wersja skrośna
105 MinGW32).
106
107 %package cxx-dll
108 Summary:        DLL libtiff C++ streams library for Windows
109 Summary(pl.UTF-8):      Biblioteka DLL strumieni C++ libtiff dla Windows
110 Group:          Applications/Emulators
111 Requires:       %{name}-dll = %{version}-%{release}
112
113 %description cxx-dll
114 DLL libtiff C++ streams library for Windows.
115
116 %description cxx-dll -l pl.UTF-8
117 Biblioteka DLL strumieni C++ libtiff dla Windows.
118
119 %prep
120 %setup -q -n tiff-%{version}
121 %patch0 -p1
122
123 %build
124 %{__libtoolize}
125 %{__aclocal} -I m4
126 %{__autoconf}
127 %{__autoheader}
128 %{__automake}
129 %configure \
130         lt_cv_deplibs_check_method=pass_all \
131         --target=%{target} \
132         --host=%{target} \
133         --enable-static
134 %{__make}
135
136 %install
137 rm -rf $RPM_BUILD_ROOT
138
139 %{__make} install \
140         DESTDIR=$RPM_BUILD_ROOT
141
142 install -d $RPM_BUILD_ROOT%{_dlldir}
143 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
144
145 %if 0%{!?debug:1}
146 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
147 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
148 %endif
149
150 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/{doc,man}
151 %{__rm} $RPM_BUILD_ROOT%{_bindir}/*.exe
152
153 %clean
154 rm -rf $RPM_BUILD_ROOT
155
156 %files
157 %defattr(644,root,root,755)
158 %doc COPYRIGHT ChangeLog README TODO
159 %{_libdir}/libtiff.dll.a
160 %{_libdir}/libtiff.la
161 %{_includedir}/tiff*.h
162 %{_pkgconfigdir}/libtiff-4.pc
163
164 %files static
165 %defattr(644,root,root,755)
166 %{_libdir}/libtiff.a
167
168 %files dll
169 %defattr(644,root,root,755)
170 %{_dlldir}/libtiff-*.dll
171
172 %files cxx
173 %defattr(644,root,root,755)
174 %{_libdir}/libtiffxx.dll.a
175 %{_libdir}/libtiffxx.la
176 %{_includedir}/tiffio.hxx
177
178 %files cxx-static
179 %defattr(644,root,root,755)
180 %{_libdir}/libtiffxx.a
181
182 %files cxx-dll
183 %defattr(644,root,root,755)
184 %{_dlldir}/libtiffxx-*.dll
This page took 0.066397 seconds and 4 git commands to generate.