]> git.pld-linux.org Git - packages/crossmingw32-libtiff.git/blob - crossmingw32-libtiff.spec
- updated to 4.0.3 (fixes CVE-2012-3401)
[packages/crossmingw32-libtiff.git] / crossmingw32-libtiff.spec
1 # TODO: jbigkit support
2 Summary:        Library for handling TIFF files - cross MinGW32 version
3 Summary(pl.UTF-8):      Biblioteka do manipulacji plikami w formacie TIFF - wersja skrośna MinGW32
4 %define         realname   libtiff
5 Name:           crossmingw32-%{realname}
6 Version:        4.0.3
7 Release:        1
8 License:        BSD-like
9 Group:          Development/Libraries
10 Source0:        http://download.osgeo.org/libtiff/tiff-%{version}.tar.gz
11 # Source0-md5:  051c1068e6a0627f461948c365290410
12 Patch0:         %{realname}-glut.patch
13 URL:            http://www.remotesensing.org/libtiff/
14 BuildRequires:  autoconf >= 2.64
15 BuildRequires:  automake >= 1:1.11
16 BuildRequires:  crossmingw32-gcc-c++
17 BuildRequires:  crossmingw32-libjpeg
18 BuildRequires:  crossmingw32-zlib
19 BuildRequires:  libtool >= 2:2.2
20 Requires:       crossmingw32-libjpeg
21 Requires:       crossmingw32-xz
22 Requires:       crossmingw32-zlib
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         no_install_post_strip   1
26
27 %define         target                  i386-mingw32
28 %define         target_platform         i386-pc-mingw32
29
30 %define         _sysprefix              /usr
31 %define         _prefix                 %{_sysprefix}/%{target}
32 %define         _libdir                 %{_prefix}/lib
33 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
34 %define         _dlldir                 /usr/share/wine/windows/system
35 %define         __cc                    %{target}-gcc
36 %define         __cxx                   %{target}-g++
37
38 %ifnarch %{ix86}
39 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
40 %define         optflags        -O2
41 %endif
42 # -z options are invalid for mingw linker
43 %define         filterout_ld    -Wl,-z,.*
44
45 %description
46 This package is a library of functions that manipulate TIFF images
47 (cross MinGW32 version).
48
49 %description -l pl.UTF-8
50 Ten pakiet zawiera bibliotekę pozwalającą manipulować plikami w
51 formacie TIFF (w wersji skrośnej MinGW32).
52
53 %package static
54 Summary:        Static libtiff library (cross MinGW32 version)
55 Summary(pl.UTF-8):      Statyczna biblioteka libtiff (wersja skrośna MinGW32)
56 Group:          Development/Libraries
57 Requires:       %{name} = %{version}-%{release}
58
59 %description static
60 Static libtiff library (cross MinGW32 version).
61
62 %description static -l pl.UTF-8
63 Statyczna biblioteka libtiff (wersja skrośna MinGW32).
64
65 %package dll
66 Summary:        DLL libtiff library for Windows
67 Summary(pl.UTF-8):      Biblioteka DLL libtiff dla Windows
68 Group:          Applications/Emulators
69 Requires:       wine
70 Requires:       crossmingw32-libjpeg-dll
71 Requires:       crossmingw32-xz-dll
72 Requires:       crossmingw32-zlib-dll
73
74 %description dll
75 DLL libtiff library for Windows.
76
77 %description dll -l pl.UTF-8
78 Biblioteka DLL libtiff dla Windows.
79
80 %package cxx
81 Summary:        libtiff C++ streams library (cross MinGW32 version)
82 Summary(pl.UTF-8):      Biblioteka strumieni C++ dla libtiff (wersja skrośna MinGW32)
83 Group:          Development/Libraries
84 Requires:       %{name} = %{version}-%{release}
85
86 %description cxx
87 libtiff C++ streams library (cross MinGW32 version).
88
89 %description cxx -l pl.UTF-8
90 Biblioteka strumieni C++ dla libtiff (wersja skrośna MinGW32).
91
92 %package cxx-static
93 Summary:        Static libtiff C++ streams library (cross MinGW32 version)
94 Summary(pl.UTF-8):      Statyczna biblioteka strumieni C++ dla libtiff (wersja skrośna MinGW32)
95 Group:          Development/Libraries
96 Requires:       %{name}-cxx = %{version}-%{release}
97
98 %description cxx-static
99 Static libtiff C++ streams library (cross MinGW32 version).
100
101 %description cxx-static -l pl.UTF-8
102 Statyczna biblioteka strumieni C++ dla libtiff (wersja skrośna
103 MinGW32).
104
105 %package cxx-dll
106 Summary:        DLL libtiff C++ streams library for Windows
107 Summary(pl.UTF-8):      Biblioteka DLL strumieni C++ libtiff dla Windows
108 Group:          Applications/Emulators
109 Requires:       %{name}-dll = %{version}-%{release}
110
111 %description cxx-dll
112 DLL libtiff C++ streams library for Windows.
113
114 %description cxx-dll -l pl.UTF-8
115 Biblioteka DLL strumieni C++ libtiff dla Windows.
116
117 %prep
118 %setup -q -n tiff-%{version}
119 %patch0 -p1
120
121 %build
122 %{__libtoolize}
123 %{__aclocal} -I m4
124 %{__autoconf}
125 %{__autoheader}
126 %{__automake}
127 %configure \
128         lt_cv_deplibs_check_method=pass_all \
129         --target=%{target} \
130         --host=%{target} \
131         --enable-static
132 %{__make}
133
134 %install
135 rm -rf $RPM_BUILD_ROOT
136
137 %{__make} install \
138         DESTDIR=$RPM_BUILD_ROOT
139
140 install -d $RPM_BUILD_ROOT%{_dlldir}
141 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
142
143 %if 0%{!?debug:1}
144 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
145 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
146 %endif
147
148 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/{doc,man}
149 %{__rm} $RPM_BUILD_ROOT%{_bindir}/*.exe
150
151 %clean
152 rm -rf $RPM_BUILD_ROOT
153
154 %files
155 %defattr(644,root,root,755)
156 %doc COPYRIGHT ChangeLog README TODO
157 %{_libdir}/libtiff.dll.a
158 %{_libdir}/libtiff.la
159 %{_includedir}/tiff*.h
160 %{_pkgconfigdir}/libtiff-4.pc
161
162 %files static
163 %defattr(644,root,root,755)
164 %{_libdir}/libtiff.a
165
166 %files dll
167 %defattr(644,root,root,755)
168 %{_dlldir}/libtiff-*.dll
169
170 %files cxx
171 %defattr(644,root,root,755)
172 %{_libdir}/libtiffxx.dll.a
173 %{_libdir}/libtiffxx.la
174 %{_includedir}/tiffio.hxx
175
176 %files cxx-static
177 %defattr(644,root,root,755)
178 %{_libdir}/libtiffxx.a
179
180 %files cxx-dll
181 %defattr(644,root,root,755)
182 %{_dlldir}/libtiffxx-*.dll
This page took 0.158345 seconds and 3 git commands to generate.