]> git.pld-linux.org Git - packages/crossmingw32-libtiff.git/blob - crossmingw32-libtiff.spec
- updated to 4.0.8
[packages/crossmingw32-libtiff.git] / crossmingw32-libtiff.spec
1 # TODO: jbigkit support
2 Summary:        Library for handling TIFF files - cross MinGW32 version
3 Summary(pl.UTF-8):      Biblioteka do manipulacji plikami w formacie TIFF - wersja skrośna MinGW32
4 %define         realname   libtiff
5 Name:           crossmingw32-%{realname}
6 Version:        4.0.8
7 Release:        1
8 License:        BSD-like
9 Group:          Development/Libraries
10 Source0:        http://download.osgeo.org/libtiff/tiff-%{version}.tar.gz
11 # Source0-md5:  2a7d1c1318416ddf36d5f6fa4600069b
12 Patch0:         %{realname}-glut.patch
13 URL:            http://www.remotesensing.org/libtiff/
14 BuildRequires:  autoconf >= 2.64
15 BuildRequires:  automake >= 1:1.11
16 BuildRequires:  crossmingw32-gcc-c++
17 BuildRequires:  crossmingw32-libjpeg
18 BuildRequires:  crossmingw32-zlib
19 BuildRequires:  libtool >= 2:2.2
20 Requires:       crossmingw32-libjpeg
21 Requires:       crossmingw32-xz
22 Requires:       crossmingw32-zlib
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         no_install_post_strip   1
26
27 %define         target                  i386-mingw32
28 %define         target_platform         i386-pc-mingw32
29
30 %define         _sysprefix              /usr
31 %define         _prefix                 %{_sysprefix}/%{target}
32 %define         _libdir                 %{_prefix}/lib
33 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
34 %define         _dlldir                 /usr/share/wine/windows/system
35 %define         __cc                    %{target}-gcc
36 %define         __cxx                   %{target}-g++
37 %define         __pkgconfig_provides    %{nil}
38 %define         __pkgconfig_requires    %{nil}
39
40 %ifnarch %{ix86}
41 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
42 %define         optflags        -O2
43 %endif
44 # -z options are invalid for mingw linker, most of -f options are Linux-specific
45 %define         filterout_ld    -Wl,-z,.*
46 %define         filterout_c     -f[-a-z0-9=]*
47 %define         filterout_cxx   -f[-a-z0-9=]*
48
49 %description
50 This package is a library of functions that manipulate TIFF images
51 (cross MinGW32 version).
52
53 %description -l pl.UTF-8
54 Ten pakiet zawiera bibliotekę pozwalającą manipulować plikami w
55 formacie TIFF (w wersji skrośnej MinGW32).
56
57 %package static
58 Summary:        Static libtiff library (cross MinGW32 version)
59 Summary(pl.UTF-8):      Statyczna biblioteka libtiff (wersja skrośna MinGW32)
60 Group:          Development/Libraries
61 Requires:       %{name} = %{version}-%{release}
62
63 %description static
64 Static libtiff library (cross MinGW32 version).
65
66 %description static -l pl.UTF-8
67 Statyczna biblioteka libtiff (wersja skrośna MinGW32).
68
69 %package dll
70 Summary:        DLL libtiff library for Windows
71 Summary(pl.UTF-8):      Biblioteka DLL libtiff dla Windows
72 Group:          Applications/Emulators
73 Requires:       wine
74 Requires:       crossmingw32-libjpeg-dll
75 Requires:       crossmingw32-xz-dll
76 Requires:       crossmingw32-zlib-dll
77
78 %description dll
79 DLL libtiff library for Windows.
80
81 %description dll -l pl.UTF-8
82 Biblioteka DLL libtiff dla Windows.
83
84 %package cxx
85 Summary:        libtiff C++ streams library (cross MinGW32 version)
86 Summary(pl.UTF-8):      Biblioteka strumieni C++ dla libtiff (wersja skrośna MinGW32)
87 Group:          Development/Libraries
88 Requires:       %{name} = %{version}-%{release}
89
90 %description cxx
91 libtiff C++ streams library (cross MinGW32 version).
92
93 %description cxx -l pl.UTF-8
94 Biblioteka strumieni C++ dla libtiff (wersja skrośna MinGW32).
95
96 %package cxx-static
97 Summary:        Static libtiff C++ streams library (cross MinGW32 version)
98 Summary(pl.UTF-8):      Statyczna biblioteka strumieni C++ dla libtiff (wersja skrośna MinGW32)
99 Group:          Development/Libraries
100 Requires:       %{name}-cxx = %{version}-%{release}
101
102 %description cxx-static
103 Static libtiff C++ streams library (cross MinGW32 version).
104
105 %description cxx-static -l pl.UTF-8
106 Statyczna biblioteka strumieni C++ dla libtiff (wersja skrośna
107 MinGW32).
108
109 %package cxx-dll
110 Summary:        DLL libtiff C++ streams library for Windows
111 Summary(pl.UTF-8):      Biblioteka DLL strumieni C++ libtiff dla Windows
112 Group:          Applications/Emulators
113 Requires:       %{name}-dll = %{version}-%{release}
114
115 %description cxx-dll
116 DLL libtiff C++ streams library for Windows.
117
118 %description cxx-dll -l pl.UTF-8
119 Biblioteka DLL strumieni C++ libtiff dla Windows.
120
121 %prep
122 %setup -q -n tiff-%{version}
123 %patch0 -p1
124
125 %build
126 %{__libtoolize}
127 %{__aclocal} -I m4
128 %{__autoconf}
129 %{__autoheader}
130 %{__automake}
131 %configure \
132         lt_cv_deplibs_check_method=pass_all \
133         --target=%{target} \
134         --host=%{target} \
135         --enable-static
136 %{__make}
137
138 %install
139 rm -rf $RPM_BUILD_ROOT
140
141 %{__make} install \
142         DESTDIR=$RPM_BUILD_ROOT
143
144 install -d $RPM_BUILD_ROOT%{_dlldir}
145 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
146
147 %if 0%{!?debug:1}
148 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
149 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
150 %endif
151
152 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/{doc,man}
153 %{__rm} $RPM_BUILD_ROOT%{_bindir}/*.exe
154
155 %clean
156 rm -rf $RPM_BUILD_ROOT
157
158 %files
159 %defattr(644,root,root,755)
160 %doc COPYRIGHT ChangeLog README TODO
161 %{_libdir}/libtiff.dll.a
162 %{_libdir}/libtiff.la
163 %{_includedir}/tiff*.h
164 %{_pkgconfigdir}/libtiff-4.pc
165
166 %files static
167 %defattr(644,root,root,755)
168 %{_libdir}/libtiff.a
169
170 %files dll
171 %defattr(644,root,root,755)
172 %{_dlldir}/libtiff-*.dll
173
174 %files cxx
175 %defattr(644,root,root,755)
176 %{_libdir}/libtiffxx.dll.a
177 %{_libdir}/libtiffxx.la
178 %{_includedir}/tiffio.hxx
179
180 %files cxx-static
181 %defattr(644,root,root,755)
182 %{_libdir}/libtiffxx.a
183
184 %files cxx-dll
185 %defattr(644,root,root,755)
186 %{_dlldir}/libtiffxx-*.dll
This page took 0.062742 seconds and 3 git commands to generate.