]> git.pld-linux.org Git - packages/crossmingw32-libsigc++.git/blob - crossmingw32-libsigc++.spec
- updated to 2.12.0
[packages/crossmingw32-libsigc++.git] / crossmingw32-libsigc++.spec
1 Summary:        The Typesafe Signal Framework for C++ - MinGW32 cross version
2 Summary(pl.UTF-8):      Środowisko sygnałów z kontrolą typów dla C++ - wersja skrośna dla MinGW32
3 %define         realname        libsigc++
4 Name:           crossmingw32-%{realname}
5 Version:        2.10.0
6 Release:        2
7 License:        LGPL v2.1+
8 Group:          Development/Libraries
9 Source0:        http://ftp.gnome.org/pub/GNOME/sources/libsigc++/2.10/%{realname}-%{version}.tar.xz
10 # Source0-md5:  70bcbde2c900e4925d6ef4bf50954195
11 URL:            http://libsigc.sourceforge.net/
12 BuildRequires:  autoconf >= 2.59
13 BuildRequires:  automake >= 1:1.9
14 BuildRequires:  crossmingw32-gcc-c++ >= 1:4.6
15 BuildRequires:  libtool >= 2:2.0
16 BuildRequires:  m4
17 BuildRequires:  mm-common >= 0.9.10
18 BuildRequires:  perl-base
19 BuildRequires:  pkgconfig
20 BuildRequires:  tar >= 1:1.22
21 BuildRequires:  xz
22 Requires:       crossmingw32-gcc-c++ >= 1:4.6
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         no_install_post_strip   1
26
27 %define         target                  i386-mingw32
28 %define         target_platform         i386-pc-mingw32
29
30 %define         _sysprefix              /usr
31 %define         _prefix                 %{_sysprefix}/%{target}
32 %define         _libdir                 %{_prefix}/lib
33 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
34 %define         _dlldir                 /usr/share/wine/windows/system
35 %define         __cc                    %{target}-gcc
36 %define         __cxx                   %{target}-g++
37 %define         __pkgconfig_provides    %{nil}
38 %define         __pkgconfig_requires    %{nil}
39
40 %ifnarch %{ix86}
41 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
42 %define         optflags        -O2
43 %endif
44 # -z options are invalid for mingw linker, most of -f options are Linux-specific
45 %define         filterout_ld    -Wl,-z,.*
46 %define         filterout_c     -f[-a-z0-9=]*
47 %define         filterout_cxx   -f[-a-z0-9=]*
48
49 %description
50 This library implements a full callback system for use in widget
51 libraries, abstract interfaces, and general programming. Originally
52 part of the Gtk-- widget set, libsigc++ is now a seperate library to
53 provide for more general use. It is the most complete library of its
54 kind with the ablity to connect an abstract callback to a class
55 method, function, or function object. It contains adaptor classes for
56 connection of dissimilar callbacks and has an ease of use unmatched by
57 other C++ callback libraries.
58
59 This package contains cross MinGW32 version.
60
61 %description -l pl.UTF-8
62 Ta biblioteka jest implementacją pełnego systemu callbacków do
63 używania w bibliotekach widgetów, interfejsach abstrakcyjnych i
64 ogólnym programowaniu. Oryginalnie była to część zestawu widgetów
65 Gtk--, ale jest teraz oddzielną biblioteką ogólniejszego
66 przeznaczenia. Jest to kompletna biblioteka tego typu z możliwością
67 łączenia abstrakcyjnych callbacków z metodami klas, funkcjami lub
68 obiektami funkcji. Zawiera klasy adapterów do łączenia różnych
69 callbacków.
70
71 Ten pakiet zawiera wersję skrośną MinGW32.
72
73 %package static
74 Summary:        Static libsigc++ library (cross MinGW32 version)
75 Summary(pl.UTF-8):      Statyczna biblioteka libsigc++ (wersja skrośna MinGW32)
76 Group:          Development/Libraries
77 Requires:       %{name} = %{version}-%{release}
78
79 %description static
80 Static libsigc++ library (cross MinGW32 version).
81
82 %description static -l pl.UTF-8
83 Statyczna biblioteka libsigc++ (wersja skrośna MinGW32).
84
85 %package dll
86 Summary:        DLL libsigc++ library for Windows
87 Summary(pl.UTF-8):      Biblioteka DLL libsigc++ dla Windows
88 Group:          Applications/Emulators
89 Requires:       wine
90
91 %description dll
92 DLL libsigc++ library for Windows.
93
94 %description dll -l pl.UTF-8
95 Biblioteka DLL libsigc++ dla Windows.
96
97 %prep
98 %setup -q -n %{realname}-%{version}
99
100 %build
101 %{__libtoolize}
102 %{__aclocal} -I build
103 %{__autoconf}
104 %{__automake}
105 %configure \
106         --target=%{target} \
107         --host=%{target} \
108         --disable-silent-rules \
109         --enable-static
110
111 %{__make}
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115
116 %{__make} install \
117         DESTDIR=$RPM_BUILD_ROOT
118
119 install -d $RPM_BUILD_ROOT%{_dlldir}
120 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
121
122 %if 0%{!?debug:1}
123 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
124 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
125 %endif
126
127 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/{devhelp,doc}
128
129 %clean
130 rm -rf $RPM_BUILD_ROOT
131
132 %files
133 %defattr(644,root,root,755)
134 %doc AUTHORS ChangeLog NEWS README
135 %{_libdir}/libsigc-2.0.dll.a
136 %{_libdir}/libsigc-2.0.la
137 %{_libdir}/sigc++-2.0
138 %{_includedir}/sigc++-2.0
139 %{_pkgconfigdir}/sigc++-2.0.pc
140
141 %files static
142 %defattr(644,root,root,755)
143 %{_libdir}/libsigc-2.0.a
144
145 %files dll
146 %defattr(644,root,root,755)
147 %{_dlldir}/libsigc-2.0-*.dll
This page took 0.113756 seconds and 3 git commands to generate.