]> git.pld-linux.org Git - packages/crossmingw32-libogg.git/blob - crossmingw32-libogg.spec
- updated to 1.3.5
[packages/crossmingw32-libogg.git] / crossmingw32-libogg.spec
1 %define         realname        libogg
2 Summary:        Ogg Bitstream Library - MinGW32 cross version
3 Summary(pl.UTF-8):      Biblioteka obsługi strumieni bitowych Ogg - wersja skrośna dla MinGW32
4 Name:           crossmingw32-%{realname}
5 Version:        1.3.2
6 Release:        2
7 License:        BSD
8 Group:          Development/Libraries
9 Source0:        http://downloads.xiph.org/releases/ogg/%{realname}-%{version}.tar.xz
10 # Source0-md5:  5c3a34309d8b98640827e5d0991a4015
11 Patch0:         %{realname}-ac_fixes.patch
12 URL:            http://www.xiph.org/ogg/
13 BuildRequires:  autoconf
14 BuildRequires:  automake >= 1:1.6
15 BuildRequires:  crossmingw32-gcc
16 BuildRequires:  crossmingw32-w32api
17 BuildRequires:  libtool
18 BuildRequires:  tar >= 1:1.22
19 BuildRequires:  xz
20 Requires:       crossmingw32-runtime
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         no_install_post_strip   1
24
25 %define         target                  i386-mingw32
26 %define         target_platform         %{target}
27
28 %define         _sysprefix              /usr
29 %define         _prefix                 %{_sysprefix}/%{target}
30 %define         _libdir                 %{_prefix}/lib
31 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
32 %define         _dlldir                 /usr/share/wine/windows/system
33 %define         __cc                    %{target}-gcc
34 %define         __cxx                   %{target}-g++
35
36 %ifnarch %{ix86}
37 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
38 %define         optflags        -O2
39 %endif
40 # -z options are invalid for mingw linker, most of -f options are Linux-specific
41 %define         filterout_ld    -Wl,-z,.*
42 %define         filterout_c     -f[-a-z0-9=]*
43
44 %description
45 Libogg is a library for manipulating Ogg bitstreams. It handles both
46 making Ogg bitstreams and getting packets from Ogg bitstreams.
47
48 This package contains the cross version for Win32.
49
50 %description -l pl.UTF-8
51 Libogg jest biblioteką do manipulacji strumieniami bitowymi Ogg.
52 Obsługuje ona zarówno tworzenie strumieni jak i uzyskiwanie pakietów
53 ze strumieni.
54
55 Ten pakiet zawiera wersję skrośną dla Win32.
56
57 %package static
58 Summary:        Static libogg library (cross MinGW32 version)
59 Summary(pl.UTF-8):      Statyczna biblioteka libogg (wersja skrośna MinGW32)
60 Group:          Development/Libraries
61 Requires:       %{name} = %{version}-%{release}
62
63 %description static
64 Static libogg library (cross MinGW32 version).
65
66 %description static -l pl.UTF-8
67 Statyczna biblioteka libogg (wersja skrośna MinGW32).
68
69 %package dll
70 Summary:        DLL libogg library for Windows
71 Summary(pl.UTF-8):      Biblioteka DLL libogg dla Windows
72 Group:          Applications/Emulators
73 Requires:       wine
74
75 %description dll
76 DLL libogg library for Windows.
77
78 %description dll -l pl.UTF-8
79 Biblioteka DLL libogg dla Windows.
80
81 %prep
82 %setup -q -n %{realname}-%{version}
83 %patch0 -p1
84
85 %build
86 %{__libtoolize}
87 %{__aclocal}
88 %{__autoconf}
89 %{__automake}
90 %configure \
91         --host=%{target} \
92         --target=%{target}
93
94 %{__make}
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98
99 %{__make} install \
100         DESTDIR=$RPM_BUILD_ROOT
101
102 install -d $RPM_BUILD_ROOT%{_dlldir}
103 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
104
105 %if 0%{!?debug:1}
106 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
107 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
108 %endif
109
110 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/{aclocal,doc}
111
112 %clean
113 rm -rf $RPM_BUILD_ROOT
114
115 %files
116 %defattr(644,root,root,755)
117 %doc AUTHORS CHANGES COPYING README
118 %{_libdir}/libogg.dll.a
119 %{_libdir}/libogg.la
120 %{_includedir}/ogg
121 %{_pkgconfigdir}/ogg.pc
122
123 %files static
124 %defattr(644,root,root,755)
125 %{_libdir}/libogg.a
126
127 %files dll
128 %defattr(644,root,root,755)
129 %{_dlldir}/libogg-*.dll
This page took 0.077217 seconds and 3 git commands to generate.