]> git.pld-linux.org Git - packages/crossmingw32-libjpeg.git/blob - crossmingw32-libjpeg.spec
- copy-pasto
[packages/crossmingw32-libjpeg.git] / crossmingw32-libjpeg.spec
1 %define         realname        libjpeg
2 Summary:        Library for handling different jpeg files - Mingw32 cross version
3 Summary(pl.UTF-8):      Biblioteka do manipulacji plikami w formacie jpeg - wersja skrośna dla Mingw32
4 Name:           crossmingw32-%{realname}
5 Version:        6b
6 Release:        5
7 License:        distributable
8 Group:          Development/Libraries
9 Source0:        ftp://ftp.uu.net/graphics/jpeg/jpegsrc.v%{version}.tar.gz
10 # Source0-md5:  dbd5f3b47ed13132f04c685d608a7547
11 Patch0:         %{realname}-DESTDIR.patch
12 Patch1:         %{realname}-include.patch
13 Patch2:         %{realname}-c++.patch
14 Patch3:         %{name}-shared.patch
15 URL:            http://www.ijg.org/
16 BuildRequires:  crossmingw32-gcc
17 Requires:       crossmingw32-runtime
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         no_install_post_strip   1
21
22 %define         target                  i386-mingw32
23 %define         target_platform         i386-pc-mingw32
24 %define         arch                    %{_prefix}/%{target}
25
26 %define         _sysprefix              /usr
27 %define         _prefix                 %{_sysprefix}/%{target}
28 %define         _dlldir                 /usr/share/wine/windows/system
29 %define         __cc                    %{target}-gcc
30 %define         __cxx                   %{target}-g++
31
32 %ifarch alpha sparc sparc64 sparcv9
33 %define         optflags        -O2
34 %endif
35
36 %description
37 The libjpeg package contains a library of functions for manipulating
38 JPEG images.
39
40 This package contains the cross version for Win32.
41
42 %description -l pl.UTF-8
43 Ten pakiet zawiera bibliotekę funkcji do manipulacji plikami jpeg.
44
45 Ten pakiet zawiera wersję skrośną dla Win32.
46
47 %package static
48 Summary:        Static libjpeg library (cross mingw32 version)
49 Summary(pl.UTF-8):      Statyczna biblioteka libjpeg (wersja skrośna mingw32)
50 Group:          Development/Libraries
51 Requires:       %{name} = %{version}-%{release}
52
53 %description static
54 Static libjpeg library (cross mingw32 version).
55
56 %description static -l pl.UTF-8
57 Statyczna biblioteka libjpeg (wersja skrośna mingw32).
58
59 %package dll
60 Summary:        libjpeg - DLL library for Windows
61 Summary(pl.UTF-8):      libjpeg - biblioteka DLL dla Windows
62 Group:          Applications/Emulators
63 Requires:       wine
64
65 %description dll
66 libjpeg - DLL library for Windows.
67
68 %description dll -l pl.UTF-8
69 libjpeg - biblioteka DLL dla Windows.
70
71 %prep
72 %setup -q -n jpeg-%{version}
73 %patch0 -p1
74 %patch1 -p1
75 %patch2 -p1
76 %patch3 -p1
77
78 %build
79 CC=%{target}-gcc ; export CC
80 CXX=%{target}-g++ ; export CXX
81 LD=%{target}-ld ; export LD
82 AR=%{target}-ar ; export AR
83 AS=%{target}-as ; export AS
84 CROSS_COMPILE=1 ; export CROSS_COMPILE
85 CPPFLAGS="-I%{arch}/include" ; export CPPFLAGS
86 RANLIB=%{target}-ranlib ; export RANLIB
87 LDSHARED="%{target}-gcc -shared" ; export LDSHARED
88 TARGET="%{target}" ; export TARGET
89
90 %configure \
91         --target=%{target} \
92         --host=%{target} \
93         --build=i386-linux \
94         --prefix=%{arch}
95
96 %{__make}
97 %{__make} jpeg.dll
98
99 cat << "EOF" >> libjpeg.la
100 # libjpeg.la - a libtool library file
101 # Generated by ltmain.sh - GNU libtool 1.5.22 (1.1220.2.365 2005/12/18 22:14:06)
102 # ^^^^ This line needs to stay
103 # Made by czarny czarny at pld-linux.org
104
105 # The name that we can dlopen(3).
106 dlname='../bin/libjpeg.dll'
107
108 # Names of this library.
109 library_names='libjpeg.dll.a'
110
111 # The name of the static archive.
112 old_library='libjpeg.a'
113
114 # Libraries that this one depends upon.
115 dependency_libs=''
116
117 # Version information for libjpeg.
118 current=0
119 age=0
120 revision=0
121
122 # Is this an already installed library?
123 installed=yes
124
125 # Should we warn about portability when linking against -modules?
126 shouldnotlink=no
127
128 # Files to dlopen/dlpreopen
129 dlopen=''
130 dlpreopen=''
131
132 # Directory that this library needs to be installed in:
133 libdir='%{_libdir}'
134 EOF
135
136 %if 0%{!?debug:1}
137 %{target}-strip jpeg.dll
138 %{target}-strip -g -R.comment -R.note *.a
139 %endif
140
141 %install
142 rm -rf $RPM_BUILD_ROOT
143 install -d $RPM_BUILD_ROOT{%{_includedir},%{_libdir},%{_dlldir}}
144
145 install jconfig.h jerror.h jmorecfg.h jpeglib.h jversion.h $RPM_BUILD_ROOT%{_includedir}
146 install *.a $RPM_BUILD_ROOT%{_libdir}
147 install jpeg.dll $RPM_BUILD_ROOT%{_dlldir}/libjpeg.dll
148 install libjpeg.la $RPM_BUILD_ROOT%{_libdir}
149
150 %clean
151 rm -rf $RPM_BUILD_ROOT
152
153 %files
154 %defattr(644,root,root,755)
155 %{_libdir}/libjpeg.dll.a
156 %{_libdir}/libjpeg.la
157 %{_includedir}/*.h
158
159 %files static
160 %defattr(644,root,root,755)
161 %{_libdir}/libjpeg.a
162
163 %files dll
164 %defattr(644,root,root,755)
165 %{_dlldir}/libjpeg.dll
This page took 0.040311 seconds and 4 git commands to generate.