]> git.pld-linux.org Git - packages/crossmingw32-libjpeg.git/blob - crossmingw32-libjpeg.spec
- x32 rebuild
[packages/crossmingw32-libjpeg.git] / crossmingw32-libjpeg.spec
1 %define         realname        libjpeg
2 Summary:        Library for handling different jpeg files - MinGW32 cross version
3 Summary(pl.UTF-8):      Biblioteka do manipulacji plikami w formacie jpeg - wersja skrośna dla MinGW32
4 Name:           crossmingw32-%{realname}
5 Version:        9a
6 Release:        2
7 License:        distributable
8 Group:          Development/Libraries
9 Source0:        http://www.ijg.org/files/jpegsrc.v%{version}.tar.gz
10 # Source0-md5:  3353992aecaee1805ef4109aadd433e7
11 Patch0:         %{realname}-maxmem-sysconf.patch
12 URL:            http://www.ijg.org/
13 BuildRequires:  autoconf >= 2.50
14 BuildRequires:  automake
15 BuildRequires:  crossmingw32-gcc
16 BuildRequires:  libtool
17 Requires:       crossmingw32-runtime
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         no_install_post_strip   1
21
22 %define         target                  i386-mingw32
23 %define         target_platform         i386-pc-mingw32
24
25 %define         _sysprefix              /usr
26 %define         _prefix                 %{_sysprefix}/%{target}
27 %define         _libdir                 %{_prefix}/lib
28 %define         _dlldir                 /usr/share/wine/windows/system
29 %define         __cc                    %{target}-gcc
30 %define         __cxx                   %{target}-g++
31
32 %ifnarch %{ix86}
33 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
34 %define         optflags        -O2
35 %endif
36
37 # -z options are invalid for mingw linker, most of -f options are Linux-specific
38 %define         filterout_ld    -Wl,-z,.*
39 %define         filterout_c     -f[-a-z0-9=]*
40
41 %description
42 The libjpeg package contains a library of functions for manipulating
43 JPEG images.
44
45 This package contains the cross version for Win32.
46
47 %description -l pl.UTF-8
48 Ten pakiet zawiera bibliotekę funkcji do manipulacji plikami jpeg.
49
50 Ten pakiet zawiera wersję skrośną dla Win32.
51
52 %package static
53 Summary:        Static libjpeg library (cross MinGW32 version)
54 Summary(pl.UTF-8):      Statyczna biblioteka libjpeg (wersja skrośna MinGW32)
55 Group:          Development/Libraries
56 Requires:       %{name} = %{version}-%{release}
57
58 %description static
59 Static libjpeg library (cross MinGW32 version).
60
61 %description static -l pl.UTF-8
62 Statyczna biblioteka libjpeg (wersja skrośna MinGW32).
63
64 %package dll
65 Summary:        libjpeg - DLL library for Windows
66 Summary(pl.UTF-8):      libjpeg - biblioteka DLL dla Windows
67 Group:          Applications/Emulators
68 Requires:       wine
69
70 %description dll
71 libjpeg - DLL library for Windows.
72
73 %description dll -l pl.UTF-8
74 libjpeg - biblioteka DLL dla Windows.
75
76 %prep
77 %setup -q -n jpeg-%{version}
78 %patch0 -p1
79
80 %build
81 %configure \
82         --target=%{target} \
83         --host=%{target} \
84         --disable-silent-rules
85
86 %{__make}
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90
91 %{__make} install \
92         DESTDIR=$RPM_BUILD_ROOT
93
94 install jversion.h $RPM_BUILD_ROOT%{_includedir}
95
96 # remove HAVE_STD{DEF,LIB}_H
97 # (not necessary but may generate warnings confusing autoconf)
98 sed -i -e 's#.*HAVE_STD..._H.*##g' $RPM_BUILD_ROOT%{_includedir}/jconfig.h
99
100 install -d $RPM_BUILD_ROOT%{_dlldir}
101 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
102
103 %if 0%{!?debug:1}
104 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
105 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
106 %endif
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %files
112 %defattr(644,root,root,755)
113 %doc README change.log
114 %{_libdir}/libjpeg.dll.a
115 %{_libdir}/libjpeg.la
116 %{_includedir}/jconfig.h
117 %{_includedir}/jerror.h
118 %{_includedir}/jmorecfg.h
119 %{_includedir}/jpeglib.h
120 %{_includedir}/jversion.h
121
122 %files static
123 %defattr(644,root,root,755)
124 %{_libdir}/libjpeg.a
125
126 %files dll
127 %defattr(644,root,root,755)
128 %{_dlldir}/libjpeg-9.dll
This page took 0.053472 seconds and 3 git commands to generate.