]> git.pld-linux.org Git - packages/crossmingw32-libjpeg.git/blame_incremental - crossmingw32-libjpeg.spec
- force %{_lib}-independent libdir
[packages/crossmingw32-libjpeg.git] / crossmingw32-libjpeg.spec
... / ...
CommitLineData
1%define realname libjpeg
2Summary: Library for handling different jpeg files - Mingw32 cross version
3Summary(pl.UTF-8): Biblioteka do manipulacji plikami w formacie jpeg - wersja skrośna dla Mingw32
4Name: crossmingw32-%{realname}
5Version: 6b
6Release: 5
7License: distributable
8Group: Development/Libraries
9Source0: ftp://ftp.uu.net/graphics/jpeg/jpegsrc.v%{version}.tar.gz
10# Source0-md5: dbd5f3b47ed13132f04c685d608a7547
11Patch0: %{realname}-DESTDIR.patch
12Patch1: %{realname}-include.patch
13Patch2: %{realname}-c++.patch
14Patch3: %{name}-shared.patch
15URL: http://www.ijg.org/
16BuildRequires: crossmingw32-gcc
17Requires: crossmingw32-runtime
18BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20%define no_install_post_strip 1
21
22%define target i386-mingw32
23%define target_platform i386-pc-mingw32
24
25%define _sysprefix /usr
26%define _prefix %{_sysprefix}/%{target}
27%define _libdir %{_prefix}/lib
28%define _dlldir /usr/share/wine/windows/system
29%define __cc %{target}-gcc
30%define __cxx %{target}-g++
31
32%ifarch alpha sparc sparc64 sparcv9
33%define optflags -O2
34%endif
35
36%description
37The libjpeg package contains a library of functions for manipulating
38JPEG images.
39
40This package contains the cross version for Win32.
41
42%description -l pl.UTF-8
43Ten pakiet zawiera bibliotekę funkcji do manipulacji plikami jpeg.
44
45Ten pakiet zawiera wersję skrośną dla Win32.
46
47%package static
48Summary: Static libjpeg library (cross mingw32 version)
49Summary(pl.UTF-8): Statyczna biblioteka libjpeg (wersja skrośna mingw32)
50Group: Development/Libraries
51Requires: %{name} = %{version}-%{release}
52
53%description static
54Static libjpeg library (cross mingw32 version).
55
56%description static -l pl.UTF-8
57Statyczna biblioteka libjpeg (wersja skrośna mingw32).
58
59%package dll
60Summary: libjpeg - DLL library for Windows
61Summary(pl.UTF-8): libjpeg - biblioteka DLL dla Windows
62Group: Applications/Emulators
63Requires: wine
64
65%description dll
66libjpeg - DLL library for Windows.
67
68%description dll -l pl.UTF-8
69libjpeg - biblioteka DLL dla Windows.
70
71%prep
72%setup -q -n jpeg-%{version}
73%patch0 -p1
74%patch1 -p1
75%patch2 -p1
76%patch3 -p1
77
78%build
79CC=%{target}-gcc ; export CC
80CXX=%{target}-g++ ; export CXX
81LD=%{target}-ld ; export LD
82AR=%{target}-ar ; export AR
83AS=%{target}-as ; export AS
84CROSS_COMPILE=1 ; export CROSS_COMPILE
85CPPFLAGS="-I%{_includedir}" ; export CPPFLAGS
86RANLIB=%{target}-ranlib ; export RANLIB
87LDSHARED="%{target}-gcc -shared" ; export LDSHARED
88TARGET="%{target}" ; export TARGET
89
90%configure \
91 --target=%{target} \
92 --host=%{target} \
93 --build=i386-linux
94
95%{__make}
96%{__make} jpeg.dll
97
98cat << "EOF" >> libjpeg.la
99# libjpeg.la - a libtool library file
100# Generated by ltmain.sh - GNU libtool 1.5.22 (1.1220.2.365 2005/12/18 22:14:06)
101# ^^^^ This line needs to stay
102# Made by czarny czarny at pld-linux.org
103
104# The name that we can dlopen(3).
105dlname='../bin/libjpeg.dll'
106
107# Names of this library.
108library_names='libjpeg.dll.a'
109
110# The name of the static archive.
111old_library='libjpeg.a'
112
113# Libraries that this one depends upon.
114dependency_libs=''
115
116# Version information for libjpeg.
117current=0
118age=0
119revision=0
120
121# Is this an already installed library?
122installed=yes
123
124# Should we warn about portability when linking against -modules?
125shouldnotlink=no
126
127# Files to dlopen/dlpreopen
128dlopen=''
129dlpreopen=''
130
131# Directory that this library needs to be installed in:
132libdir='%{_libdir}'
133EOF
134
135%if 0%{!?debug:1}
136%{target}-strip jpeg.dll
137%{target}-strip -g -R.comment -R.note *.a
138%endif
139
140%install
141rm -rf $RPM_BUILD_ROOT
142install -d $RPM_BUILD_ROOT{%{_includedir},%{_libdir},%{_dlldir}}
143
144install jconfig.h jerror.h jmorecfg.h jpeglib.h jversion.h $RPM_BUILD_ROOT%{_includedir}
145install *.a $RPM_BUILD_ROOT%{_libdir}
146install jpeg.dll $RPM_BUILD_ROOT%{_dlldir}/libjpeg.dll
147install libjpeg.la $RPM_BUILD_ROOT%{_libdir}
148
149%clean
150rm -rf $RPM_BUILD_ROOT
151
152%files
153%defattr(644,root,root,755)
154%{_libdir}/libjpeg.dll.a
155%{_libdir}/libjpeg.la
156%{_includedir}/*.h
157
158%files static
159%defattr(644,root,root,755)
160%{_libdir}/libjpeg.a
161
162%files dll
163%defattr(644,root,root,755)
164%{_dlldir}/libjpeg.dll
This page took 0.035456 seconds and 4 git commands to generate.