]> git.pld-linux.org Git - packages/crossmingw32-libffi.git/blob - crossmingw32-libffi.spec
- updated to 3.4.4
[packages/crossmingw32-libffi.git] / crossmingw32-libffi.spec
1 Summary:        Foreign Function Interface library (cross MinGW32 version)
2 Summary(pl.UTF-8):      Biblioteka Foreign Function Interface (wersja skrośna MinGW32)
3 Name:           crossmingw32-libffi
4 Version:        3.2.1
5 Release:        2
6 License:        MIT-like
7 Group:          Libraries
8 Source0:        ftp://sourceware.org/pub/libffi/libffi-%{version}.tar.gz
9 # Source0-md5:  83b89587607e3eb65c70d361f13bab43
10 URL:            http://sources.redhat.com/libffi/
11 BuildRequires:  texinfo
12 Requires:       crossmingw32-runtime
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %define         no_install_post_strip   1
16
17 %define         target                  i386-mingw32
18 %define         target_platform         i386-pc-mingw32
19
20 %define         _sysprefix              /usr
21 %define         _prefix                 %{_sysprefix}/%{target}
22 %define         _libdir                 %{_prefix}/lib
23 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
24 %define         _dlldir                 /usr/share/wine/windows/system
25 %define         __cc                    %{target}-gcc
26 %define         __pkgconfig_provides    %{nil}
27 %define         __pkgconfig_requires    %{nil}
28
29 %ifnarch %{ix86}
30 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
31 %define         optflags        -O2
32 %endif
33 # -z options are invalid for mingw linker, most of -f options are Linux-specific
34 %define         filterout_ld    -Wl,-z,.*
35 %define         filterout_c     -f[-a-z0-9=]*
36
37 %description
38 The libffi library provides a portable, high level programming
39 interface to various calling conventions. This allows a programmer to
40 call any function specified by a call interface description at
41 run-time.
42
43 Ffi stands for Foreign Function Interface. A foreign function
44 interface is the popular name for the interface that allows code
45 written in one language to call code written in another language. The
46 libffi library really only provides the lowest, machine dependent
47 layer of a fully featured foreign function interface. A layer must
48 exist above libffi that handles type conversions for values passed
49 between the two languages.
50
51 This package contains the cross version for MinGW32.
52
53 %description -l pl.UTF-8
54 Biblioteka libffi dostarcza przenośny, wysokopoziomowy interfejs do
55 różnych konwencji wywołań funkcji. Pozwala to programiście wywołać
56 dowolną funkcję podaną przez opis interfejsu wywołania w czasie
57 działania programu.
58
59 FFI to skrót od Foreign Function Interface, czyli interfejsu do obcych
60 funkcji. Jest to potoczna nazwa interfejsu pozwalającego programowi
61 napisanemu w jednym języku wywoływać kod napisany w innym języku.
62 Biblioteka libffi daje tylko najniższą, zależną od maszyny warstwę
63 pełnego interfejsu. Potrzebne są wyższe warstwy do obsługi konwersji
64 typów dla wartości przekazywanych pomiędzy różnymi językami.
65
66 Ten pakiet zawiera wersję skrośną dla MinGW32.
67
68 %package static
69 Summary:        Static libffi library (cross MinGW32 version)
70 Summary(pl.UTF-8):      Statyczna biblioteka libffi (wersja skrośna MinGW32)
71 Group:          Development/Libraries
72 Requires:       %{name} = %{version}-%{release}
73
74 %description static
75 Static libffi library (cross MinGW32 version).
76
77 %description static -l pl.UTF-8
78 Statyczna biblioteka libffi (wersja skrośna MinGW32).
79
80 %package dll
81 Summary:        Foreign Function Interface DLL library for Windows
82 Summary(pl.UTF-8):      Biblioteka DLL Foreign Function Interface dla Windows
83 Group:          Applications/Emulators
84 Requires:       wine
85
86 %description dll
87 Foreign Function Interface DLL library for Windows.
88
89 %description dll -l pl.UTF-8
90 Biblioteka DLL Foreign Function Interface dla Windows.
91
92 %prep
93 %setup -q -n libffi-%{version}
94
95 %build
96 %configure \
97         --target=%{target} \
98         --host=%{target}
99
100 %{__make}
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104
105 %{__make} install \
106         DESTDIR=$RPM_BUILD_ROOT
107
108 install -d $RPM_BUILD_ROOT%{_dlldir}
109 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
110
111 %if 0%{!?debug:1}
112 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
113 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
114 %endif
115
116 %{__rm} -r $RPM_BUILD_ROOT{%{_mandir},%{_infodir}}
117
118 %clean
119 rm -rf $RPM_BUILD_ROOT
120
121 %files
122 %defattr(644,root,root,755)
123 %doc ChangeLog* LICENSE README
124 %{_libdir}/libffi.dll.a
125 %{_libdir}/libffi.la
126 %{_libdir}/libffi-%{version}
127 %{_pkgconfigdir}/libffi.pc
128
129 %files static
130 %defattr(644,root,root,755)
131 %{_libdir}/libffi.a
132
133 %files dll
134 %defattr(644,root,root,755)
135 %{_dlldir}/libffi-6.dll
This page took 0.101901 seconds and 3 git commands to generate.