]> git.pld-linux.org Git - packages/crossmingw32-harfbuzz.git/commitdiff
- updated to 0.9.8
authorJakub Bogusz <qboosh@pld-linux.org>
Thu, 6 Dec 2012 17:26:47 +0000 (18:26 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Thu, 6 Dec 2012 17:26:47 +0000 (18:26 +0100)
- added void patch (resolve VOID define conflict with mingw32 headers)

crossmingw32-harfbuzz.spec
harfbuzz-void.patch [new file with mode: 0644]

index 6390b673524c3407e5c9ee7dd244bc3d20fefeb6..a1749d8ce9aea3563ea22c42c7a8efa362de8818 100644 (file)
@@ -1,12 +1,13 @@
 Summary:       HarfBuzz - internationalized text shaping library - MinGW32 cross version
 Summary(pl.UTF-8):     Rasteryzer fontów TrueType - wersja skrośna dla MinGW32
 Name:          crossmingw32-harfbuzz
-Version:       0.9.7
+Version:       0.9.8
 Release:       1
 License:       MIT
 Group:         Development/Libraries
 Source0:       http://www.freedesktop.org/software/harfbuzz/release/harfbuzz-%{version}.tar.bz2
-# Source0-md5: db5382728a912352633d3be2e2a1d988
+# Source0-md5: 13b569f0acedbdb6ffe1fb8fbb4914cc
+Patch0:                harfbuzz-void.patch
 URL:           http://www.freedesktop.org/wiki/HarfBuzz
 BuildRequires: crossmingw32-cairo >= 1.8.0
 BuildRequires: crossmingw32-freetype >= 2.3.8
@@ -84,6 +85,7 @@ Biblioteka DLL harfbuzz dla Windows.
 
 %prep
 %setup -q -n harfbuzz-%{version}
+%patch0 -p1
 
 %build
 export PKG_CONFIG_LIBDIR=%{_pkgconfigdir}
diff --git a/harfbuzz-void.patch b/harfbuzz-void.patch
new file mode 100644 (file)
index 0000000..97ae054
--- /dev/null
@@ -0,0 +1,53 @@
+--- harfbuzz-0.9.8/src/hb-private.hh.orig      2012-11-23 23:33:08.000000000 +0100
++++ harfbuzz-0.9.8/src/hb-private.hh   2012-12-06 18:21:40.215335229 +0100
+@@ -65,7 +65,7 @@
+ /* Void! */
+ struct _void_t;
+ typedef const _void_t &void_t;
+-#define VOID (* (const _void_t *) NULL)
++#define HBVOID (* (const _void_t *) NULL)
+ /* Basics */
+--- harfbuzz-0.9.8/src/hb-ot-layout-gsubgpos-private.hh.orig   2012-11-30 07:38:20.000000000 +0100
++++ harfbuzz-0.9.8/src/hb-ot-layout-gsubgpos-private.hh        2012-12-06 18:22:07.522001326 +0100
+@@ -60,8 +60,8 @@ struct hb_closure_context_t
+   typedef void_t return_t;
+   typedef return_t (*recurse_func_t) (hb_closure_context_t *c, unsigned int lookup_index);
+   template <typename T>
+-  inline return_t process (const T &obj) { obj.closure (this); return VOID; }
+-  static return_t default_return_value (void) { return VOID; }
++  inline return_t process (const T &obj) { obj.closure (this); return HBVOID; }
++  static return_t default_return_value (void) { return HBVOID; }
+   bool stop_sublookup_iteration (const return_t r) const { return false; }
+   return_t recurse (unsigned int lookup_index)
+   {
+@@ -71,7 +71,7 @@ struct hb_closure_context_t
+     nesting_level_left--;
+     recurse_func (this, lookup_index);
+     nesting_level_left++;
+-    return VOID;
++    return HBVOID;
+   }
+   hb_face_t *face;
+@@ -148,8 +148,8 @@ struct hb_collect_glyphs_context_t
+   typedef void_t return_t;
+   typedef return_t (*recurse_func_t) (hb_collect_glyphs_context_t *c, unsigned int lookup_index);
+   template <typename T>
+-  inline return_t process (const T &obj) { obj.collect_glyphs (this); return VOID; }
+-  static return_t default_return_value (void) { return VOID; }
++  inline return_t process (const T &obj) { obj.collect_glyphs (this); return HBVOID; }
++  static return_t default_return_value (void) { return HBVOID; }
+   bool stop_sublookup_iteration (const return_t r) const { return false; }
+   return_t recurse (unsigned int lookup_index)
+   {
+@@ -161,7 +161,7 @@ struct hb_collect_glyphs_context_t
+     hb_collect_glyphs_context_t new_c (this->face, NULL, NULL, NULL, &output, nesting_level_left);
+     recurse_func (&new_c, lookup_index);
+     nesting_level_left++;
+-    return VOID;
++    return HBVOID;
+   }
+   hb_face_t *face;
This page took 0.238236 seconds and 4 git commands to generate.