]> git.pld-linux.org Git - packages/crossmingw32-harfbuzz.git/commitdiff
- updated to 1.4.5 auto/th/crossmingw32-harfbuzz-1.4.5-1
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 9 Apr 2017 12:35:30 +0000 (14:35 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sun, 9 Apr 2017 12:35:30 +0000 (14:35 +0200)
- added hack for LONG typedef conflict to win32 patch

crossmingw32-harfbuzz.spec
harfbuzz-win32.patch

index d682a18ac0e7ceaab09d385cb0b5677c3fbde95a..b912bfb8f304f4e2a1ad2a6ef9b9c227f907009e 100644 (file)
@@ -1,12 +1,12 @@
 Summary:       HarfBuzz - internationalized text shaping library - MinGW32 cross version
 Summary(pl.UTF-8):     Rasteryzer fontów TrueType - wersja skrośna dla MinGW32
 Name:          crossmingw32-harfbuzz
-Version:       1.3.4
+Version:       1.4.5
 Release:       1
 License:       MIT
 Group:         Development/Libraries
 Source0:       https://www.freedesktop.org/software/harfbuzz/release/harfbuzz-%{version}.tar.bz2
-# Source0-md5: 065843caf247687b94126773285bc70f
+# Source0-md5: 635126eeab703d1729df9391ffb7983c
 Patch0:                harfbuzz-win32.patch
 URL:           https://www.freedesktop.org/wiki/HarfBuzz
 BuildRequires: autoconf >= 2.64
index d1d958775344505339cd1b81d1fec6e0107960c7..0524bf71a557c03d1a4ae179c6ecfa2edf1b6e7d 100644 (file)
  
  static inline uint16_t hb_uint16_swap (const uint16_t v)
  { return (v >> 8) | (v << 8); }
+--- harfbuzz-1.4.5/src/hb-atomic-private.hh.orig       2016-07-13 04:09:47.000000000 +0200
++++ harfbuzz-1.4.5/src/hb-atomic-private.hh    2017-04-09 14:28:37.769359459 +0200
+@@ -67,7 +67,7 @@
+ #define hb_atomic_int_impl_add(AI, V)         InterlockedExchangeAdd (&(AI), (V))
+ #define hb_atomic_ptr_impl_get(P)             (_HBMemoryBarrier (), (void *) *(P))
+-#define hb_atomic_ptr_impl_cmpexch(P,O,N)     (InterlockedCompareExchangePointer ((void **) (P), (void *) (N), (void *) (O)) == (void *) (O))
++#define hb_atomic_ptr_impl_cmpexch(P,O,N)     (((void*)InterlockedCompareExchange((long volatile*)(void **) (P), (long)(void *) (N), (long)(void *) (O))) == (void *) (O))
+ #elif !defined(HB_NO_MT) && defined(__APPLE__)
This page took 0.586337 seconds and 4 git commands to generate.