]> git.pld-linux.org Git - packages/crossmingw32-gtkmm.git/blob - crossmingw32-gtkmm.spec
- drop .la file; release 5
[packages/crossmingw32-gtkmm.git] / crossmingw32-gtkmm.spec
1 Summary:        A C++ interface for the GTK+ (a GUI library for X) - cross MinGW32 version
2 Summary(pl.UTF-8):      Wrapper C++ dla GTK+ - skrośna wersja MinGW32
3 %define         realname   gtkmm
4 Name:           crossmingw32-%{realname}
5 Version:        2.24.5
6 Release:        2
7 License:        LGPL v2+
8 Group:          Development/Libraries
9 Source0:        http://ftp.gnome.org/pub/GNOME/sources/gtkmm/2.24/%{realname}-%{version}.tar.xz
10 # Source0-md5:  6c59ae8bbff48fad9132f23af347acf1
11 URL:            http://www.gtkmm.org/
12 BuildRequires:  autoconf >= 2.59
13 BuildRequires:  automake >= 1:1.9
14 BuildRequires:  crossmingw32-atkmm >= 2.22.2
15 BuildRequires:  crossmingw32-cairomm >= 1.6.3
16 BuildRequires:  crossmingw32-gcc-c++ >= 3.3.1
17 BuildRequires:  crossmingw32-glibmm >= 2.28.0
18 BuildRequires:  crossmingw32-gtk+2 >= 2.20.0
19 BuildRequires:  crossmingw32-pangomm >= 2.28.0
20 BuildRequires:  libtool >= 2:1.5
21 BuildRequires:  mm-common >= 0.9.8
22 BuildRequires:  perl-base >= 1:5.6.0
23 BuildRequires:  pkgconfig >= 1:0.15
24 BuildRequires:  rpmbuild(macros) >= 1.446
25 BuildRequires:  tar >= 1:1.22
26 BuildRequires:  xz
27 Requires:       crossmingw32-atkmm >= 2.22.2
28 Requires:       crossmingw32-cairomm >= 1.6.3
29 Requires:       crossmingw32-gtk+2 >= 2.20.0
30 Requires:       crossmingw32-pangomm >= 2.28.0
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define         no_install_post_strip   1
34
35 %define         target                  i386-mingw32
36 %define         target_platform         i386-pc-mingw32
37
38 %define         _sysprefix              /usr
39 %define         _prefix                 %{_sysprefix}/%{target}
40 %define         _libdir                 %{_prefix}/lib
41 %define         _pkgconfigdir           %{_prefix}/lib/pkgconfig
42 %define         _dlldir                 /usr/share/wine/windows/system
43 %define         __cc                    %{target}-gcc
44 %define         __cxx                   %{target}-g++
45 %define         __pkgconfig_provides    %{nil}
46 %define         __pkgconfig_requires    %{nil}
47
48 %ifnarch %{ix86}
49 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
50 %define         optflags        -O2
51 %endif
52 # -z options are invalid for mingw linker, most of -f options are Linux-specific
53 %define         filterout_ld    -Wl,-z,.*
54 %define         filterout_c     -f[-a-z0-9=]*
55 %define         filterout_cxx   -f[-a-z0-9=]*
56
57 %description
58 This package provides a C++ interface for GTK+ (the Gimp ToolKit) GUI
59 library. The interface provides a convenient interface for C++
60 programmers to create GUIs with GTK+'s flexible object-oriented
61 framework. Features include type safe callbacks, widgets that are
62 extensible using inheritance and over 110 classes that can be freely
63 combined to quickly create complex user interfaces.
64
65 This package contains the cross version for Win32.
66
67 %description -l pl.UTF-8
68 gtkmm jest wrapperem C++ dla Gimp ToolKit (GTK). GTK+ jest biblioteką
69 służącą do tworzenia graficznych interfejsów. W pakiecie znajduje się
70 także biblioteka gdkmm - wrapper C++ dla GDK (General Drawing Kit).
71
72 Ten pakiet zawiera wersję skrośną dla Win32.
73
74 %package static
75 Summary:        Static gtkmm libraries (cross MinGW32 version)
76 Summary(pl.UTF-8):      Statyczne biblioteki gtkmm (wersja skrośna MinGW32)
77 Group:          Development/Libraries
78 Requires:       %{name} = %{version}-%{release}
79
80 %description static
81 Static gtkmm libraries (cross MinGW32 version).
82
83 %description static -l pl.UTF-8
84 Statyczne biblioteki gtkmm (wersja skrośna MinGW32).
85
86 %package dll
87 Summary:        DLL gtkmm libraries for Windows
88 Summary(pl.UTF-8):      Biblioteki DLL gtkmm dla Windows
89 Group:          Applications/Emulators
90 Requires:       crossmingw32-atkmm-dll >= 2.22.2
91 Requires:       crossmingw32-cairomm-dll >= 1.6.3
92 Requires:       crossmingw32-glibmm-dll >= 2.28.0
93 Requires:       crossmingw32-gtk+2-dll >= 2.20.0
94 Requires:       crossmingw32-pangomm-dll >= 2.28.0
95 Requires:       wine
96
97 %description dll
98 DLL gtkmm libraries for Windows.
99
100 %description dll -l pl.UTF-8
101 Biblioteki DLL gtkmm dla Windows.
102
103 %prep
104 %setup -q -n %{realname}-%{version}
105
106 %build
107 export PKG_CONFIG_LIBDIR=%{_prefix}/lib/pkgconfig:%{_npkgconfigdir}
108 %{__libtoolize}
109 %{__aclocal} -I build
110 %{__autoconf}
111 %{__autoheader}
112 %{__automake}
113 %configure \
114         --targe=%{target} \
115         --host=%{target} \
116         --disable-documentation \
117         --enable-static
118
119 %{__make}
120
121 %install
122 rm -rf $RPM_BUILD_ROOT
123
124 %{__make} install \
125         DESTDIR=$RPM_BUILD_ROOT
126
127 install -d $RPM_BUILD_ROOT%{_dlldir}
128 mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
129
130 %if 0%{!?debug:1}
131 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
132 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
133 %endif
134
135 %clean
136 rm -rf $RPM_BUILD_ROOT
137
138 %files
139 %defattr(644,root,root,755)
140 %doc AUTHORS ChangeLog NEWS PORTING README
141 %{_libdir}/libgdkmm-2.4.dll.a
142 %{_libdir}/libgtkmm-2.4.dll.a
143 %{_libdir}/libgdkmm-2.4.la
144 %{_libdir}/libgtkmm-2.4.la
145 %{_libdir}/gdkmm-2.4
146 %{_libdir}/gtkmm-2.4
147 %{_includedir}/gdkmm-2.4
148 %{_includedir}/gtkmm-2.4
149 %{_pkgconfigdir}/gdkmm-2.4.pc
150 %{_pkgconfigdir}/gtkmm-2.4.pc
151
152 %files static
153 %defattr(644,root,root,755)
154 %{_libdir}/libgdkmm-2.4.a
155 %{_libdir}/libgtkmm-2.4.a
156
157 %files dll
158 %defattr(644,root,root,755)
159 %{_dlldir}/libgdkmm-2.4-*.dll
160 %{_dlldir}/libgtkmm-2.4-*.dll
This page took 0.132346 seconds and 3 git commands to generate.