]> git.pld-linux.org Git - packages/crossmingw32-gettext.git/blobdiff - crossmingw32-gettext.patch
- updated for 0.17
[packages/crossmingw32-gettext.git] / crossmingw32-gettext.patch
index d87b061f174dac0e39f80ccc3601a338dd2a2b1b..e506589b52a7b1be1c9af658d1009228dc6aeab2 100644 (file)
@@ -1,33 +1,69 @@
-diff -uNr gettext-0.11.5/lib/Makefile.am gettext-0.11.5.2/lib/Makefile.am
---- gettext-0.11.5/lib/Makefile.am     2003-02-01 19:13:17.000000000 +0100
-+++ gettext-0.11.5.2/lib/Makefile.am   2003-08-25 18:02:56.000000000 +0200
-@@ -39,7 +39,6 @@
-   fstrcmp.h fstrcmp.c \
-   full-write.h full-write.c \
-   gcd.h gcd.c \
--  getopt.h getopt.c getopt1.c \
-   hash.h hash.c \
-   javacomp.h javacomp.c \
-   javaexec.h javaexec.c \
-diff -uNr gettext-0.11.5/lib/Makefile.in gettext-0.11.5.2/lib/Makefile.in
---- gettext-0.11.5/lib/Makefile.in     2003-02-01 19:23:37.000000000 +0100
-+++ gettext-0.11.5.2/lib/Makefile.in   2003-08-25 18:03:09.000000000 +0200
-@@ -228,7 +228,6 @@
-   fstrcmp.h fstrcmp.c \
-   full-write.h full-write.c \
-   gcd.h gcd.c \
--  getopt.h getopt.c getopt1.c \
-   hash.h hash.c \
-   javacomp.h javacomp.c \
-   javaexec.h javaexec.c \
-@@ -324,8 +323,8 @@
- libgettextlib_la_DEPENDENCIES = @LTALLOCA@ @LTLIBOBJS@
- am_libgettextlib_la_OBJECTS = argmatch.lo backupfile.lo addext.lo \
-       basename.lo c-ctype.lo copy-file.lo error.lo execute.lo \
--      findprog.lo fstrcmp.lo full-write.lo gcd.lo getopt.lo \
--      getopt1.lo hash.lo javacomp.lo javaexec.lo linebreak.lo \
-+      findprog.lo fstrcmp.lo full-write.lo gcd.lo \
-+      hash.lo javacomp.lo javaexec.lo linebreak.lo \
-       localcharset.lo mbswidth.lo obstack.lo concatpath.lo \
-       pipe-bidi.lo pipe-in.lo pipe-out.lo progname.lo safe-read.lo \
-       sh-quote.lo stpncpy.lo strtoul.lo tmpdir.lo wait-process.lo \
+--- gettext-0.12.1/gettext-runtime/intl/relocatable.c  2003-04-07 12:42:24.000000000 +0200
++++ gettext-0.12.1.good/gettext-runtime/intl/relocatable.c     2003-08-26 14:32:46.000000000 +0200
+@@ -38,6 +38,9 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
++#include <windef.h>
++#include <wtypes.h>
++#include <winbase.h>
+ #ifdef NO_XMALLOC
+ # define xmalloc malloc
+--- gettext-0.16/gettext-tools/gnulib-lib/canonicalize.c       2003-05-09 12:12:06.000000000 +0200
++++ gettext-0.16.good/gettext-tools/gnulib-lib/canonicalize.c  2003-08-26 15:22:31.000000000 +0200
+@@ -46,6 +46,7 @@
+ #endif
+ #include <sys/stat.h>
++#define lstat stat
+ #include <errno.h>
+ #ifndef _LIBC
+--- gettext-0.16/gettext-tools/gnulib-lib/mkdtemp.c    2003-01-14 14:36:07.000000000 +0100
++++ gettext-0.16.good/gettext-tools/gnulib-lib/mkdtemp.c       2003-08-26 15:08:12.000000000 +0200
+@@ -167,7 +167,7 @@
+       v /= 62;
+       XXXXXX[5] = letters[v % 62];
+-      fd = __mkdir (tmpl, S_IRUSR | S_IWUSR | S_IXUSR);
++      fd = __mkdir (tmpl);
+       if (fd >= 0)
+       {
+--- gettext-0.16/gettext-tools/gnulib-lib/relocatable.c        2003-04-07 12:42:24.000000000 +0200
++++ gettext-0.16.good/gettext-tools/gnulib-lib/relocatable.c   2003-08-26 14:08:11.000000000 +0200
+@@ -38,6 +38,8 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
++#include <windef.h>
++#include <winbase.h>
+ #ifdef NO_XMALLOC
+ # define xmalloc malloc
+--- gettext-0.16/gettext-tools/gnulib-lib/xreadlink.c  2003-02-28 13:19:46.000000000 +0100
++++ gettext-0.16.good/gettext-tools/gnulib-lib/xreadlink.c     2003-08-26 15:14:40.000000000 +0200
+@@ -66,6 +68,11 @@
+    If realloc fails, or if the link value is longer than SIZE_MAX :-),
+    give a diagnostic and exit.  */
++int readlink(const char *path, char *buf, size_t bufsiz)
++{
++    return -1;
++}
++
+ char *
+ xreadlink (char const *filename)
+ {
+--- gettext-0.16/Makefile.am.orig      2006-10-09 13:55:41.000000000 +0200
++++ gettext-0.16/Makefile.am   2006-10-30 07:48:28.900392000 +0100
+@@ -19,7 +19,7 @@
+ AUTOMAKE_OPTIONS = 1.5 gnu no-dependencies
+-SUBDIRS = gnulib-local gettext-runtime gettext-tools autoconf-lib-link
++SUBDIRS = gnulib-local gettext-runtime autoconf-lib-link
+ EXTRA_DIST = \
+   version.sh PACKAGING ChangeLog.0 autogen.sh \
This page took 0.573324 seconds and 4 git commands to generate.