]> git.pld-linux.org Git - packages/crossmingw32-gettext.git/blob - crossmingw32-gettext.spec
- automake epoch
[packages/crossmingw32-gettext.git] / crossmingw32-gettext.spec
1 #
2 # Conditional build:
3 %bcond_without  asprintf        # without libasprintf (in C++)
4 #
5 %define         realname                gettext
6 Summary:        gettext libraries - cross mingw32 version
7 Summary(pl):    Biblioteki gettext - wersja skro¶na dla mingw32
8 Name:           crossmingw32-%{realname}
9 Version:        0.14.1
10 Release:        1
11 License:        LGPL
12 Group:          Libraries
13 Source0:        ftp://ftp.gnu.org/pub/gnu/gettext/%{realname}-%{version}.tar.gz
14 # Source0-md5:  78f4b862510beb2e5d43223dd610e77d
15 Patch0:         %{realname}-info.patch
16 Patch1:         %{realname}-killkillkill.patch
17 Patch2:         %{name}.patch
18 URL:            http://www.gnu.org/software/gettext/
19 BuildRequires:  autoconf >= 2.57
20 BuildRequires:  automake >= 1:1.7.5
21 BuildRequires:  crossmingw32-gcc
22 %{?with_asprintf:BuildRequires: crossmingw32-gcc-c++}
23 BuildRequires:  crossmingw32-libiconv
24 BuildRequires:  libtool
25 BuildRequires:  texinfo
26 Requires:       crossmingw32-libiconv
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define         no_install_post_strip   1
30
31 %define         target                  i386-mingw32
32 %define         target_platform         i386-pc-mingw32
33 %define         _sysprefix              /usr
34 %define         _prefix                 %{_sysprefix}/%{target}
35
36 %define         __cc                    %{target}-gcc
37 %define         __cxx                   %{target}-g++
38
39 %description
40 gettext libraries - cross mingw32 version.
41
42 %description -l pl
43 Biblioteki gettext - wersja skro¶na dla mingw32.
44
45 %prep
46 %setup -q -n %{realname}-%{version}
47 %patch0 -p1
48 %patch1 -p1
49 %patch2 -p1
50
51 %build
52 # it's m4_included somewhere
53 install %{_aclocaldir}/libtool.m4 config/m4/libtool.m4
54 %{__libtoolize}
55 %{__aclocal}
56 %{__autoconf}
57 %{__automake}
58 cd autoconf-lib-link
59 %{__aclocal} -I m4 -I ../config/m4
60 %{__autoconf}
61 %{__automake}
62 cd ../gettext-runtime
63 %{__aclocal} -I m4 -I ../autoconf-lib-link/m4 -I ../gettext-tools/m4 -I ../config/m4
64 %{__autoconf}
65 %{__automake}
66 cd ..
67
68 %configure \
69         AR="%{target}-ar" \
70         RANLIB="%{target}-ranlib" \
71         --target=%{target} \
72         --host=%{target_platform} \
73         --disable-csharp \
74         --disable-static
75 %{__make}
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79
80 %{__make} install \
81         DESTDIR=$RPM_BUILD_ROOT
82
83 %if 0%{!?debug:1}
84 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_bindir}/*.dll
85 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
86 %endif
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %files
92 %defattr(644,root,root,755)
93 %{_bindir}/libintl-3.dll
94 %if %{with asprintf}
95 %{_libdir}/libasprintf.a
96 %{_libdir}/libasprintf.la
97 %endif
98 %{_libdir}/libintl.dll.a
99 %{_libdir}/libintl.la
100 %{_includedir}/*.h
This page took 0.059609 seconds and 4 git commands to generate.