]> git.pld-linux.org Git - packages/crossmingw32-gettext.git/blob - crossmingw32-gettext.spec
- there IS libasprintf (but requires gcc-c++)
[packages/crossmingw32-gettext.git] / crossmingw32-gettext.spec
1 #
2 # Conditional build:
3 %bcond_without  asprintf        # without libasprintf (in C++)
4 #
5 %define         realname                gettext
6 Summary:        gettext libraries - cross mingw32 version
7 Summary(pl):    Biblioteki gettext - wersja skro¶na dla mingw32
8 Name:           crossmingw32-%{realname}
9 Version:        0.13.1
10 Release:        1
11 License:        LGPL
12 Group:          Libraries
13 Source0:        ftp://ftp.gnu.org/pub/gnu/gettext/%{realname}-%{version}.tar.gz
14 # Source0-md5:  b3477289185e7781527345c14a4565de
15 Patch0:         %{realname}-info.patch
16 Patch1:         %{realname}-killkillkill.patch
17 Patch2:         %{realname}-pl.po-update.patch
18 Patch3:         %{realname}-am18.patch
19 Patch4:         %{name}.patch
20 URL:            http://www.gnu.org/software/gettext/
21 BuildRequires:  autoconf >= 2.57
22 BuildRequires:  automake >= 1.7.5
23 BuildRequires:  crossmingw32-gcc
24 %{?with_asprintf:BuildRequires: crossmingw32-gcc-c++}
25 BuildRequires:  crossmingw32-libiconv
26 BuildRequires:  libtool
27 Requires:       crossmingw32-libiconv
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %define         no_install_post_strip   1
31
32 %define         target                  i386-mingw32
33 %define         target_platform         i386-pc-mingw32
34 %define         _sysprefix              /usr
35 %define         _prefix                 %{_sysprefix}/%{target}
36
37 %define         __cc                    %{target}-gcc
38 %define         __cxx                   %{target}-g++
39
40 %description
41 gettext libraries - cross mingw32 version.
42
43 %description -l pl
44 Biblioteki gettext - wersja skro¶na dla mingw32.
45
46 %prep
47 %setup -q -n %{realname}-%{version}
48 %patch0 -p1
49 %patch1 -p1
50 %patch2 -p1
51 %patch3 -p1
52 %patch4 -p1
53
54 %build
55 %{__libtoolize}
56 %{__aclocal}
57 %{__autoconf}
58 %{__automake}
59 cd gettext-runtime
60 %{__libtoolize}
61 %{__aclocal} -I m4 -I ../autoconf-lib-link/m4 -I ../gettext-tools/m4 -I ../config/m4
62 %{__autoconf}
63 %{__automake}
64 cd ..
65
66 %configure \
67         AR="%{target}-ar" \
68         RANLIB="%{target}-ranlib" \
69         --target=%{target} \
70         --host=%{target_platform} \
71         --disable-static
72 %{__make}
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76
77 %{__make} install \
78         DESTDIR=$RPM_BUILD_ROOT
79
80 %if 0%{!?debug:1}
81 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_bindir}/*.dll
82 %{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{_libdir}/*.a
83 %endif
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %files
89 %defattr(644,root,root,755)
90 %{_bindir}/libintl-2.dll
91 %if %{with asprintf}
92 %{_libdir}/libasprintf.a
93 %{_libdir}/libasprintf.la
94 %endif
95 %{_libdir}/libintl.dll.a
96 %{_libdir}/libintl.la
97 %{_includedir}/*.h
This page took 0.081714 seconds and 4 git commands to generate.