]> git.pld-linux.org Git - packages/crossmingw32-gettext.git/blob - crossmingw32-gettext.spec
- patch for getopt bug in crossmingw32-gettext
[packages/crossmingw32-gettext.git] / crossmingw32-gettext.spec
1
2 %define         realname                gettext
3 %define         snapshot                2003.02.01-1
4 Summary:        iconv
5 Name:           crossmingw32-%{realname}
6 Version:        0.11.5
7 Release:        1
8 License:        LGPL
9 Group:          Libraries
10 Source0:        http://dl.sourceforge.net/mingw/%{realname}-%{version}-%{snapshot}-src.tar.bz2
11 URL:            http://www.gnu.org/software/gettext/
12 BuildRequires:  autoconf
13 BuildRequires:  automake
14 BuildRequires:  gtk-doc >= 0.9-4
15 BuildRequires:  libtool
16 BuildRequires:  rpm-build >= 4.1-8.2
17 BuildRequires:  crossmingw32-iconv
18 BuildRoot:      %{tmpdir}/%{realname}-%{version}-root-%(id -u -n)
19
20 %define         no_install_post_strip   1
21
22 %define         target                  i386-mingw32
23 %define         target_platform         i386-pc-mingw32
24 %define         arch                    %{_prefix}/%{target}
25 %define         gccarch                 %{_prefix}/lib/gcc-lib/%{target}
26 %define         gcclib                  %{_prefix}/lib/gcc-lib/%{target}/%{version}
27
28 %define         __cc                    %{target}-gcc
29 %define         __cxx                   %{target}-g++
30
31 %description
32 gettext
33
34 %prep
35 %setup -q -n %{realname}-%{version}
36
37 %build
38 CC=%{target}-gcc ; export CC
39 CXX=%{target}-g++ ; export CXX
40 LD=%{target}-ld ; export LD
41 AR=%{target}-ar ; export AR
42 AS=%{target}-as ; export AS
43 CROSS_COMPILE=1 ; export CROSS_COMPILE
44 CPPFLAGS="-I%{arch}/include" ; export CPPFLAGS
45 RANLIB=%{target}-ranlib ; export RANLIB
46
47 #rm -f missing
48 %{__libtoolize}
49 %{__aclocal} -I m4
50 %{__autoconf}
51
52 %configure \
53         --target=%{target} \
54         --host=%{target_platform} \
55         --prefix=%{arch} \
56         --disable-static \
57         --bindir=%{arch}/bin \
58         --libdir=%{arch}/lib \
59         --includedir=%{arch}/include
60 %{__make}
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64 install -d $RPM_BUILD_ROOT%{_mandir}
65
66 %{__make} install \
67         DESTDIR=$RPM_BUILD_ROOT
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %files
73 %{arch}
This page took 0.093935 seconds and 3 git commands to generate.