]> git.pld-linux.org Git - packages/crossmingw32-gcc.git/blobdiff - crossmingw32-gcc.spec
- allow override flags.
[packages/crossmingw32-gcc.git] / crossmingw32-gcc.spec
index fe73946243e472d60be811359fc789e0563592b9..ac2bfb9fc07fce6a4187eef5cb9de965a41a6661 100644 (file)
@@ -1,41 +1,45 @@
-%bcond_with     bootstrap
+#
+# Conditional build:
+%bcond_with    bootstrap       # bootstrap build (using binary w32api/mingw)
+#
 %define                DASHED_SNAP     %{nil}
 %define                SNAP            %(echo %{DASHED_SNAP} | sed -e "s#-##g")
-%define                GCC_VERSION     3.4.1
-%define        apiver  2.5
-%define        apisrc  w32api-%{apiver}
-%define runver 3.3
-%define        runsrc  mingw-runtime-%{runver}
+%define                GCC_VERSION     3.4.3
+%define                apiver          3.5
+%define                apisrc          w32api-%{apiver}
+%define                runver          3.9
+%define                runsrc          mingw-runtime-%{runver}
 Summary:       Cross Mingw32 GNU binary utility development utilities - gcc
 Summary(es):   Utilitarios para desarrollo de binarios de la GNU - Mingw32 gcc
 Summary(fr):   Utilitaires de développement binaire de GNU - Mingw32 gcc
 Summary(pl):   Skro¶ne narzêdzia programistyczne GNU dla Mingw32 - gcc
 Summary(pt_BR): Utilitários para desenvolvimento de binários da GNU - Mingw32 gcc
-Summary(tr):    GNU geliþtirme araçlarý - Mingw32 gcc
+Summary(tr):   GNU geliþtirme araçlarý - Mingw32 gcc
 Name:          crossmingw32-gcc
 Version:       %{GCC_VERSION}
-Release:       1
+Release:       4
 Epoch:         1
 License:       GPL
 Group:         Development/Languages
 Source0:       ftp://gcc.gnu.org/pub/gcc/releases/gcc-%{GCC_VERSION}/gcc-%{GCC_VERSION}.tar.bz2
-# Source0-md5: 31b459062499f9f68d451db9cbf3205c
+# Source0-md5: e744b30c834360fccac41eb7269a3011
 Source1:       http://dl.sourceforge.net/mingw/%{apisrc}.tar.gz
-# Source1-md5: be74d8925d1e273336ecb0d9225867f1
+# Source1-md5: 2529dffea94118865cdc06c1f7ead697
 Source2:       http://dl.sourceforge.net/mingw/%{runsrc}.tar.gz
-# Source2-md5: 49c4a72951cb34c86b7583970dc058e9
+# Source2-md5: 0cb66b1071da224ea2174f960c593e2e
 Patch0:                gcc-nodebug.patch
 Patch1:                %{name}-noioctl.patch
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: bison
-BuildRequires: crossmingw32-binutils >= 2.14.90.0.4.1-2
+BuildRequires: crossmingw32-binutils >= 2.15.91.0.2-2
 BuildRequires: flex
 %if %{without bootstrap}
-BuildRequires: crossmingw32-runtime >= 3.3
-BuildRequires: crossmingw32-w32api >= 2.5
+BuildRequires: crossmingw32-runtime >= 3.5
+BuildRequires: crossmingw32-w32api >= 3.1
 %endif
-Requires:      crossmingw32-binutils >= 2.14.90.0.4.1-2
+Requires:      crossmingw32-binutils >= 2.15.91.0.2-2
+Requires:      gcc-dirs
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                no_install_post_strip   1
@@ -72,7 +76,7 @@ Ten pakiet zawiera gcc generuj
 Summary:       Mingw32 binary utility development utilities - g++
 Summary(pl):   Zestaw narzêdzi mingw32 - g++
 Group:         Development/Languages
-Requires:      %{name} = %{epoch}:%{version}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description c++
 crossmingw32 is a complete cross-compiling development system for
@@ -98,7 +102,7 @@ libstdc++.
 Summary:       Mingw32 binary utility development utilities - objc
 Summary(pl):   Zestaw narzêdzi mingw32 - objc
 Group:         Development/Languages
-Requires:      %{name} = %{epoch}:%{version}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description objc
 crossmingw32 is a complete cross-compiling development system for
@@ -123,7 +127,7 @@ Ten pakiet zawiera kompilator objc generuj
 Summary:       Mingw32 binary utility development utilities - g77
 Summary(pl):   Zestaw narzêdzi mingw32 - g77
 Group:         Development/Languages
-Requires:      %{name} = %{epoch}:%{version}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description g77
 crossmingw32 is a complete cross-compiling development system for
@@ -148,7 +152,7 @@ Ten pakiet zawiera g77 generuj
 Summary:       Mingw32 binary utility development utilities - java
 Summary(pl):   Zestaw narzêdzi mingw32 - java
 Group:         Development/Languages
-Requires:      %{name} = %{epoch}:%{version}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description java
 crossmingw32 is a complete cross-compiling development system for
@@ -199,12 +203,12 @@ rm -rf obj-%{target_platform} && install -d obj-%{target_platform} && cd obj-%{t
 # note: alpha's -mieee and sparc's -mtune=* are not valid for target's g++
 CFLAGS="%{rpmcflags}" \
 %ifarch alpha
-CXXFLAGS="`echo '%{rpmcflags}' | sed -e 's/ \?-mieee\>//'`"  \
+CXXFLAGS="`echo '%{rpmcflags}' | sed -e 's/ \?-mieee\>//'`" \
 %else
 %ifarch sparc sparc64 sparcv9
 CXXFLAGS="`echo '%{rpmcflags}' | sed -e 's/ \?-mtune[=0-9a-z]*//'`" \
 %else
-CXXFLAGS="%{rpmcflags}"  \
+CXXFLAGS="%{rpmcflags}" \
 %endif
 %endif
 LDFLAGS="%{rpmldflags}" \
This page took 0.074218 seconds and 4 git commands to generate.