]> git.pld-linux.org Git - packages/crossmingw32-gcc.git/blame - crossmingw32-gcc.spec
- updated to 10.5.0
[packages/crossmingw32-gcc.git] / crossmingw32-gcc.spec
CommitLineData
a3bdc2a1 1#
2# Conditional build:
69291689 3%bcond_with bootstrap # bootstrap build (using binary w32api/mingwrt, only C/C++, no gomp)
46fc5303 4%bcond_without pthreads # POSIX threads support (needed for GOMP and C++ 11 thread/mutex support)
6ccf21dc 5%bcond_without gomp # OpenMP libraries
a3bdc2a1 6#
6ccf21dc 7%if %{with bootstrap}
46fc5303
JB
8%undefine with_pthreads
9%endif
10%if %{without pthreads}
6ccf21dc
JB
11%undefine with_gomp
12%endif
8c4c66e6
JB
13Summary: Cross MinGW32 GNU binary utility development utilities - gcc
14Summary(es.UTF-8): Utilitarios para desarrollo de binarios de la GNU - MinGW32 gcc
15Summary(fr.UTF-8): Utilitaires de développement binaire de GNU - MinGW32 gcc
16Summary(pl.UTF-8): Skrośne narzędzia programistyczne GNU dla MinGW32 - gcc
17Summary(pt_BR.UTF-8): Utilitários para desenvolvimento de binários da GNU - MinGW32 gcc
18Summary(tr.UTF-8): GNU geliştirme araçları - MinGW32 gcc
b336056d 19Name: crossmingw32-gcc
713797b9 20Version: 10.5.0
e1e2e047 21Release: 1
d3f237e2 22Epoch: 1
acb9fe67 23License: GPL v3+
d3f237e2 24Group: Development/Languages
da54ab64 25Source0: https://ftp.gnu.org/gnu/gcc/gcc-%{version}/gcc-%{version}.tar.xz
713797b9 26# Source0-md5: c7d1958570fbd1cd859b015774b9987a
0f000c5c
JB
27%define w32api_ver 5.4.2
28#Source1Download: https://osdn.net/projects/mingw/releases/
29Source1: https://osdn.net/projects/mingw/downloads/74926/w32api-%{w32api_ver}-mingw32-dev.tar.xz
30# Source1-md5: 88b0dc6185079e60d83bdbaec92028b8
31%define mingw32_ver 5.4.2
32#Source2Download: https://osdn.net/projects/mingw/releases/
33Source2: https://osdn.net/projects/mingw/downloads/74925/mingwrt-%{mingw32_ver}-mingw32-dev.tar.xz
34# Source2-md5: d8dceb05b85602eec82eac4e11d5c027
8b161635 35Source3: gcc-optimize-la.pl
0c9e92e0 36#Patch100: gcc-branch.diff
83afd976
ŁK
37Patch0: %{name}-buildsystem1.patch
38Patch1: %{name}-buildsystem2.patch
39Patch2: %{name}-lfs.patch
14b9b67e 40Patch3: gcc-mingw32.patch
da54ab64 41Patch4: gcc-build-libvtv.patch
46fc5303 42Patch5: gcc-pthreads-w32.patch
6ccf21dc 43URL: http://gcc.gnu.org/
669fa8b1 44BuildRequires: autoconf >= 2.64
14b9b67e 45BuildRequires: automake >= 1:1.11.1
d12aabe0 46BuildRequires: bison
45b14b32 47BuildRequires: crossmingw32-binutils >= 2.30
46fc5303 48%{?with_pthreads:BuildRequires: crossmingw32-pthreads-w32}
6ccf21dc
JB
49%if %{without bootstrap}
50BuildRequires: crossmingw32-runtime >= 3.5
cfcc9227 51BuildRequires: crossmingw32-w32api >= 1:5.4.2-3
6ccf21dc 52%endif
14b9b67e
JB
53BuildRequires: flex >= 2.5.4
54BuildRequires: gettext-tools >= 0.14.5
55BuildRequires: gmp-devel >= 4.3.2
da54ab64 56BuildRequires: isl-devel >= 0.15
14b9b67e 57BuildRequires: libmpc-devel >= 0.8.1
da54ab64 58BuildRequires: libstdc++-devel
45b14b32 59BuildRequires: mpfr-devel >= 3.1.0
207a380a 60BuildRequires: perl-tools-pod
73ff33c1 61BuildRequires: tar >= 1:1.22
da54ab64 62BuildRequires: texinfo >= 4.7
73ff33c1 63BuildRequires: xz
da54ab64 64BuildRequires: zlib-devel
14b9b67e 65BuildConflicts: pdksh < 5.2.14-50
45b14b32 66Requires: crossmingw32-binutils >= 2.30
6ab368b0 67Requires: gcc-dirs
14b9b67e 68Requires: gmp >= 4.3.2
da54ab64 69Requires: isl >= 0.15
14b9b67e 70Requires: libmpc >= 0.8.1
45b14b32 71Requires: mpfr >= 3.1.0
0c9e92e0
JB
72# java support dropped from gcc 7+
73Obsoletes: crossmingw32-java < 1:7
b336056d
JB
74BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
75
d3f237e2 76%define target i386-mingw32
8f1d5c0c 77%define sysprefix /usr
77399965
JB
78%define archprefix %{sysprefix}/%{target}
79%define archbindir %{archprefix}/bin
80%define archincludedir %{archprefix}/include
81%define archlibdir %{archprefix}/lib
73ff33c1
JB
82%define gccarchdir %{_libdir}/gcc/%{target}
83%define gcclibdir %{gccarchdir}/%{version}
84%define _dlldir /usr/share/wine/windows/system
dee9b92f 85
5b936a1d 86%define _noautostrip .*/lib.*\\.a
b336056d 87
66f480ce
JP
88%define _enable_debug_packages 0
89
45ff11c2
JR
90# functions with printf format attribute but with special parser and also
91# receiving non constant format strings
92%define Werror_cflags %{nil}
42fa9439 93%define _ssp_cflags %{nil}
c07647a9
JB
94# -fPIC is not valid for target platform
95%define filterout_c -fPIC
42fa9439 96
b336056d
JB
97%description
98crossmingw32 is a complete cross-compiling development system for
99building stand-alone Microsoft Windows applications under Linux using
8c4c66e6 100the MinGW32 build libraries. This includes a binutils, gcc with g++
b336056d
JB
101and objc, and libstdc++, all cross targeted to i386-mingw32, along
102with supporting Win32 libraries in 'coff' format from free sources.
103
d3f237e2 104This package contains cross targeted gcc.
b336056d 105
4a6c89d0 106%description -l de.UTF-8
107Dieses Paket enthält einen Cross-gcc, der es erlaubt, auf einem
108anderem Rechner Code für Win32 zu generieren.
9dd4c848 109
4a6c89d0 110%description -l pl.UTF-8
111crossmingw32 jest kompletnym systemem do kompilacji skrośnej,
112pozwalającym budować aplikacje MS Windows pod Linuksem używając
8c4c66e6 113bibliotek MinGW32. System składa się z binutils, gcc z g++ i objc,
4a6c89d0 114libstdc++ - wszystkie generujące kod dla platformy i386-mingw32, oraz
2e5b9011 115z bibliotek w formacie COFF.
d790a8ba 116
4a6c89d0 117Ten pakiet zawiera gcc generujące skrośnie kod dla Win32.
d790a8ba 118
73ff33c1
JB
119%package -n crossmingw32-libgcc-dll
120Summary: libgcc DLL library for Windows
121Summary(pl.UTF-8): Biblioteka DLL libgcc dla Windows
122Group: Applications/Emulators
123Requires: wine
124
125%description -n crossmingw32-libgcc-dll
126libgcc DLL library for Windows.
127
128%description -n crossmingw32-libgcc-dll -l pl.UTF-8
129Biblioteka DLL libgcc dla Windows.
130
14b9b67e
JB
131%package -n crossmingw32-libatomic
132Summary: The GNU Atomic library - cross MinGW32 version
133Summary(pl.UTF-8): Biblioteka GNU Atomic - wersja skrośna MinGW32
134License: GPL v3+ with GCC Runtime Library Exception v3.1
135Group: Development/Libraries
136Requires: %{name} = %{epoch}:%{version}-%{release}
137
138%description -n crossmingw32-libatomic
139This package contains cross MinGW32 version of the GNU Atomic library
140which is a GCC support library for atomic operations not supported by
141hardware.
142
143%description -n crossmingw32-libatomic -l pl.UTF-8
144Ten pakiet zawiera wersję skrośną MinGW32 biblioteki GNU Atomic,
145będącej biblioteką GCC, wspierającej operacje atomowe na sprzęcie ich
146nie obsługującym.
147
148%package -n crossmingw32-libatomic-static
149Summary: The GNU Atomic static library - cross MinGW32 version
150Summary(pl.UTF-8): Statyczna biblioteka GNU Atomic - wersja skrośna MinGW32
151License: GPL v3+ with GCC Runtime Library Exception v3.1
152Group: Development/Libraries
153Requires: crossmingw32-libatomic = %{epoch}:%{version}-%{release}
154
155%description -n crossmingw32-libatomic-static
156The GNU Atomic static library - cross MinGW32 version.
157
8bb997bf 158%description -n crossmingw32-libatomic-static -l pl.UTF-8
14b9b67e
JB
159Statyczna biblioteka GNU Atomic - wersja skrośna MinGW32.
160
161%package -n crossmingw32-libatomic-dll
162Summary: DLL GNU Atomic library for Windows
163Summary(pl.UTF-8): Biblioteka DLL GNU Atomic dla Windows
164License: GPL v3+ with GCC Runtime Library Exception v3.1
165Group: Applications/Emulators
166Requires: wine
167
168%description -n crossmingw32-libatomic-dll
169DLL GNU Atomic library for Windows.
170
171%description -n crossmingw32-libatomic-dll -l pl.UTF-8
172Biblioteka DLL GNU Atomic dla Windows.
173
6ccf21dc
JB
174%package -n crossmingw32-libgomp
175Summary: GNU OpenMP library - cross MinGW32 version
176Summary(pl.UTF-8): Biblioteka GNU OpenMP - wersja skrośna MinGW32
177License: GPL v3+ with GCC Runtime Library Exception v3.1
178Group: Development/Libraries
179Requires: %{name} = %{epoch}:%{version}-%{release}
180
181%description -n crossmingw32-libgomp
182This package contains cross MinGW32 version of GNU OpenMP library.
183
184%description -n crossmingw32-libgomp -l pl.UTF-8
185Ten pakiet zawiera wersję skrośną MinGW32 biblioteki GNU OpenMP.
186
187%package -n crossmingw32-libgomp-static
188Summary: Static GNU OpenMP library - cross MinGW32 version
189Summary(pl.UTF-8): Statyczna biblioteka GNU OpenMP - wersja skrośna MinGW32
190License: GPL v3+ with GCC Runtime Library Exception v3.1
191Group: Development/Libraries
192Requires: crossmingw32-libgomp = %{epoch}:%{version}-%{release}
193
194%description -n crossmingw32-libgomp-static
195Static GNU OpenMP library - cross MinGW32 version.
196
197%description -n crossmingw32-libgomp-static -l pl.UTF-8
198Statyczna biblioteka GNU OpenMP - wersja skrośna MinGW32.
199
200%package -n crossmingw32-libgomp-dll
201Summary: DLL GNU OpenMP library for Windows
202Summary(pl.UTF-8): Biblioteka DLL GNU OpenMP dla Windows
203License: GPL v3+ with GCC Runtime Library Exception v3.1
14b9b67e 204Group: Applications/Emulators
6ccf21dc 205Requires: crossmingw32-libgcc-dll = %{epoch}:%{version}-%{release}
e49d4dab 206Requires: crossmingw32-pthreads-w32-dll
6ccf21dc
JB
207
208%description -n crossmingw32-libgomp-dll
209DLL GNU OpenMP library for Windows.
210
211%description -n crossmingw32-libgomp-dll -l pl.UTF-8
212Biblioteka DLL GNU OpenMP dla Windows.
213
14b9b67e
JB
214%package -n crossmingw32-libvtv
215Summary: The Virtual Table Verification library - cross MinGW32 version
216Summary(pl.UTF-8): Biblioteka Virtual Table Verification do weryfikacji tablicy wirtualnej - wersja skrośna MinGW32
217License: GPL v3+ with GCC Runtime Library Exception v3.1
218Group: Development/Libraries
219URL: https://gcc.gnu.org/wiki/vtv
220Requires: %{name} = %{epoch}:%{version}-%{release}
221
222%description -n crossmingw32-libvtv
223This package contains cross MinGW32 version of the Virtual Table
224Verification library which is used for -fvtable-verify=...
225instrumented programs.
226
227%description -n crossmingw32-libvtv -l pl.UTF-8
228Ten pakiet zawiera wersję skrośną MinGW32 biblioteki Virtual Table
229Verification, służącej do weryfikacji tablicy wirtualnej w programach
230kompilowanych z opcją -fvtable-verify=....
231
232%package -n crossmingw32-libvtv-static
233Summary: The Virtual Table Verification static library - cross MinGW32 version
234Summary(pl.UTF-8): Statyczna biblioteka Virtual Table Verification - wersja skrośna MinGW32
235License: GPL v3+ with GCC Runtime Library Exception v3.1
236Group: Development/Libraries
237URL: https://gcc.gnu.org/wiki/vtv
238Requires: crossmingw32-libvtv = %{epoch}:%{version}-%{release}
239
240%description -n crossmingw32-libvtv-static
241The Virtual Table Verification static library - cross MinGW32 version.
242
243%description -n crossmingw32-libvtv-static -l pl.UTF-8
244Statyczna biblioteka Virtual Table Verification - wersja skrośna
245MinGW32.
246
247%package -n crossmingw32-libvtv-dll
248Summary: DLL Virtual Table Verification libraries for Windows
249Summary(pl.UTF-8): Biblioteki DLL Virtual Table Verification dla Windows
250License: GPL v3+ with GCC Runtime Library Exception v3.1
251Group: Applications/Emulators
252URL: https://gcc.gnu.org/wiki/vtv
253Requires: crossmingw32-libgcc-dll = %{epoch}:%{version}-%{release}
254
255%description -n crossmingw32-libvtv-dll
256DLL Virtual Table Verification libraries for Windows.
257
258%description -n crossmingw32-libvtv-dll -l pl.UTF-8
259Biblioteki DLL Virtual Table Verification dla Windows.
260
d3f237e2 261%package c++
8c4c66e6
JB
262Summary: MinGW32 binary utility development utilities - g++
263Summary(pl.UTF-8): Zestaw narzędzi MinGW32 - g++
d3f237e2 264Group: Development/Languages
cae974d4 265Requires: %{name} = %{epoch}:%{version}-%{release}
b336056d 266
d3f237e2
JB
267%description c++
268crossmingw32 is a complete cross-compiling development system for
269building stand-alone Microsoft Windows applications under Linux using
8c4c66e6 270the MinGW32 build libraries. This includes a binutils, gcc with g++
d3f237e2
JB
271and objc, and libstdc++, all cross targeted to i386-mingw32, along
272with supporting Win32 libraries in 'coff' format from free sources.
273
274This package contains cross targeted g++ and (static) libstdc++.
275
4a6c89d0 276%description c++ -l pl.UTF-8
277crossmingw32 jest kompletnym systemem do kompilacji skrośnej,
278pozwalającym budować aplikacje MS Windows pod Linuksem używając
8c4c66e6 279bibliotek MinGW32. System składa się z binutils, gcc z g++ i objc,
4a6c89d0 280libstdc++ - wszystkie generujące kod dla platformy i386-mingw32, oraz
2e5b9011 281z bibliotek w formacie COFF.
d790a8ba 282
4a6c89d0 283Ten pakiet zawiera g++ generujące kod pod Win32 oraz bibliotekę
d790a8ba
JB
284libstdc++.
285
73ff33c1
JB
286%package -n crossmingw32-libstdc++-static
287Summary: Static standard C++ library - cross MinGW32 version
288Summary(pl.UTF-8): Statyczna biblioteka standardowa C++ - wersja skrośna MinGW32
289Group: Development/Libraries
290Requires: %{name}-c++ = %{epoch}:%{version}-%{release}
291
292%description -n crossmingw32-libstdc++-static
293Static standard C++ library - cross MinGW32 version.
294
295%description -n crossmingw32-libstdc++-static -l pl.UTF-8
296Statyczna biblioteka standardowa C++ - wersja skrośna MinGW32.
297
298%package -n crossmingw32-libstdc++-dll
299Summary: libstdc++ DLL library for Windows
300Summary(pl.UTF-8): Biblioteka DLL libstdc++ dla Windows
301Group: Applications/Emulators
302Requires: crossmingw32-libgcc-dll = %{epoch}:%{version}-%{release}
303Requires: wine
304
305%description -n crossmingw32-libstdc++-dll
306libstdc++ DLL library for Windows.
307
308%description -n crossmingw32-libstdc++-dll -l pl.UTF-8
309Biblioteka DLL libstdc++ dla Windows.
310
d3f237e2 311%package objc
8c4c66e6
JB
312Summary: MinGW32 binary utility development utilities - objc
313Summary(pl.UTF-8): Zestaw narzędzi MinGW32 - objc
d3f237e2 314Group: Development/Languages
cae974d4 315Requires: %{name} = %{epoch}:%{version}-%{release}
d3f237e2
JB
316
317%description objc
318crossmingw32 is a complete cross-compiling development system for
319building stand-alone Microsoft Windows applications under Linux using
8c4c66e6 320the MinGW32 build libraries. This includes a binutils, gcc with g++
d3f237e2
JB
321and objc, and libstdc++, all cross targeted to i386-mingw32, along
322with supporting Win32 libraries in 'coff' format from free sources.
323
37948e2b 324This package contains cross targeted objc compiler.
d3f237e2 325
4a6c89d0 326%description objc -l pl.UTF-8
327crossmingw32 jest kompletnym systemem do kompilacji skrośnej,
328pozwalającym budować aplikacje MS Windows pod Linuksem używając
8c4c66e6 329bibliotek MinGW32. System składa się z binutils, gcc z g++ i objc,
4a6c89d0 330libstdc++ - wszystkie generujące kod dla platformy i386-mingw32, oraz
2e5b9011 331z bibliotek w formacie COFF.
d790a8ba 332
4a6c89d0 333Ten pakiet zawiera kompilator objc generujący kod pod Win32.
d790a8ba 334
14b9b67e
JB
335%package objc++
336Summary: MinGW32 binary utility development utilities - objc++
337Summary(pl.UTF-8): Zestaw narzędzi MinGW32 - objc++
338Group: Development/Languages
339Requires: %{name}-objc = %{epoch}:%{version}-%{release}
340
341%description objc++
342crossmingw32 is a complete cross-compiling development system for
343building stand-alone Microsoft Windows applications under Linux using
344the MinGW32 build libraries. This includes a binutils, gcc with g++
345and objc, and libstdc++, all cross targeted to i386-mingw32, along
346with supporting Win32 libraries in 'coff' format from free sources.
347
348This package contains Objective C++ support.
349
350%description objc++ -l pl.UTF-8
351crossmingw32 jest kompletnym systemem do kompilacji skrośnej,
352pozwalającym budować aplikacje MS Windows pod Linuksem używając
353bibliotek MinGW32. System składa się z binutils, gcc z g++ i objc,
354libstdc++ - wszystkie generujące kod dla platformy i386-mingw32, oraz
355z bibliotek w formacie COFF.
356
357Ten pakiet zawiera obsługę języka Objective C++.
358
8f1d5c0c
JB
359%package -n crossmingw32-libobjc-static
360Summary: Static Objective C library - cross MinGW32 version
361Summary(pl.UTF-8): Statyczna biblioteka Objective C - wersja skrośna MinGW32
362Group: Development/Libraries
363Requires: %{name}-objc = %{epoch}:%{version}-%{release}
364
365%description -n crossmingw32-libobjc-static
366Static Objective C library - cross MinGW32 version.
367
368%description -n crossmingw32-libobjc-static -l pl.UTF-8
369Statyczna biblioteka Objective C - wersja skrośna MinGW32.
370
371%package -n crossmingw32-libobjc-dll
372Summary: libobjc DLL library for Windows
373Summary(pl.UTF-8): Biblioteka DLL libobjc dla Windows
374Group: Applications/Emulators
375Requires: crossmingw32-libgcc-dll = %{epoch}:%{version}-%{release}
376Requires: wine
377
378%description -n crossmingw32-libobjc-dll
379libobjc DLL library for Windows.
380
381%description -n crossmingw32-libobjc-dll -l pl.UTF-8
382Biblioteka DLL libobjc dla Windows.
383
52a544a1 384%package fortran
8c4c66e6
JB
385Summary: MinGW32 binary utility development utilities - Fortran
386Summary(pl.UTF-8): Zestaw narzędzi MinGW32 - Fortran
d3f237e2 387Group: Development/Languages
cae974d4 388Requires: %{name} = %{epoch}:%{version}-%{release}
ed6b55ce 389Requires: crossmingw32-libquadmath = %{epoch}:%{version}-%{release}
07818e83 390Obsoletes: crossmingw32-gcc-g77 < 1:4
d3f237e2 391
52a544a1 392%description fortran
d3f237e2
JB
393crossmingw32 is a complete cross-compiling development system for
394building stand-alone Microsoft Windows applications under Linux using
8c4c66e6 395the MinGW32 build libraries. This includes a binutils, gcc with g++
d3f237e2
JB
396and objc, and libstdc++, all cross targeted to i386-mingw32, along
397with supporting Win32 libraries in 'coff' format from free sources.
398
37948e2b 399This package contains cross targeted Fortran compiler.
d3f237e2 400
4a6c89d0 401%description fortran -l pl.UTF-8
402crossmingw32 jest kompletnym systemem do kompilacji skrośnej,
403pozwalającym budować aplikacje MS Windows pod Linuksem używając
8c4c66e6 404bibliotek MinGW32. System składa się z binutils, gcc z g++ i objc,
4a6c89d0 405libstdc++ - wszystkie generujące kod dla platformy i386-mingw32, oraz
2e5b9011 406z bibliotek w formacie COFF.
d790a8ba 407
4a6c89d0 408Ten pakiet zawiera kompilator Fortranu generujący kod pod Win32.
d790a8ba 409
0d9cd0a8
JB
410%package -n crossmingw32-libgfortran-static
411Summary: Static Fortran library - cross MinGW32 version
6a795f6e 412Summary(pl.UTF-8): Statyczna biblioteka Fortranu - wersja skrośna MinGW32
0d9cd0a8
JB
413Group: Development/Libraries
414Requires: %{name}-fortran = %{epoch}:%{version}-%{release}
415
416%description -n crossmingw32-libgfortran-static
417Static Fortran library - cross MinGW32 version.
418
419%description -n crossmingw32-libgfortran-static -l pl.UTF-8
6a795f6e 420Statyczna biblioteka Fortranu - wersja skrośna MinGW32.
0d9cd0a8
JB
421
422%package -n crossmingw32-libgfortran-dll
423Summary: libgfortran DLL library for Windows
424Summary(pl.UTF-8): Biblioteka DLL libgfortran dla Windows
425Group: Applications/Emulators
b07ce80e 426Requires: crossmingw32-libquadmath-dll
0d9cd0a8
JB
427
428%description -n crossmingw32-libgfortran-dll
429libgfortran DLL library for Windows.
430
431%description -n crossmingw32-libgfortran-dll -l pl.UTF-8
432Biblioteka DLL libgfortran dla Windows.
433
b07ce80e
JB
434%package -n crossmingw32-libquadmath
435Summary: GCC __float128 support library - cross MinGW32 version
436Summary(pl.UTF-8): Biblioteka do obsługi typu __float128 - wersja skrośna MinGW32
437License: GPL v2+ with linking exception
438Group: Development/Libraries
439Requires: %{name} = %{epoch}:%{version}-%{release}
440
441%description -n crossmingw32-libquadmath
442This package contains cross MinGW32 version of GCC support library
443which is needed for __float128 math support and for Fortran REAL*16
444support.
445
446%description -n crossmingw32-libquadmath -l pl.UTF-8
447Ten pakiet zawiera wersję skrośną MinGW32 biblioteki GCC do obsługi
448operacji matematycznych na zmiennych typu __float128 oraz typu REAL*16
449w Fortranie.
450
451%package -n crossmingw32-libquadmath-static
452Summary: Static GCC __float128 support library - cross MinGW32 version
453Summary(pl.UTF-8): Biblioteka statyczna GCC do obsługi typu __float128 - wersja skrośna MinGW32
454License: GPL v2+ with linking exception
455Group: Development/Libraries
456Requires: crossmingw32-libquadmath = %{epoch}:%{version}-%{release}
457
458%description -n crossmingw32-libquadmath-static
459Static GCC __float128 support library - cross MinGW32 version.
460
461%description -n crossmingw32-libquadmath-static -l pl.UTF-8
462Biblioteka statyczna GCC do obsługi typu __float128 - wersja skrośna
463MinGW32.
464
465%package -n crossmingw32-libquadmath-dll
466Summary: DLL GCC __float128 support library for Windows
467Summary(pl.UTF-8): Biblioteka DLL GCC do obsługi typu __float128 dla Windows
468License: GPL v2+ with linking exception
469Group: Applications/Emulators
470Requires: wine
471
472%description -n crossmingw32-libquadmath-dll
473DLL GCC __float128 support library for Windows.
474
475%description -n crossmingw32-libquadmath-dll -l pl.UTF-8
476Biblioteka DLL GCC do obsługi typu __float128 dla Windows.
477
d3f237e2 478%prep
dee9b92f 479%setup -q -n gcc-%{version}
0c9e92e0 480#patch100 -p0
83afd976
ŁK
481%patch0 -p1
482%patch2 -p1
14b9b67e 483%patch3 -p1
da54ab64 484%patch4 -p1
46fc5303 485%patch5 -p1
83afd976 486
b399bc1a 487%if %{with bootstrap}
8b161635
JB
488# note: "winsup" dirs are special, handled by gcc's configure
489install -d winsup/{mingw,w32api}
490tar xf %{SOURCE1} -C winsup/w32api
491tar xf %{SOURCE2} -C winsup/mingw
69291689
JB
492# required by _mingw.h
493touch winsup/mingw/include/features.h
b399bc1a 494%endif
83afd976
ŁK
495
496# override snapshot version.
497echo %{version} > gcc/BASE-VER
498echo "release" > gcc/DEV-PHASE
b336056d
JB
499
500%build
da54ab64
JB
501cd libvtv
502%{__aclocal} -I .. -I ../config
503%{__autoconf}
504%{__automake}
505cd ..
506
73ff33c1 507rm -rf builddir && install -d builddir && cd builddir
b399bc1a 508%if %{with bootstrap}
73ff33c1 509install -d %{target}/winsup
73ff33c1 510ln -sf ../../../winsup/mingw/lib %{target}/winsup/mingw
8b161635 511ln -sf ../../../winsup/w32api %{target}/winsup/w32api
73ff33c1 512WINSUPDIR=$(cd ..; pwd)/winsup
b399bc1a
AF
513%endif
514
da54ab64 515# note: libbacktrace requires at least i486 now
83afd976 516CC="%{__cc}" \
b4c37c30 517CFLAGS="%{rpmcflags}" \
83afd976 518CXXFLAGS="%{rpmcxxflags}" \
b4c37c30 519TEXCONFIG=false \
da54ab64
JB
520CFLAGS_FOR_TARGET="-O2 -march=i486" \
521CXXFLAGS_FOR_TARGET="-O2 -march=i486" \
b336056d 522../configure \
8f1d5c0c 523 --prefix=%{sysprefix} \
77399965 524 --bindir=%{archbindir} \
73ff33c1 525 --libdir=%{_libdir} \
77399965 526 --includedir=%{archincludedir} \
a7ca5423 527 --libexecdir=%{_libdir} \
b336056d
JB
528 --infodir=%{_infodir} \
529 --mandir=%{_mandir} \
77399965
JB
530 --with-bugurl="http://bugs.pld-linux.org" \
531 --with-build-time-tools=%{archbindir} \
532 %{!?with_bootstrap:--with-headers=%{archincludedir}} \
533 --with-libs=%{!?with_bootstrap:%{archlibdir}}%{?with_bootstrap:${WINSUPDIR}/mingw/lib} \
14b9b67e 534 --with-demangler-in-ld \
83afd976
ŁK
535 --with-dwarf2 \
536 --with-gnu-as \
537 --with-gnu-ld \
83afd976 538 --with-long-double-128 \
77399965 539 --with-pkgversion="PLD-Linux" \
14b9b67e
JB
540 --enable-c99 \
541 --enable-fully-dynamic-string \
6ccf21dc 542 --disable-isl-version-check \
69291689
JB
543 --enable-languages="c,c++%{!?with_bootstrap:,fortran,objc,obj-c++}" \
544 %{?with_bootstrap:--disable-libatomic} \
14b9b67e
JB
545 --disable-libcc1 \
546 --enable-libgomp%{!?with_gomp:=no} \
69291689 547 %{?with_bootstrap:--disable-libquadmath} \
14b9b67e 548 --disable-libssp \
83afd976 549 --enable-libstdcxx-allocator=new \
69291689 550 %{?with_bootstrap:--disable-libvtv} \
14b9b67e 551 --enable-linker-build-id \
6ccf21dc 552 --enable-long-long \
14b9b67e 553 --enable-lto \
6ccf21dc 554 --disable-multilib \
0dcd3a97 555 --disable-nls \
da54ab64 556 --enable-shared \
83afd976 557 --disable-sjlj-exceptions \
6ccf21dc 558 --disable-symvers \
46fc5303 559 --enable-threads%{?with_pthreads:=posix} \
14b9b67e 560 --disable-werror \
83afd976 561 --disable-win32-registry \
b336056d
JB
562 --target=%{target}
563
83afd976
ŁK
564cd ..
565%{__make} -C builddir all-host
566patch -p1 <%{PATCH1}
567%{__make} -C builddir
b336056d
JB
568
569%install
b336056d 570rm -rf $RPM_BUILD_ROOT
73ff33c1 571install -d $RPM_BUILD_ROOT%{_bindir}
b336056d 572
83afd976 573%{__make} -C builddir install \
d12aabe0 574 DESTDIR=$RPM_BUILD_ROOT
b336056d 575
14b9b67e 576%{__mv} $RPM_BUILD_ROOT%{gcclibdir}/include-fixed/{limits,syslimits}.h $RPM_BUILD_ROOT%{gcclibdir}/include
73ff33c1
JB
577%{__rm} -r $RPM_BUILD_ROOT%{gcclibdir}/include-fixed
578%{__rm} -r $RPM_BUILD_ROOT%{gcclibdir}/install-tools
d12aabe0 579
82f2d40f 580# these must be symlinks: gcclibdir is calculated relatively to real binary path
77399965
JB
581ln -sf %{archbindir}/%{target}-gcc $RPM_BUILD_ROOT%{_bindir}/%{target}-gcc
582ln -sf %{archbindir}/%{target}-g++ $RPM_BUILD_ROOT%{_bindir}/%{target}-g++
583ln -sf %{archbindir}/%{target}-cpp $RPM_BUILD_ROOT%{_bindir}/%{target}-cpp
584ln -sf %{archbindir}/%{target}-gcov $RPM_BUILD_ROOT%{_bindir}/%{target}-gcov
585ln -sf %{archbindir}/%{target}-gcov-dump $RPM_BUILD_ROOT%{_bindir}/%{target}-gcov-dump
586ln -sf %{archbindir}/%{target}-gcov-tool $RPM_BUILD_ROOT%{_bindir}/%{target}-gcov-tool
77399965 587ln -sf %{archbindir}/%{target}-gfortran $RPM_BUILD_ROOT%{_bindir}/%{target}-gfortran
9ea34387 588ln -sf %{archbindir}/%{target}-lto-dump $RPM_BUILD_ROOT%{_bindir}/%{target}-lto-dump
83afd976 589
73ff33c1
JB
590# DLLs
591install -d $RPM_BUILD_ROOT%{_dlldir}
8b161635 592%{__mv} $RPM_BUILD_ROOT%{archlibdir}/*.dll $RPM_BUILD_ROOT%{_dlldir}
8f1d5c0c
JB
593if [ ! -f $RPM_BUILD_ROOT%{_dlldir}/libgcc_s_dw2-1.dll ]; then
594 echo "libgcc DLL not installed?"
595 install builddir/i386-mingw32/libgcc/shlib/libgcc_s_dw2-1.dll $RPM_BUILD_ROOT%{_dlldir}
596fi
d12aabe0 597
73ff33c1
JB
598%if 0%{!?debug:1}
599%{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
8b161635 600%{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{archlibdir}/lib*.a
d33f98c7 601%{target}-strip -g -R.comment -R.note $RPM_BUILD_ROOT%{gcclibdir}/lib*.a
73ff33c1 602%endif
83afd976 603
6ccf21dc 604# avoid -L poisoning in *.la
69291689 605%if %{without bootstrap}
8b161635
JB
606for f in libatomic.la libgfortran.la libobjc.la libquadmath.la %{?with_gomp:libgomp.la} ; do
607 file="$RPM_BUILD_ROOT%{archlibdir}/$f"
608 %{__perl} %{SOURCE3} "$file" %{gcclibdir} >"${file}.fixed"
609 %{__mv} "${file}.fixed" "$file"
610done
611for f in libcaf_single.la ; do
6ccf21dc 612 file="$RPM_BUILD_ROOT%{gcclibdir}/$f"
8b161635 613 %{__perl} %{SOURCE3} "$file" %{gcclibdir} >"${file}.fixed"
6ccf21dc
JB
614 %{__mv} "${file}.fixed" "$file"
615done
69291689 616%endif
6ccf21dc 617
b07ce80e 618# for pretty-printers see native gcc
8b161635 619%{__rm} $RPM_BUILD_ROOT%{archlibdir}/libstdc++.dll.a-gdb.py
b07ce80e 620%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/gcc-%{version}/python/libstdcxx
4b27d406
JB
621# no plugin development for mingw32 (at least for now)
622%{__rm} $RPM_BUILD_ROOT%{gcclibdir}/liblto_plugin.la
b07ce80e 623%{__rm} -r $RPM_BUILD_ROOT%{gcclibdir}/plugin
73ff33c1
JB
624# already in native gcc
625%{__rm} -r $RPM_BUILD_ROOT%{_infodir}
626# common FSF man pages
627%{__rm} $RPM_BUILD_ROOT%{_mandir}/man7/{fsf-funding,gfdl,gpl}.7
8c4c66e6 628
b336056d 629%clean
b336056d
JB
630rm -rf $RPM_BUILD_ROOT
631
632%files
633%defattr(644,root,root,755)
83afd976 634%attr(755,root,root) %{_bindir}/%{target}-gcc
b4c37c30 635%attr(755,root,root) %{_bindir}/%{target}-cpp
636%attr(755,root,root) %{_bindir}/%{target}-gcov
da54ab64 637%attr(755,root,root) %{_bindir}/%{target}-gcov-dump
14b9b67e 638%attr(755,root,root) %{_bindir}/%{target}-gcov-tool
9ea34387 639%attr(755,root,root) %{_bindir}/%{target}-lto-dump
17407f44 640%attr(755,root,root) %{archbindir}/%{target}-cpp
77399965
JB
641%attr(755,root,root) %{archbindir}/%{target}-gcc
642%attr(755,root,root) %{archbindir}/%{target}-gcc-%{version}
643%attr(755,root,root) %{archbindir}/%{target}-gcc-ar
644%attr(755,root,root) %{archbindir}/%{target}-gcc-nm
645%attr(755,root,root) %{archbindir}/%{target}-gcc-ranlib
77399965
JB
646%attr(755,root,root) %{archbindir}/%{target}-gcov
647%attr(755,root,root) %{archbindir}/%{target}-gcov-dump
648%attr(755,root,root) %{archbindir}/%{target}-gcov-tool
9ea34387 649%attr(755,root,root) %{archbindir}/%{target}-lto-dump
8b161635 650%{archlibdir}/libgcc_s.a
73ff33c1
JB
651%dir %{gccarchdir}
652%dir %{gcclibdir}
653%attr(755,root,root) %{gcclibdir}/cc1
654%attr(755,root,root) %{gcclibdir}/collect2
655%attr(755,root,root) %{gcclibdir}/lto-wrapper
4b27d406
JB
656%attr(755,root,root) %{gcclibdir}/lto1
657%attr(755,root,root) %{gcclibdir}/liblto_plugin.so*
73ff33c1
JB
658%{gcclibdir}/libgcc.a
659%{gcclibdir}/libgcc_eh.a
73ff33c1 660%{gcclibdir}/libgcov.a
00383376
AF
661%{gcclibdir}/crtbegin.o
662%{gcclibdir}/crtend.o
663%{gcclibdir}/crtfastmath.o
73ff33c1
JB
664%dir %{gcclibdir}/include
665%{gcclibdir}/include/*.h
539d7886 666%{_mandir}/man1/%{target}-cpp.1*
d3f237e2 667%{_mandir}/man1/%{target}-gcc.1*
539d7886 668%{_mandir}/man1/%{target}-gcov.1*
da54ab64
JB
669%{_mandir}/man1/%{target}-gcov-dump.1*
670%{_mandir}/man1/%{target}-gcov-tool.1*
9ea34387 671%{_mandir}/man1/%{target}-lto-dump.1*
d3f237e2 672
73ff33c1
JB
673%files -n crossmingw32-libgcc-dll
674%defattr(644,root,root,755)
675%{_dlldir}/libgcc_s_dw2-1.dll
676
69291689 677%if %{without bootstrap}
14b9b67e
JB
678%files -n crossmingw32-libatomic
679%defattr(644,root,root,755)
8b161635
JB
680%{archlibdir}/libatomic.dll.a
681%{archlibdir}/libatomic.la
14b9b67e
JB
682
683%files -n crossmingw32-libatomic-static
684%defattr(644,root,root,755)
8b161635 685%{archlibdir}/libatomic.a
14b9b67e
JB
686
687%files -n crossmingw32-libatomic-dll
688%defattr(644,root,root,755)
689%{_dlldir}/libatomic-1.dll
69291689 690%endif
14b9b67e 691
6ccf21dc
JB
692%if %{with gomp}
693%files -n crossmingw32-libgomp
694%defattr(644,root,root,755)
8b161635
JB
695%{archlibdir}/libgomp.dll.a
696%{archlibdir}/libgomp.la
697%{archlibdir}/libgomp.spec
6ccf21dc
JB
698
699%files -n crossmingw32-libgomp-static
700%defattr(644,root,root,755)
8b161635 701%{archlibdir}/libgomp.a
6ccf21dc
JB
702
703%files -n crossmingw32-libgomp-dll
704%defattr(644,root,root,755)
705%{_dlldir}/libgomp-1.dll
706%endif
707
69291689 708%if %{without bootstrap}
14b9b67e
JB
709%files -n crossmingw32-libvtv
710%defattr(644,root,root,755)
8b161635
JB
711%{archlibdir}/libvtv.dll.a
712%{archlibdir}/libvtv.la
713%{archlibdir}/libvtv_stubs.dll.a
714%{archlibdir}/libvtv_stubs.la
14b9b67e
JB
715
716%files -n crossmingw32-libvtv-static
717%defattr(644,root,root,755)
8b161635
JB
718%{archlibdir}/libvtv.a
719%{archlibdir}/libvtv_stubs.a
14b9b67e
JB
720
721%files -n crossmingw32-libvtv-dll
722%defattr(644,root,root,755)
723%{_dlldir}/libvtv-0.dll
724%{_dlldir}/libvtv_stubs-0.dll
69291689 725%endif
14b9b67e 726
d3f237e2
JB
727%files c++
728%defattr(644,root,root,755)
83afd976 729%attr(755,root,root) %{_bindir}/%{target}-g++
77399965
JB
730%attr(755,root,root) %{archbindir}/%{target}-c++
731%attr(755,root,root) %{archbindir}/%{target}-g++
73ff33c1 732%attr(755,root,root) %{gcclibdir}/cc1plus
8b161635
JB
733%{archlibdir}/libstdc++.dll.a
734%{archlibdir}/libstdc++.la
9ea34387
JB
735%{archlibdir}/libstdc++fs.a
736%{archlibdir}/libstdc++fs.la
8b161635
JB
737%{archlibdir}/libsupc++.la
738%{archlibdir}/libsupc++.a
739%{archincludedir}/c++
d3f237e2
JB
740%{_mandir}/man1/%{target}-g++.1*
741
73ff33c1
JB
742%files -n crossmingw32-libstdc++-static
743%defattr(644,root,root,755)
8b161635 744%{archlibdir}/libstdc++.a
73ff33c1
JB
745
746%files -n crossmingw32-libstdc++-dll
747%defattr(644,root,root,755)
748%{_dlldir}/libstdc++-6.dll
749
69291689 750%if %{without bootstrap}
d3f237e2
JB
751%files objc
752%defattr(644,root,root,755)
14b9b67e 753%doc libobjc/README
8f1d5c0c 754%attr(755,root,root) %{gcclibdir}/cc1obj
8b161635
JB
755%{archlibdir}/libobjc.dll.a
756%{archlibdir}/libobjc.la
8f1d5c0c 757%{gcclibdir}/include/objc
d3f237e2 758
14b9b67e
JB
759%files objc++
760%defattr(644,root,root,755)
761%doc gcc/objcp/ChangeLog
762%attr(755,root,root) %{gcclibdir}/cc1objplus
763
8f1d5c0c
JB
764%files -n crossmingw32-libobjc-static
765%defattr(644,root,root,755)
8b161635 766%{archlibdir}/libobjc.a
8f1d5c0c
JB
767
768%files -n crossmingw32-libobjc-dll
769%defattr(644,root,root,755)
669fa8b1 770%{_dlldir}/libobjc-4.dll
8f1d5c0c 771
52a544a1 772%files fortran
d3f237e2 773%defattr(644,root,root,755)
52a544a1 774%attr(755,root,root) %{_bindir}/%{target}-gfortran
77399965 775%attr(755,root,root) %{archbindir}/%{target}-gfortran
7f7a2048 776%attr(755,root,root) %{gcclibdir}/f951
8b161635
JB
777%{archlibdir}/libgfortran.dll.a
778%{archlibdir}/libgfortran.la
779%{archlibdir}/libgfortran.spec
0d9cd0a8 780%{gcclibdir}/finclude
669fa8b1
JB
781%{gcclibdir}/libcaf_single.a
782%{gcclibdir}/libcaf_single.la
52a544a1 783%{_mandir}/man1/%{target}-gfortran.1*
0d9cd0a8
JB
784
785%files -n crossmingw32-libgfortran-static
786%defattr(644,root,root,755)
8b161635 787%{archlibdir}/libgfortran.a
0d9cd0a8
JB
788
789%files -n crossmingw32-libgfortran-dll
790%defattr(644,root,root,755)
0f000c5c 791%{_dlldir}/libgfortran-5.dll
d3f237e2 792
b07ce80e
JB
793%files -n crossmingw32-libquadmath
794%defattr(644,root,root,755)
8b161635
JB
795%{archlibdir}/libquadmath.dll.a
796%{archlibdir}/libquadmath.la
b07ce80e
JB
797
798%files -n crossmingw32-libquadmath-static
799%defattr(644,root,root,755)
8b161635 800%{archlibdir}/libquadmath.a
b07ce80e
JB
801
802%files -n crossmingw32-libquadmath-dll
803%defattr(644,root,root,755)
804%{_dlldir}/libquadmath-0.dll
69291689 805%endif
This page took 0.318045 seconds and 4 git commands to generate.