]> git.pld-linux.org Git - packages/crossmingw32-freetype.git/commitdiff
- fix shared library creation
authorwolf <wolf@pld-linux.org>
Sat, 20 Oct 2007 22:12:34 +0000 (22:12 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    crossmingw32-freetype.spec -> 1.9

crossmingw32-freetype.spec

index 178df1a77c8b8e10d48adab0ea1ea1880e23eeaa..8fde50aa701cbc8ecf0cf651f7fee08777457168 100644 (file)
@@ -110,14 +110,59 @@ CFLAGS="%{rpmcflags} \
 
 %{__make}
 
+# link shared library
+cd objs/.libs
+%{__cc} \
+       --shared *.o -llualib50 -llua50 -lm -o libfreetype.dll \
+       -Wl,--enable-auto-image-base -Wl,--out-implib,libfreetype.dll.a -lz
+cd ../..
+
+cat << "EOF" >> libfreetype.la
+# libfreetype.la - a libtool library file
+# Generated by ltmain.sh - GNU libtool 1.5.22 (1.1220.2.365 2005/12/18 22:14:06)
+
+# The name that we can dlopen(3).
+dlname=''
+
+# Names of this library.
+library_names='libfreetype.dll.a'
+
+# The name of the static archive.
+old_library='libfreetype.a'
+
+# Libraries that this one depends upon.
+dependency_libs=' -lz'
+
+# Version information for libfreetype.
+current=9
+age=3
+revision=16
+
+# Is this an already installed library?
+installed=yes
+
+# Should we warn about portability when linking against -modules?
+shouldnotlink=no
+
+# Files to dlopen/dlpreopen
+dlopen=''
+dlpreopen=''
+
+# Directory that this library needs to be installed in:
+libdir='%{_libdir}'
+EOF
+
 %install
 rm -rf $RPM_BUILD_ROOT
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
+install libfreetype.la $RPM_BUILD_ROOT%{_libdir}
+
 install -d $RPM_BUILD_ROOT%{_dlldir}
-mv -f $RPM_BUILD_ROOT%{_prefix}/bin/*.dll $RPM_BUILD_ROOT%{_dlldir}
+install objs/.libs/libfreetype.dll $RPM_BUILD_ROOT%{_dlldir}
+install objs/.libs/libfreetype.dll.a $RPM_BUILD_ROOT%{_libdir}
 
 %if 0%{!?debug:1}
 %{target}-strip --strip-unneeded -R.comment -R.note $RPM_BUILD_ROOT%{_dlldir}/*.dll
@@ -132,6 +177,7 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %doc docs/{CHANGES,FTL.TXT,LICENSE.TXT,PATENTS,TODO,formats.txt,raster.txt}
+%{_bindir}/freetype-config
 %{_libdir}/libfreetype.dll.a
 %{_libdir}/libfreetype.la
 %{_includedir}/freetype2
@@ -144,4 +190,4 @@ rm -rf $RPM_BUILD_ROOT
 
 %files dll
 %defattr(644,root,root,755)
-%{_dlldir}/libfreetype-*.dll
+%{_dlldir}/libfreetype.dll
This page took 0.157876 seconds and 4 git commands to generate.