]> git.pld-linux.org Git - packages/crossmingw32-fontconfig.git/commitdiff
- updated to 2.10.91 (required by new stable pango) auto/th/crossmingw32-fontconfig-2.10.91-1
authorJakub Bogusz <qboosh@pld-linux.org>
Wed, 27 Mar 2013 17:32:20 +0000 (18:32 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Wed, 27 Mar 2013 17:32:20 +0000 (18:32 +0100)
- added mkstemp patch (fixes build on mingw32 due to missing mkstemp-like interfaces

crossmingw32-fontconfig.spec
fontconfig-mkstemp.patch [new file with mode: 0644]

index ffee673349b032e126cee427d3619a17cb1526dc..1361b14e151d5277fdc01b1872cd95ab2c6f4ecb 100644 (file)
@@ -2,14 +2,15 @@
 Summary:       Font configuration and customization tools - cross MinGW32 versoin
 Summary(pl.UTF-8):     Narzędzia do konfigurowania fontów - wersja skrośna dla MinGW32
 Name:          crossmingw32-%{realname}
-Version:       2.10.2
+Version:       2.10.91
 Release:       1
 License:       MIT
 Group:         Development/Libraries
-Source0:       http://fontconfig.org/release/%{realname}-%{version}.tar.gz
-# Source0-md5: 025e08b3d7fe45c433de5718e441ed15
+Source0:       http://fontconfig.org/release/%{realname}-%{version}.tar.bz2
+# Source0-md5: c795bb39fab3a656e5dff8bad6a199f6
 Patch0:                %{realname}-blacklist.patch
 Patch1:                %{realname}-bitstream-cyberbit.patch
+Patch2:                %{realname}-mkstemp.patch
 URL:           http://fontconfig.org/
 BuildRequires: autoconf >= 2.61
 BuildRequires: automake
@@ -85,6 +86,7 @@ Biblioteka DLL freetype dla Windows.
 %setup -q -n %{realname}-%{version}
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
 
 %build
 export PKG_CONFIG_LIBDIR=%{_prefix}/lib/pkgconfig
diff --git a/fontconfig-mkstemp.patch b/fontconfig-mkstemp.patch
new file mode 100644 (file)
index 0000000..58c2b8a
--- /dev/null
@@ -0,0 +1,29 @@
+From dffb69ed8c7cf2e707bc692f94b51108b772d9d8 Mon Sep 17 00:00:00 2001
+From: Akira TAGOH <akira@tagoh.org>
+Date: Tue, 15 Jan 2013 08:26:27 +0000
+Subject: Fix the build fail on MinGW
+
+Reported at http://lists.freedesktop.org/archives/fontconfig/2013-January/004601.html
+
+just warn at the runtime instead of the compile time. it somewhat works
+on even MinGW since FcMakeTempfile() isn't used on Win32 so far.
+---
+diff --git a/src/fccompat.c b/src/fccompat.c
+index 169cab9..2aa29dd 100644
+--- a/src/fccompat.c
++++ b/src/fccompat.c
+@@ -100,7 +100,11 @@ FcMakeTempfile (char *template)
+        return -1;
+    fd = FcOpen(template, O_RDWR | O_EXCL | O_CREAT, 0600);
+ #else
+-#error no secure functions to create a temporary file
++   /* warn at the runtime for just debugging purpose why something may
++    * goes wrong. mingw may not have one, but it shouldn't be reached since
++    * this function isn't used so far.
++    */
++   fprintf(stderr, "Fontconfig warning: No secure functions to create a temporary file\n");
+ #endif
+     return fd;
+--
+cgit v0.9.0.2-2-gbebe
This page took 0.133212 seconds and 4 git commands to generate.